Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя обработка, заполнение табличной части  (Прочитано 9292 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте. Есть документ Реализация товаров и услуг. Надо сделать обработку, чтобы при вызове обработки создавался документ Поступление товаров и услуг на основании документа Реализация. Как выгрузить табличную часть? У меня код ничего не заполняет:

Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) Экспорт
    Форма = Документы.ПоступлениеТоваровУслуг.ПолучитьФормуНовогоДокумента();
    Форма.Открыть();
ДокПоступление = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
ЗаполнитьЗначенияСвойств(ДокПоступление, Объект);
Для каждого Стр Из Объект.Товары Цикл
    НовСтр = ДокПоступление.Товары.Добавить();
    ЗаполнитьЗначениясвойств(НовСтр, Стр);
    КонецЦикла;
КонецПроцедуры

Подскажите, в чем ошибка, спасибо.

Последний раз редактировалось: MuI_I_Ika; 16 Окт 2012, 15:52


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Объект это документ Реализация товаров и услуг.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ДокПоступление = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
ЗаполнитьЗначенияСвойств(ДокПоступление, Объект);
ДокПоступление.Товары.Загрузить(Объект.Товары.Выгрузить());
ОткрытьЗначение(ДокПоступление);
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн AlenkaInt

  • ****
  • Сообщений: 266
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-21
  • Сайт: 
  • Профессия: Программист 1С
Спасибо. Я поняла в чем было дело. В том, что я форму не открывала. Добавила такую строку - ДокПоступление.ПолучитьФорму().Открыть();
И все заработало.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Здравствуйте. Есть документ Реализация товаров и услуг. Надо сделать обработку, чтобы при вызове обработки создавался документ Поступление товаров и услуг на основании документа Реализация. Как выгрузить табличную часть? У меня код ничего не заполняет:

Процедура Инициализировать(Объект, ИмяТабличнойЧасти, ТабличноеПолеОбъекта) Экспорт
    Форма = Документы.ПоступлениеТоваровУслуг.ПолучитьФормуНовогоДокумента();
    Форма.Открыть();
ДокПоступление = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
ЗаполнитьЗначенияСвойств(ДокПоступление, Объект);
Для каждого Стр Из Объект.Товары Цикл
    НовСтр = ДокПоступление.Товары.Добавить();
    ЗаполнитьЗначениясвойств(НовСтр, Стр);
    КонецЦикла;
КонецПроцедуры

Подскажите, в чем ошибка, спасибо.

Соответственно вот это:

    Форма = Документы.ПоступлениеТоваровУслуг.ПолучитьФормуНовогоДокумента();
    Форма.Открыть();

не надо ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8581
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Обработка "ПодборНоменклатуры"

Автор BigAnnРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2973
Последний ответ 18 Апр 2012, 20:38
от Dethmontt
Обработка "СогласованиеЗаявок"

Автор Денис АндрушкоРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 811
Последний ответ 24 Сен 2016, 00:37
от Денис Андрушко
заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3602
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1958
Последний ответ 20 Авг 2014, 12:22
от has

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 220
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal