Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Редактирование реквизитов справочника (помогите новичку)  (Прочитано 2602 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн borkhalenko

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-12
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, уважаемые форумчане. У меня такая проблема: хочу поменять значения реквизитов справочника "Валюты", если изменяется значение константы (тип константы: СправочникСсылка.Валюты). Сначала пробовал так:
Процедура ПриЗаписи(Отказ)
Выборка=Справочники.Валюты.Выбрать();
ТекущееЗначение=Константы.ОсновнаяВалюта.Получить();
Пока Выборка.Следующий() Цикл
Выборка.Курс=Выборка.Курс/ТекущееЗначение.Курс;
КонецЦикла;
КонецПроцедуры
пишет, что поле недоступно для редактирования. Понял, что Выборка.Курс - это не обьект, а ссылка, тоесть ее изменять нельзя. Везде пишут, что нужно сначала получить обьект, но когда пишу:
	Пока Выборка.Следующий() Цикл
Обьект=Выборка.ПолучитьОбьект();
Выборка.Курс=Выборка.Курс/ТекущееЗначение.Курс;
КонецЦикла;
пишет, что метод ПолучитьОбьект() недоступен.
Я совсем новичек в 1с, по-любому же туплю где-то или чего-то не понимаю. Помогите пожалуйста разобраться)))


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
смотрим в синтаксис-помощник и видим:

Пример:

Процедура УстановитьРеквизит(ИдСправочника, ИдРеквизита, 
        ЗначениеРеквизита, СтруктураДляОтбора)
    ВыборкаСправочника = Справочники[ИдСправочника].Выбрать(,,СтруктураДляОтбора);
    Пока ВыборкаСправочника.Следующий() Цикл
        Объект = ВыборкаСправочника.ПолучитьОбъект();
        Объект[ИдРеквизита] = ЗначениеРеквизита;
        Объект.Записать();
    КонецЦикла;
КонецПроцедуры

очевидно, если у вас все сделано как в примере, то все должно работать.

Добавлено: 12 Окт 2012, 12:31

другими словами, код у вас должен получиться приблизительно такой:
Процедура ПриЗаписи(Отказ)
Выборка=Справочники.Валюты.Выбрать();
ТекущееЗначение=Константы.ОсновнаяВалюта.Получить();
Пока Выборка.Следующий() Цикл
Обьект=Выборка.ПолучитьОбьект();       
Обьект.Курс=Выборка.Курс/ТекущееЗначение.Курс;
Обьект.Записать();
КонецЦикла;
КонецПроцедуры

Примечание: даю ответ ровно на ваш вопрос, не вникая в суть и правильность того эффекта, которого вы хотите этим кодом добиться, то есть исходя из предположения, что кроме проблемы с получением объекта вся остальная логика у вас верна.

Оффлайн borkhalenko

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-12
  • Сайт: 
  • Профессия: Ученик 1С
смотрим в синтаксис-помощник и видим:
Я этот помощник еще со вчерашнего дня изучаю)))
Примечание:
На счет логики - это не очень важно, так как конфигурация учебная. Мне главное - понять суть выборки и доступа (изменения) обьектов конфигурации.

По поводу
од у вас должен получиться приблизительно такой:
все равно не работает. Очевидно, у обьекта Справочники.Валюты нет метода ПолучитьОбьект(), или Выбрать() работает не так, как я думаю. Она же  возвращает ссылку на обьект?
Добавлено: 12 Окт 2012, 15:12

Вопрос решен, я вместо "ъ" написал "ь". Спасибо mixqn-у за помощь.

Последний раз редактировалось: borkhalenko; 12 Окт 2012, 15:12


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4290
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5546
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5882
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4361
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1975
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 342
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal