Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Июн 2018, 16:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Небольшая задачка  (Прочитано 2272 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Евгений90

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-03
  • Сайт: 
  • Профессия: Ученик 1С


Процедура ДействияФормыРаспределитьПоИФ(Кнопка)

   ОбработкаКомментариев = глЗначениеПеременной("глОбработкаСообщений");
   ОбработкаКомментариев.УдалитьСообщения();

   МассивТаблиц = Новый Массив;
   МассивТаблиц.Добавить(ОсновныеНачисленияПоИФ);
   МассивТаблиц.Добавить(ДополнительныеНачисленияПоИФ);
   ТекстВопроса1 = "Распределить начисления документа по источникам можно только после отмены его проведения. Продолжить?";
   ТекстВопроса2 = "Текущее распределение по источникам будет удалено. Продолжить?";
   Если НЕ РаботаСДиалогами.ЗаписатьДокументОчиститьТаблицыПередВыполнениемДействия(ДокументОбъект, ЭтаФорма, МассивТаблиц, ТекстВопроса1, ТекстВопроса2) Тогда
      ОбработкаКомментариев.ПоказатьСообщения();
      Возврат;
   КонецЕсли;
   
   РаспределитьНачисленияПоИсточникамФинансирования();   // Это процедура в модуле объекта
   
   ОбработкаКомментариев.ПоказатьСообщения();




Код для кнопки попробовал изменить, не выходит


Процедура ВыполнитьНажатие(Элемент)
   
      

   ДокументОбъект = Документы.РегистрацияРазовыхНачисленийРаботниковОрганизаций.ПолучитьФорму();
      ОбработкаКомментариев = глЗначениеПеременной("глОбработкаСообщений");
   ОбработкаКомментариев.УдалитьСообщения();    
   
   МассивТаблиц = Новый Массив;
   МассивТаблиц.Добавить(ДокументОбъект.РегистрацияРазовыхНачисленийРаботниковОрганизаций.ОсновныеНачисленияПоИФ);
   
   ТекстВопроса1 = "Распределить начисления документа по источникам можно только после отмены его проведения. Продолжить?";
   ТекстВопроса2 = "Текущее распределение по источникам будет удалено. Продолжить?";
   Если НЕ РаботаСДиалогами.ЗаписатьДокументОчиститьТаблицыПередВыполнениемДействия(ДокументОбъект, ЭтаФорма, МассивТаблиц, ТекстВопроса1, ТекстВопроса2) Тогда
      ОбработкаКомментариев.ПоказатьСообщения();
      Возврат;
   КонецЕсли;
   
   ДокументСписок.РегистрацияРазовыхНачисленийРаботниковОрганизаций.РаспределитьНачисленияПоИсточникамФинансирования ();   
     
   ОбработкаКомментариев.ПоказатьСообщения();
   КонецПроцедуры


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
В модуле объекта дописать к процедуре РаспределитьНачисленияПоИсточникамФинансирования() ЭКСПОРТ

В форме списка пишешь для твоей кнопки:
   
ТекущаяСтрока = ЭлементыФормы.ДокументСписок.ТекущиеДанные;
Если ТекущаяСтрока = Неопределено тогда
Возврат
КонецЕсли;
ОбъектДокумент = ТекущиеДанные.Ссылка.ПолучитьОбъект();
ОбъектДокумент.РаспределитьНачисленияПоИсточникамФинансирования();
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
126 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
118 Сообщений
alexandr_ll
65 Сообщений
pavl_vs
40 Сообщений
alex0402
28 Сообщений
buketov.av buketov.av
24 Сообщений
magnifico61
21 Сообщений
wise wise
16 Сообщений
ilyay ilyay
15 Сообщений
mixei
14 Сообщений

* Кто онлайн

  • Точка Гостей: 701
  • Точка Скрытых: 0
  • Точка Пользователей: 17
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal