Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 19:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выбор только нужных групп  (Прочитано 2835 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlexKag

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-05
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Скажите, в документе есть реквизит группа (СправочникСсылка.Группы). Там все группы от 1 курса до 4 курса. Но мне надо чтобы в данном документе в этом реквизите возможен был выбор только групп 4-х курсов. Как мне это реализовать??


Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
Справочник как организован?
skype: slin-dev

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1348
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
каким образом у вас различаются группы 1 курсов от групп 4 курсов? только по названию? если да, то сложно будет вашу задачу решить. добавьте в справочник группы реквизит курс и делайте по нему отбор в форме выбора.

Оффлайн AlexKag

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-05
  • Сайт: 
  • Профессия: Ученик 1С
Вот, посмотрите пожалуйста... в справочнике группы есть реквизит курс...  вот я запрос написал... только почему то выгрузка не происходит в данный реквизит.. или может тут не правильно??


Процедура ВыпуститьГруппуПриИзменении(Элемент)
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   группы.ссылка как группа
      |ИЗ
      |   Справочник.Группы КАК Группы
      |ГДЕ
      |   Группы.Курс = &Курс";

   Запрос.УстановитьПараметр("Курс", 4);
    Выборка=Запрос.Выполнить().Выбрать();
   Если Выборка.Следующий() Тогда
   Объект.Группа=Выборка.Группа;
   КонецЕсли;
КонецПроцедуры

Добавлено: 05 Окт 2012, 19:28

Вот структура справочника
Добавлено: 05 Окт 2012, 19:34

аа.. понял.. это немного не то... скажите а как отбор в форме выбора сделать?
Добавлено: 06 Окт 2012, 14:29

Вот сделал форму выбора но она почему то не работает.. скажите в чем ошибка?

Процедура ГруппаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   
СтандартнаяОбработка = Ложь;
ФормаВыбора = Справочники.Группы.ПолучитьФормуВыбора();
ФормаВыбора.Отбор.Курс.Установить(4);
ФормаВыбора.Открыть();
КонецПроцедуры

Последний раз редактировалось: AlexKag; 06 Окт 2012, 14:29


Теги:
 

как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1334
Последний ответ 13 Мар 2016, 00:55
от дфтын
Вид договора только "Прочие"

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 9424
Последний ответ 09 Сен 2013, 16:51
от 33lab
Лучший веб хостинг. Только лучшие хостинг провайдеры

Автор Joy12Раздел Беседка

Ответов: 0
Просмотров: 210
Последний ответ 16 Янв 2018, 12:34
от Joy12
1c 8.2: как установить ограничение на поле ввода на форме (вводить только диапазон цифр от 1 до 31) и как устанавливать фокус ввода

Автор jhd235Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4205
Последний ответ 12 Сен 2014, 14:14
от cska-fanat-kz
Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 802
Последний ответ 15 Май 2017, 08:59
от ZSS

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
ilyay ilyay
29 Сообщений
Анюта17
29 Сообщений
Alter
28 Сообщений

* Кто онлайн

  • Точка Гостей: 331
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal