Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поиск в массиве  (Прочитано 6231 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Seolkin

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-27
  • Сайт: 
В очередной раз поисковики мне не помогли.

Вот очень простенький код

&НаКлиенте
Процедура Команда1(Команда)
Массивчик=Новый Массив();
Массивчик.Вставить(0, "Ты кто");
Массивчик.Вставить(1, "Это была шутка?");
Массивчик.Добавить("Это ещё что?");
Если Массивчик.Найти("Это была шутка?")=Истина Тогда
Сообщить("Найдено");
Иначе
Сообщить("Не найдено");
КонецЕсли;
КонецПроцедуры


Почему-то отказывается находить первый Элемент в массиве. То есть, если попытаться найти "Это ещё что?" или "Это была шутка?", то появляется сообщение "Найдено", однако если попытаться найти "Ты кто", то результат "Не найдено". Пробовал изменить код на

&НаКлиенте
Процедура Команда1(Команда)
Массивчик=Новый Массив();
Массивчик.Добавить("Это ещё что?");
Массивчик.Вставить(1, "Ты кто");
Массивчик.Вставить(2, "Это была шутка?");
Если Массивчик.Найти("Это ещё что?")=Истина Тогда
Сообщить("Найдено");
Иначе
Сообщить("Ненайдено");
КонецЕсли;
КонецПроцедуры

Но тут он тогда "Ты кто" находит, а всё остальное нет. Не могу никак понять, почему?


Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
Re: Поиск в массиве
« Ответ #1: 04 Окт 2012, 22:44 »
А ответ очень простой :) Читаем, что пишет СП:
Цитировать
Найти (Find)
...
Возвращаемое значение:
Тип: Число; Неопределено.
Если элемент найден, возвращается его индекс. Если элемент не найден, возвращается Неопределено.
Дальше сами догадаетесь? ;)

Оффлайн Seolkin

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-27
  • Сайт: 
Re: Поиск в массиве
« Ответ #2: 04 Окт 2012, 23:12 »
Всё)) Спасибо. Понял глупость "Истины".  :D
Глянул внимательно справку и нашёл такое
Цитировать
Синтаксис:
Найти(<Значение>)
Параметры:
<Значение> (необязательный)

Как это "значение" может быть необязательным? При попытке выполнить такой код
Массивчик=Новый Массив();
Массивчик.Вставить(0, "Ты кто");
Массивчик.Вставить(1, "Это была шутка?");
Массивчик.Добавить("Это ещё что?");
Массивчик.Найти();

Выскакивает ошибка "Недостаточно фактических параметров". Вот и не пойму ни как - это ошибка справки или я опять что-то не понимаю?

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
Re: Поиск в массиве
« Ответ #3: 04 Окт 2012, 23:58 »
Ну, справку тоже люди пишут :) Иногда по пятницам, вечером :)

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Re: Поиск в массиве
« Ответ #4: 09 Окт 2012, 11:34 »
Массивчик=Новый Массив();
Массивчик.Вставить(0, "Ты кто");
Массивчик.Вставить(1, "Это была шутка?");
Массивчик.Добавить("Это ещё что?");
ЭлементМассива = Массивчик.Получить(1);


Теги:
 

Поиск в справочнике "Номенклатура" в УТ 11

Автор HolicРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1390
Последний ответ 08 Фев 2016, 20:53
от Holic
Поиск стандартных процедур модуля формы из другой формы.

Автор Дамир ТлеухановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 745
Последний ответ 18 Авг 2016, 11:50
от MuI_I_Ika
Как установить "Поиск по точному совпадению" по умолчанию?

Автор BulatsergРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1673
Последний ответ 16 Сен 2016, 14:58
от Bulatserg
Поиск и замена способа отражения расходов в документе Передача материалов в эксплуатацию

Автор Елена ПлаксинаРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 2560
Последний ответ 08 Авг 2015, 00:37
от Дмитрий@
Поиск в основной форме обработки ссылок на формирование табличной части

Автор Nail2010Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3531
Последний ответ 21 Дек 2010, 10:02
от Nail2010

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
43 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal