Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 20:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Массив  (Прочитано 2292 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Массив
« Первое сообщение: 04 Окт 2012, 13:35 »
Загружаю данные из xml в массив, а потом записываю в справочник.  Такой вопрос если в файле xml нет данных (<pr_live_settlement/>) в массив ничего не попадает как прописать чтобы он не ругался на отсутствие, а пропускал, спасибо, если нужно могу прислать код


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1348
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Re: Массив
« Ответ #1: 04 Окт 2012, 17:45 »
думаю, есть смысл прислать код (в том месте, где происходит ругань)

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Re: Массив
« Ответ #2: 05 Окт 2012, 09:44 »
 ЧтениеXML = Новый ЧтениеXML;
    ЧтениеXML.ОткрытьФайл(Файл);
    Имя = ЧтениеXML.Имя;
    Массив = Новый Структура(Имя);                                                     
    Пока ЧтениеXML.Прочитать() Цикл                 
        ПолучитьXMLТип(ЧтениеXML);
        Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента  Тогда
                       
            Имя = ЧтениеXML.Имя;
           
         //Сообщить("Начало " + ЧтениеXML.Имя);
            Пока ЧтениеXML.ПрочитатьАтрибут() Цикл
                Атрибут = ЧтениеXML.Значение;
            //Сообщить("атрибут:" + ЧтениеXML.Имя + "=" + ЧтениеXML.Значение);
            КонецЦикла;
        КонецЕсли;
       
        Если ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
            Массив.Вставить(Имя,ЧтениеXML.Значение);
         //Сообщить(ЧтениеXML.Значение);
        КонецЕсли;
   
        Если ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда
            Если ЧтениеXML.Имя = "CatalogObject.ФизическиеЛица" Тогда
            ДобавитьЭлемент(Массив);
            КонецЕсли;
         //Сообщить("Конец " + ЧтениеXML.Имя);
        КонецЕсли;
    КонецЦикла;

Вот код, как можно обойти элементы которые не попадают в массив???

Оффлайн Tyshkan

  • ***
  • Сообщений: 233
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-22
  • Сайт: 
  • Профессия: Программист 1С
Re: Массив
« Ответ #3: 08 Окт 2012, 16:18 »
помогите кто знает, как сделать добавление информации?? Т.е. вначале создаем физ лицо и заполняем всю информацию по нему, а потом из другого файла xml добавляем членов семьи...как сделать, не получается...


Теги:
 

Массив, Таблица значений и Список значений

Автор Константин163Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 7307
Последний ответ 25 Мар 2015, 16:02
от cska-fanat-kz
Как отлаживать запросы в консоли запросов, в которые нужно передавать массив?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3383
Последний ответ 26 Апр 2012, 10:28
от cska-fanat-kz
сделать из числа символьный массив (есть ли функция)

Автор Игорь1cРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 2804
Последний ответ 04 Дек 2014, 12:41
от Luzer1C
Не удается избавиться от ошибки если массив пустой

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1030
Последний ответ 19 Янв 2016, 09:09
от ktu78
Ссылка на файл или массив как параметр сеанса

Автор LeviathanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1962
Последний ответ 21 Июн 2011, 12:27
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
63 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
39 Сообщений
KOI8-R
36 Сообщений
Анюта17
33 Сообщений
Alter
30 Сообщений

* Кто онлайн

  • Точка Гостей: 271
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal