Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 03:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка при печати акта на списание в требование-накладной  (Прочитано 3925 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dimaadidas

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-03
  • Сайт: 
  • Профессия: Программист 1С
Добрый день. При печати в требование-накладной акта на списание или требование - накладной М-11 сообщает ошибку с которой не получается разобраться, так как программирую в 1с недавно. наведите на правильный выход, а то не понимаю, где искать проблему. Есть предположение, что нужно что-то править в учетной политике. Конфигурация Бухгалтерия для беларуси 8.2


ОбщийМодуль.БухгалтерскийУчет(2917)}: Ошибка при вызове метода контекста (Выполнить): {(8, 2)}: Неверные параметры "РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто"
<<?>>РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
ПроводкиДокумента = Запрос.Выполнить().Выгрузить();
по причине:
{(8, 2)}: Неверные параметры "РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто"
<<?>>РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(

Вот сам модуль на который ругается

Функция ПолучитьСуммуСписанияАктивов(ТекДокумент) Экспорт

УчетнаяПолитикаНеЗадана = Ложь;
мУчетнаяПолитика = ОбщегоНазначения.ПолучитьПараметрыУчетнойПолитики(ТекДокумент.Дата, УчетнаяПолитикаНеЗадана, ТекДокумент.Организация, "Бух");
мВалютаРегламентированногоУчета  = Константы.ВалютаРегламентированногоУчета.Получить();
мУчетПоСредней = Ложь;
Если  мУчетнаяПолитика.Количество()>0 И мУчетнаяПолитика["СпособОценкиМПЗ"]= Перечисления.СпособыОценки.ПоСредней  Тогда
мУчетПоСредней = Истина;
КонецЕсли;

ПроводкиДокумента = Новый ТаблицаЗначений;
ПроводкиДокумента.Колонки.Добавить("Номенклатура");
ПроводкиДокумента.Колонки.Добавить("Количество");
ПроводкиДокумента.Колонки.Добавить("Сумма");
ТаблицаСуммСписания = Новый ТаблицаЗначений;
ТаблицаСуммСписания.Колонки.Добавить("Номенклатура");
ТаблицаСуммСписания.Колонки.Добавить("Партия");
ТаблицаСуммСписания.Колонки.Добавить("Количество");
ТаблицаСуммСписания.Колонки.Добавить("Сумма");
Если ТекДокумент.Проведен Тогда
ТекстЗапроса =
"ВЫБРАТЬ
| ХозрасчетныйДвиженияССубконто.СубконтоКт1 КАК СубконтоКт1,
| ХозрасчетныйДвиженияССубконто.СубконтоКт2 КАК СубконтоКт2,
| СУММА(ХозрасчетныйДвиженияССубконто.КоличествоКт) КАК КоличествоКт,
| СУММА(ХозрасчетныйДвиженияССубконто.Сумма) КАК Сумма,
| ХозрасчетныйДвиженияССубконто.СубконтоКт3
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
| &ДатаНач,
| &ДатаКон,
| Регистратор = &Регистратор
| И (НЕ СчетКт = &СчетГТД),
| ,
| ) КАК ХозрасчетныйДвиженияССубконто
|
|СГРУППИРОВАТЬ ПО
| ХозрасчетныйДвиженияССубконто.СубконтоКт1,
| ХозрасчетныйДвиженияССубконто.СубконтоКт2,
| ХозрасчетныйДвиженияССубконто.СубконтоКт3";

Запрос = Новый Запрос;
Запрос.Текст = ТекстЗапроса;
Запрос.УстановитьПараметр("ДатаНач", ТекДокумент.Дата);
Запрос.УстановитьПараметр("ДатаКон", ТекДокумент.Дата);
Запрос.УстановитьПараметр("Регистратор", ТекДокумент.Ссылка);
Запрос.УстановитьПараметр("СчетГТД", ПланыСчетов.Хозрасчетный.ГТД);

ПроводкиДокумента = Запрос.Выполнить().Выгрузить();
Для Каждого ПроводкаДокумента Из ПроводкиДокумента Цикл
Если ТипЗнч(ПроводкаДокумента.СубконтоКт1) = Тип("СправочникСсылка.Номенклатура") Тогда
Строка = ТаблицаСуммСписания.Добавить();
Строка.Номенклатура = ПроводкаДокумента.СубконтоКт1;
Если ТипЗнч(ПроводкаДокумента.СубконтоКт2) = Тип("СправочникСсылка.Партии") Тогда
Строка.Партия       = ПроводкаДокумента.СубконтоКт2;
ИначеЕсли ТипЗнч(ПроводкаДокумента.СубконтоКт3) = Тип("СправочникСсылка.Партии") Тогда
Строка.Партия       = ПроводкаДокумента.СубконтоКт3;
КонецЕсли;
Строка.Количество   = ПроводкаДокумента.КоличествоКт;
Строка.Сумма        = ПроводкаДокумента.Сумма;
КонецЕсли;
Если ТипЗнч(ПроводкаДокумента.СубконтоКт2) = Тип("СправочникСсылка.Номенклатура") Тогда
Строка = ТаблицаСуммСписания.Добавить();
Строка.Номенклатура = ПроводкаДокумента.СубконтоКт2;
Строка.Количество   = ПроводкаДокумента.КоличествоКт;
Строка.Сумма        = ПроводкаДокумента.Сумма;
КонецЕсли;

КонецЦикла;

Если мУчетПоСредней ТОгда
ТаблицаСуммСписания.Свернуть("Номенклатура","Количество,Сумма");
Иначе
ТаблицаСуммСписания.Свернуть("Номенклатура, Партия","Количество,Сумма");
КонецЕсли;

КонецЕсли;

Возврат  ТаблицаСуммСписания;



КонецФункции



Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
код очень очень похож на не типовой!
Запрос в конструкторе открывается?
Зачем задавать параметры "ДатаНач" и "ДатаКон" если ты жестко отбираешь по регистратору???????????
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Зачем инициализировать переменную и заполнять ее если ты ее потом затираешь???
       
ПроводкиДокумента = Новый ТаблицаЗначений;
        ПроводкиДокумента.Колонки.Добавить("Номенклатура");
        ПроводкиДокумента.Колонки.Добавить("Количество");
        ПроводкиДокумента.Колонки.Добавить("Сумма");
ПроводкиДокумента = Запрос.Выполнить().Выгрузить();
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Попробуй зайти в параметры виртуальной таблицы и удалить параметры ДатаНач и ДатаКон
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн dimaadidas

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-10-03
  • Сайт: 
  • Профессия: Программист 1С
код очень очень похож на не типовой!
Запрос в конструкторе открывается?
Зачем задавать параметры "ДатаНач" и "ДатаКон" если ты жестко отбираешь по регистратору???????????

нет не открывается, сообщает ту же ошибку . Да код немного отличается от типовой.
Добавлено: 03 Окт 2012, 23:20

Я заменил в запросе
РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
            |            &ДатаНач,
            |            &ДатаКон,
            |            Регистратор = &Регистратор
            |                И (НЕ СчетКт = &СчетГТД),
            |            ,
            |            ) КАК ХозрасчетныйДвиженияССубконто

на вот это

РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(&ДатаНач, &ДатаКон, Регистратор = &Регистратор И (НЕ СчетКт = &СчетГТД)) КАК ХозрасчетныйДвиженияССубконто

Запрос стал открываться и формируется печатная форма, но в ней поле сумма пустое, так должно быть?

Последний раз редактировалось: dimaadidas; 03 Окт 2012, 23:20

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
МНЕ ТОЧНО не известно как должно быть =)))
И это можно удалить:

 
      ПроводкиДокумента = Новый ТаблицаЗначений;
        ПроводкиДокумента.Колонки.Добавить("Номенклатура");
        ПроводкиДокумента.Колонки.Добавить("Количество");
        ПроводкиДокумента.Колонки.Добавить("Сумма");
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4530
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6087
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4199
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8502
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8563
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 178
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal