Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите найти ошибку  (Прочитано 1368 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн beztrud

1с 8.2 управляемое приложение. Вот код который работает:
&НаКлиенте
Процедура Расчет(Команда)
Элементы.Результат.ДобавитьСтроку();
СтрокаТабличнойЧасти=Элементы.Результат.ТекущиеДанные;
СтрокаТабличнойЧасти.ВысотаВставки=Объект.ВысотаШкафа-
Объект.Цоколь-Объект.Подпятник-
Объект.Горизонталь-Объект.Крышка-
Объект.Треки-Объект.ГоризонтальныйПрофиль;
Если Объект.КоличествоСтворок=2 Тогда
СтрокаТабличнойЧасти.ШиринаВставки=
Цел(((Объект.ШиринаШкафа-
Объект.ТолщинаБоков+Объект.Перехлест)/2)-
КонецЕсли;
Если Объект.КоличествоСтворок=4 Тогда
СтрокаТабличнойЧасти.ШиринаВставки=
Цел((((Объект.ШиринаШкафа-
Объект.ТолщинаБоков+(Объект.Перехлест*2))/3))-
Объект.ВертикальныйПрофиль);
КонецЕсли;
КонецПроцедуры
Если добавить в форму реквизит ТипКупе - Перечисления ТипКупе и написать условие при котором данный код отрабатывается только при условии, что Объекту ТипКупе присвоено значение перечисления Обычный и сделать отработку на сервере, то ошибок не выдает, но и табличная часть не заполняется. Вот пример неработающего кода:
&НаСервере
Процедура Расчет(Команда)
Если Объект.ТипКупе=Перечисления.ТипКупе.Обычный Тогда
Элементы.Результат.ДобавитьСтроку();
СтрокаТабличнойЧасти=Элементы.Результат.ТекущиеДанные;
СтрокаТабличнойЧасти.ВысотаВставки=Объект.ВысотаШкафа-
Объект.Цоколь-Объект.Подпятник-
Объект.Горизонталь-Объект.Крышка-
Объект.Треки-Объект.ГоризонтальныйПрофиль;
Если Объект.КоличествоСтворок=2 Тогда
СтрокаТабличнойЧасти.ШиринаВставки=
Цел(((Объект.ШиринаШкафа-
Объект.ТолщинаБоков+Объект.Перехлест)/2)-
КонецЕсли;
Если Объект.КоличествоСтворок=4 Тогда
СтрокаТабличнойЧасти.ШиринаВставки=
Цел((((Объект.ШиринаШкафа-
Объект.ТолщинаБоков+(Объект.Перехлест*2))/3))-
Объект.ВертикальныйПрофиль);
КонецЕсли;
КонецЕсли;
КонецПроцедуры


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
ну правильно. На сервере вы заполнили, а на форму, что на клиенте, не передали.
Смотреть функцию "ЗначениеВРеквизитФормы"

пример: ЗначениеВРеквизитФормы(ДокОбъект, "Объект");


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ТекущиеДанные
не доступны на сервере

Может как то так?

&НаКлиенте
Процедура Расчет(Команда)
Если Объект.ТипКупе = ПолучитьЗначениеПеречисления("ТипКупе","Обычный") Тогда
Элементы.Результат.ДобавитьСтроку();   
СтрокаТабличнойЧасти=Элементы.Результат.ТекущиеДанные;
СтрокаТабличнойЧасти.ВысотаВставки=Объект.ВысотаШкафа-
Объект.Цоколь-Объект.Подпятник-
Объект.Горизонталь-Объект.Крышка-
Объект.Треки-Объект.ГоризонтальныйПрофиль;
Если Объект.КоличествоСтворок=2 Тогда
СтрокаТабличнойЧасти.ШиринаВставки=
Цел(((Объект.ШиринаШкафа-
Объект.ТолщинаБоков+Объект.Перехлест)/2)-
КонецЕсли;       
Если Объект.КоличествоСтворок=4 Тогда
СтрокаТабличнойЧасти.ШиринаВставки=
Цел((((Объект.ШиринаШкафа-
Объект.ТолщинаБоков+(Объект.Перехлест*2))/3))-
Объект.ВертикальныйПрофиль);
КонецЕсли;
КонецЕсли;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьЗначениеПеречисления(Менеджер,ЗначениеПеречисления)

    Возврат Перечисления[Менеджер][ЗначениеПеречисления];

КонецФункции
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4294
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5891
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4374
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
43 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal