Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 09:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Прикрепить изображение к документу  (Прочитано 7490 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
Ребята, очень нужно прикрепить скан к документу Поступление товаров и услуг... но навыки не позволяют написать с нуля :(
У кого нибудь есть примеры написания подобных обработок (с выбором изображение в диалоговом окне и последующее хранение изображение в ХранилищеЗначений? или может уже реализовывали
подобное?

на подобии http://katalog.forum-1c.ru/public/72536/ только в 8.2
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Думаю быстрее будет загуглить и реализовать самому.

Оффлайн Gendelf

  • ***
  • Сообщений: 228
  • РЕПУТАЦИЯ: 2
  • КПД: 1%
  • Регистрация: 2010-11-10
  • Сайт: 
вот как раз и проблемы с реализацией
Логика приведёт вас от А к В. Воображение доставит вас куда угодно.
Сайт про аквариум, аквариумные рыбки и аквариумные растения http://myaquainfo.ru/

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
В чем проблема именно? Что пытались сделать, что не получается?

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Вам надо будет:
1. Создать кнопку на форме, по которой будет вызываться процедура показанная ниже.

2. Внести этот код в форму вашего документа
Процедура ДействияФормыФайлы(Кнопка)
   
   Если НЕ РаботаСДиалогами.ЗаписатьНовыйОбъектВФорме(ЭтаФорма) Тогда
      Возврат;
   КонецЕсли;
   
   СтруктураДляСпискаИзображдений = Новый Структура("ОтборОбъектИспользование, ОтборОбъектЗначение, ДоступностьОтбораОбъекта, ВидимостьКолонкиОбъекта", Истина, Ссылка, Ложь, Ложь);
   СтруктураДляСпискаДополнительныхФайлов = Новый Структура("ОтборОбъектИспользование, ОтборОбъектЗначение, ДоступностьОтбораОбъекта, ВидимостьКолонкиОбъекта", Истина, Ссылка, Ложь, Ложь);
   ОбязательныеОтборы = Новый Структура("Объект", Ссылка);
   
   РаботаСФайлами.ОткрытьФормуСпискаФайловИИзображений(СтруктураДляСпискаИзображдений, СтруктураДляСпискаДополнительныхФайлов, ОбязательныеОтборы, ЭтаФорма);

КонецПроцедуры

Всех делов на 5 минут с перекурами.


Но вынужден предупредить, что если документов будет много, тогда база будет очень быстро расти. Есть другой способ немного сложнее, кода больше надо писать, но зато очень действенный.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
chuevsf - красавчик!!!
Я о типовом механизме - даже и не подумал =)))
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн mainer

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-05-28
  • Сайт: 
  • Профессия: Ученик 1С
Вам надо будет:
1. Создать кнопку на форме, по которой будет вызываться процедура показанная ниже.

2. Внести этот код в форму вашего документа
Процедура ДействияФормыФайлы(Кнопка)
   
   Если НЕ РаботаСДиалогами.ЗаписатьНовыйОбъектВФорме(ЭтаФорма) Тогда
      Возврат;
   КонецЕсли;
   
   СтруктураДляСпискаИзображдений = Новый Структура("ОтборОбъектИспользование, ОтборОбъектЗначение, ДоступностьОтбораОбъекта, ВидимостьКолонкиОбъекта", Истина, Ссылка, Ложь, Ложь);
   СтруктураДляСпискаДополнительныхФайлов = Новый Структура("ОтборОбъектИспользование, ОтборОбъектЗначение, ДоступностьОтбораОбъекта, ВидимостьКолонкиОбъекта", Истина, Ссылка, Ложь, Ложь);
   ОбязательныеОтборы = Новый Структура("Объект", Ссылка);
   
   РаботаСФайлами.ОткрытьФормуСпискаФайловИИзображений(СтруктураДляСпискаИзображдений, СтруктураДляСпискаДополнительныхФайлов, ОбязательныеОтборы, ЭтаФорма);

КонецПроцедуры

Всех делов на 5 минут с перекурами.


Но вынужден предупредить, что если документов будет много, тогда база будет очень быстро расти. Есть другой способ немного сложнее, кода больше надо писать, но зато очень действенный.
Вам надо будет:
1. Создать кнопку на форме, по которой будет вызываться процедура показанная ниже.

2. Внести этот код в форму вашего документа
Процедура ДействияФормыФайлы(Кнопка)
   
   Если НЕ РаботаСДиалогами.ЗаписатьНовыйОбъектВФорме(ЭтаФорма) Тогда
      Возврат;
   КонецЕсли;
   
   СтруктураДляСпискаИзображдений = Новый Структура("ОтборОбъектИспользование, ОтборОбъектЗначение, ДоступностьОтбораОбъекта, ВидимостьКолонкиОбъекта", Истина, Ссылка, Ложь, Ложь);
   СтруктураДляСпискаДополнительныхФайлов = Новый Структура("ОтборОбъектИспользование, ОтборОбъектЗначение, ДоступностьОтбораОбъекта, ВидимостьКолонкиОбъекта", Истина, Ссылка, Ложь, Ложь);
   ОбязательныеОтборы = Новый Структура("Объект", Ссылка);
   
   РаботаСФайлами.ОткрытьФормуСпискаФайловИИзображений(СтруктураДляСпискаИзображдений, СтруктураДляСпискаДополнительныхФайлов, ОбязательныеОтборы, ЭтаФорма);

КонецПроцедуры

Всех делов на 5 минут с перекурами.


Но вынужден предупредить, что если документов будет много, тогда база будет очень быстро расти. Есть другой способ немного сложнее, кода больше надо писать, но зато очень действенный.

Сделал также, но пишет что не определена переменная "РаботСДиалогами"


Оффлайн megret

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-03-18
  • Сайт: 
  • Профессия: Ученик 1С
Ребята! Почти такая-же проблема, только нужно к бизнес-процессу (по кнопке) прикрепить PDF. Перепробывал различные варианты, но что-то не идёт. Форма обычная! Heeelp!


Теги:
 

Префикс документу "ГГГГММДД/"

Автор NuuqРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2178
Последний ответ 02 Мар 2010, 06:48
от Slin
Нужно добавить к документу "Оригинал получен"

Автор ZnNuРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 738
Последний ответ 27 Окт 2016, 08:37
от alexandr_ll
ЗУП внешняя печатная к документу "Зарплата к выплате организации"

Автор kuza_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3280
Последний ответ 10 Май 2012, 12:47
от kuza_87
Указана сумма предоплаты (сделка: не указана) больше возможной по документу на 200 грн

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1705
Последний ответ 20 Апр 2016, 01:59
от ktu78
Отчет преобразовать из встроенного во внешний, если он прикреплен к документу

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 181
Последний ответ 21 Ноя 2017, 11:06
от kiksi

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
alexandr_ll
24 Сообщений

* Кто онлайн

  • Точка Гостей: 197
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal