Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 01:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Записать в Excel  (Прочитано 3287 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Seolkin

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-27
  • Сайт: 
Здравствуйте! Пытаюсь Загрузить в базу информацию из Excel и наткунлся на проблему - не пойму как загружать данные в реквизиты, которые не находятся в "Объект". Можете пожалуйста пояснить, как в данном примере через "Бланки" обратиться к реквизитам "Логин" и "Пароль"? (Я новичок, так что пожалуйста сильно не пинайте за вопрос)

Процедура Команда1(Команда)
   Попытка
   Эксель=Новый COMОбъект("Excel.Application");
Исключение
   Сообщить(ОписаниеОшибки());
   Возврат;
КонецПопытки;
Книга=Эксель.WorkBooks.Open("N:\Бланки.xls");
Лист=Книга.WorkSheets("Пользователи");
ВсегоСтрок=Лист.Cells(1,1).SpecialCells(11).Row;
Для Счётчик=2 по ВсегоСтрок Цикл
   ЗначениеФИО=Лист.Cells(Счётчик,1).Value;
   ЗначениеЛогин=Лист.Cells(Счётчик,4).Value;
   ЗначениеПароль=Лист.Cells(Счётчик,5).Value;
   Если ЗначениеЗаполнено(ЗначениеФИО)=Истина Тогда
   Бланки=Справочники.БланкиПользователей.СоздатьЭлемент();
   Бланки.Наименование=ЗначениеФИО;
   Бланки.Логин=ЗначениеЛогин;
   Элементы.Пароль=ЗначениеПароль;

   Бланки.Записать();
КонецЕсли;         
КонецЦикла;
Эксель.Application.Quit();
КонецПроцедуры


Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
Re: Записать в Excel
« Ответ #1: 27 Сен 2012, 10:53 »
Не
   Элементы.Пароль=ЗначениеПароль;
а
   Бланки.Пароль=ЗначениеПароль;

Оффлайн Seolkin

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-27
  • Сайт: 
Re: Записать в Excel
« Ответ #2: 27 Сен 2012, 11:35 »
Увы, не работает. Пишет что поле не обнаружено.
Но всё же решил проблему.  В свойствах формы во вкладке "Данные" добавил реквизиты, а те что можно увидеть на скриншоте - удалил.

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Re: Записать в Excel
« Ответ #3: 27 Сен 2012, 12:04 »
а вы заполняете в справочник не открывая формы? Посмотрите куму принадлежат эти поля, какому справочнику! может они принадлежа подчиненному справочнику?   
Помогли, отблагодари!


Теги:
 

Круглый стол "Автоматизация учета и отчетности по МСФО: Excel против программных продуктов"

Автор mixqnРаздел Мероприятия

Ответов: 0
Просмотров: 1692
Последний ответ 10 Сен 2014, 10:25
от mixqn
работа с файлами excel открытие файла xls, чтение данных и запись нового файла xls

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2797
Последний ответ 11 Фев 2016, 12:49
от Rasty
Внешняя компонента для прямого чтения файлов Excel всех версий

Автор CrazyDaveРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2100
Последний ответ 01 Мар 2012, 16:23
от CrazyDave
Не создается COM объект Excel.Application, хотя всё установлено и права есть

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 7168
Последний ответ 23 Июл 2015, 14:25
от vitasw
Алгоритм загрузки изображений из excel по ссылке URL в реквизит основное изображение

Автор nikioioioРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 992
Последний ответ 23 Мар 2016, 05:43
от nikioioio

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 162
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal