Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 17:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Форма элемента в Управляемом Приложении  (Прочитано 11357 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Помогите нужно сделать вот такую форму элемента в УП.
Кнопки не хотят выстраиваться вряд, если кто знает как это сделать. ПОМОГИТЕ!!!!!!!!!!!!!!!



Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
При помощи групп
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Это форма обработки, и группы эти я уже как только не переставлял и настраивал не чего не получается.
Если не сложно сделайте форму обработки из кнопок в УП.
А то я уже с ума с хожу с этими кнопками.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
??????
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Респект и Уважуха тебе дружище!!!!

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Подскажите как мне теперь сделать так чтоб когда нажимаешь на эти кнопки в реквизите печатались цифры.
Я пока додумался только до вот этого
&НаКлиенте
Процедура Команда1(Команда)
Объект.Телефон = 1;
КонецПроцедуры

&НаКлиенте
Процедура Команда2(Команда)
Объект.Телефон = 2;
КонецПроцедуры

И то когда нажимаешь "Кнопка 1" появляется "цифра 1"
А когда нажимаешь "Кнопка 2" то первая цифра стирается и появляется "цифра 2"
Туплю не пойму как сделать!!!!!

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура Команда1(Команда)
Объект.Телефон = 1;
КонецПроцедуры

&НаКлиенте
Процедура Команда2(Команда)
Объект.Телефон = 2;
КонецПроцедуры
Ну а этот способ не работает?

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура Команда1(Команда)
   Объект.Телефон = Объект.Телефон + 1;
КонецПроцедуры

&НаКлиенте
Процедура Команда2(Команда)
   Объект.Телефон = Объект.Телефон + 2;
КонецПроцедуры

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
&НаКлиенте
Процедура Команда1(Команда)
   Объект.Телефон = Объект.Телефон + 1;
КонецПроцедуры

&НаКлиенте
Процедура Команда2(Команда)
   Объект.Телефон = Объект.Телефон + 2;
КонецПроцедуры

При этом способе он цифры складывает!!!

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
При этом способе он цифры складывает!!!
Ну так сделай реквизит Телефон типа 'Строка'


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 737
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal