Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 17:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Префикс  (Прочитано 5099 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Folomsha

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Префикс
« Первое сообщение: 25 Сен 2012, 10:51 »
Подскажите, пожалуйста, как во внешней форме, в строке "основание" убрать префикс из номера счета?
Т.е. сейчас номер счета выглядит так: М000000223, а хотелось бы, чтобы было просто 223.


Оффлайн ИгорьШпак

  • **
  • Сообщений: 98
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2012-04-04
  • Сайт: 
  • Профессия: Программист 1С
Re: Префикс
« Ответ #1: 25 Сен 2012, 11:01 »
А как этот номер заполняется?

Оффлайн Folomsha

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Re: Префикс
« Ответ #2: 25 Сен 2012, 11:03 »
Просто берется номер документа реализации. Номера документов у клиентов - с префиксом. Вот я и думаю, можно ли его как-нибудь "откусить"?

Оффлайн ИгорьШпак

  • **
  • Сообщений: 98
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2012-04-04
  • Сайт: 
  • Профессия: Программист 1С
Re: Префикс
« Ответ #3: 25 Сен 2012, 11:09 »
Все можно)  Самое простое это тупо перебором и условиями отобрать нужное вам. Но это очень несерьезно. Вдруг у вас будет номер М1110981 к примеру .. или еще какие - нибудь исключительные ситуации

Оффлайн ИгорьШпак

  • **
  • Сообщений: 98
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2012-04-04
  • Сайт: 
  • Профессия: Программист 1С
Re: Префикс
« Ответ #4: 25 Сен 2012, 11:14 »
Поэтому и спрашиваю как именно заполняется

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
Re: Префикс
« Ответ #5: 25 Сен 2012, 11:29 »
>> Вот я и думаю, можно ли его как-нибудь "откусить"?

Как вариант:
Функция ОткуситьНеЦифры(вхСтрока)
Длина = СтрДлина(вхСтрока);
Для i = 1 По Длина Цикл
ТекущийСимвол = КодСимвола(Сред(вхСтрока, i , 1));
Если ТекущийСимвол > 48 И  ТекущийСимвол < 58 Тогда
Возврат Прав(вхСтрока, Длина - i + 1);
КонецЕсли;
КонецЦикла;
КонецФункции

Можно её легко доработать, чтобы удаляла не только начальные 'нецифры', но вообще все во входной строке...

Оффлайн ИгорьШпак

  • **
  • Сообщений: 98
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2012-04-04
  • Сайт: 
  • Профессия: Программист 1С
Re: Префикс
« Ответ #6: 25 Сен 2012, 12:19 »
Тут много лишнего на мой взгляд...я только начинающий программист 1С )))) Так что если у тебя формат такого рода М00000ХХХХ тогда я б сделал вот так:


   Строка1 = СокрЛП(ПолеВвода2);   
   КоличествоСимволов = СтрДлина(СокрЛП(ПолеВвода2));
   Сообщить(КоличествоСимволов);
   Для Первый = 1 По КоличествоСимволов Цикл
      Если Лев(СокрЛП(Строка1),1) = "0" Тогда        
         Строка1 = Число(Строка1);
         Прервать;
      Иначе
         Строка1 = Прав(Строка1,КоличествоСимволов-Первый);           
      КонецЕсли;          
   КонецЦикла;
   Сообщить(Строка1);


Но это только для такого вида ХХ 00000 YYYY, гдн ХХ - идет любое количество различных БУКВ , далее идут нули и после ХХ- любое количество цифр

Оффлайн ИгорьШпак

  • **
  • Сообщений: 98
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2012-04-04
  • Сайт: 
  • Профессия: Программист 1С
Re: Префикс
« Ответ #7: 25 Сен 2012, 12:19 »
Но это бред!!!!

Оффлайн ИгорьШпак

  • **
  • Сообщений: 98
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2012-04-04
  • Сайт: 
  • Профессия: Программист 1С
Re: Префикс
« Ответ #8: 25 Сен 2012, 12:20 »
ах да - поле ввода - это поле с вашим номером

Оффлайн ИгорьШпак

  • **
  • Сообщений: 98
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2012-04-04
  • Сайт: 
  • Профессия: Программист 1С
Re: Префикс
« Ответ #9: 25 Сен 2012, 12:21 »
Хотя Ваш код помойму покорректнее)))


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 761
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal