Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 23:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение табличной части документа  (Прочитано 6153 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AlexKag

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-05
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!
Возник такой вопрос. Есть справочник ученики, в котором есть ученики и группа (допустим). И есть документ зачисление. В Документе есть табличная часть, и реквизит группа. Нужно в документе установив в реквизите какую-то группу, нажать кнопку заполнить и в табличной части выводится список всех учеников по этой группе. Подскажите пожалуйста в написании кода, с чего вообще надо начать? Сам документ и справочник созданы и готовы к работе. Помогите пожалуйста с кодом


Оффлайн dimalf

  • **
  • Сообщений: 62
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-13
  • Сайт: 
  • Профессия: Программист 1С
Создайте справочник или перечисление "ГРУППЫ" и реквизит ученикам "ГРУППА", являющийся ссылкой на этот справочник (перечисление). Делайте запрос по этому реквизиту и заполняйте нужными учениками табличную часть.

Оффлайн AlexKag

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-05
  • Сайт: 
  • Профессия: Ученик 1С
Хорошо, запрос допустим сделал... а куда его записывать? просто хотелось бы на документе иметь кнопку что-то типа "Заполнить" при нажатии на которую и заполнялась бы ТЧ документа?

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Напишу кусок кода минут через 30, если раньше никто не ответит. Сейчас с телефона не удобно...

Оффлайн AlexKag

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-05
  • Сайт: 
  • Профессия: Ученик 1С
Буду очень благодарен!

Оффлайн dimalf

  • **
  • Сообщений: 62
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-13
  • Сайт: 
  • Профессия: Программист 1С
В процедуру ПРИНАЖАТИИ() на эту кнопку

Оффлайн AlexKag

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-05
  • Сайт: 
  • Профессия: Ученик 1С
Сразу скажи Справочник "Студенты" не иерархический, там просто есть реквизит такой - группа. И документ "Зачисление", с названием табличной части "Студенты", в этой табличной части есть 1 реквизит - "студент" (СправочникСсылка.Студенты). А также в документе есть реквизит Группа (СправочникСсылка. Группы), собственно мы в этом реквизите выбираем группу, нажимаем видимо на команду "Заполнить", и в этой табличной части студенты появляются.. вот механизм.. а как сделать не совсем еще понимаю

Оффлайн AlexKag

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-05
  • Сайт: 
  • Профессия: Ученик 1С
Сделал вот такой запрос на форме документа. Но почему то при нажатии на кнопку "заполнить" у меня в ТЧ заполняются только номера студентов.. а поле куда сам студент должен выводится пустое остается.. в чем ошибка подскажите пожалуйста??


&НаКлиенте
Процедура Заполнить(Команда)
   ЗаполнитьТабличнуюЧасть()
КонецПроцедуры

Процедура ЗаполнитьТабличнуюЧасть()
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Студенты.Ссылка
      |ИЗ
      |   Справочник.Студенты КАК Студенты
      |ГДЕ
      |   Студенты.Группа = &Группа";
 Запрос.УстановитьПараметр("Группа", Объект.Группа);
  Объект.Студенты.Загрузить(Запрос.Выполнить().Выгрузить());
  КонецПроцедуры

Оффлайн AlexKag

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-05
  • Сайт: 
  • Профессия: Ученик 1С
Вот собственно это выходит

Оффлайн AlexKag

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-05
  • Сайт: 
  • Профессия: Ученик 1С
Все.. я с этим разобрался.. Там в запросе добавить "...как студент" надо было.
Если не сложно подскажите еще с таким вот вопросом, в справочнике студенты, есть реквизит СтатусСтудента, а в документе "Зачисление" есть поле флажка "Зачислить студента" (это булево) Когда я делал документ с одним всего реквизитом, где указывал 1 студента, и нажимал на флажок и проводил документ у меня статус менялся в справочнике на соответствующий... А вот как теперь сделать так чтобы допустим у этого же документа, но вот с этой вот табличной частью с множеством студентов, также ставить галочку и чтобы у всех студентов менялся статус, то есть массово.. Просто объясните принцип или с кодом, если сможете помогите, хотя старый код можно по образцу изменить, просто вот как поменять массово статус с этой же галочкой.. ?? Вот примерно такой вопрос...

вот код для 1 студента..


Процедура ОбработкаПроведения(Отказ, Режим)
Если Зачислить Тогда
   Студенты = Студент.ПолучитьОбъект();
   Студенты.СтатусСтудента = Перечисления.СтатусСтудента.Учится;
   Студенты.Записать();
КонецЕсли;
КонецПроцедуры


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4481
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7751
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4787
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8534
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7345
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 177
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal