Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 01:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сопоставление артикулов.  (Прочитано 2149 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн slavabatov

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-12
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
Подскажите, пожалуйста, как решить такую задачу.
Есть парсер, он выводит данные в табличную часть, как отметить цветом те позиции которые имеются в собственном Справочнике Номенклатура, причем, например, зеленым те которые имеются в наличии, а желтым просто которые присутствуют в Справочнике, без выделения остальные.
Спасибо.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Обычное или управляемое приложение?

Для обычного:
Раскрашивать строки в ТабличнойЧасти можно только из двух событий

ПриПолученииДанных(Элемент, ОформленияСтрок)

и

ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
//Например
    Если ДанныеСтроки = Неопределено Тогда
        Возврат;
    КонецЕсли;
   
    Если ДанныеСтроки.БольшеСтаСимволов Тогда
        ОформлениеСтроки.ЦветФона = WebЦвета.Желтый;
    КонецЕсли;
   
    Если ЗначениеЗаполнено(ДанныеСтроки.Номенклатура) Тогда
        ОформлениеСтроки.ЦветФона = WebЦвета.Зеленый;
    КонецЕсли;
 
 
Аналогично и для ячейки:

ОформлениеСтроки.Ячейки.Сотрудник.ЦветФона = WebЦвета.Зеленый;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
А в управляемом можн с помощью условного оформления. И даже код писать не нужно :)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Угу.
Но можно и кодом...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Сопоставление номенклатуры и организаций с данными ЕГАИС в Розница 2.2.8.27

Автор Practic75Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 222
Последний ответ 20 Май 2018, 05:59
от Геннадий ОбьГЭС
Сопоставление значения, полученного из двух запросов

Автор dsidentРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 33
Просмотров: 11643
Последний ответ 19 Апр 2011, 15:15
от Klyacksa
Сопоставление контрагента и контактной информации

Автор user003Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 556
Последний ответ 08 Янв 2017, 18:40
от дфтын
Сопоставление организаций при Обмене м/у БУ и УТ

Автор iceman2112Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5046
Последний ответ 15 Ноя 2011, 22:03
от Dethmontt
Сопоставление при объединении конфигураций

Автор АЛ1Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 850
Последний ответ 17 Сен 2015, 08:51
от ls600

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
ilyay ilyay
29 Сообщений
Анюта17
29 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 176
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal