Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 22:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сопоставление артикулов.  (Прочитано 1831 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн slavabatov

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-12
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
Подскажите, пожалуйста, как решить такую задачу.
Есть парсер, он выводит данные в табличную часть, как отметить цветом те позиции которые имеются в собственном Справочнике Номенклатура, причем, например, зеленым те которые имеются в наличии, а желтым просто которые присутствуют в Справочнике, без выделения остальные.
Спасибо.


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Обычное или управляемое приложение?

Для обычного:
Раскрашивать строки в ТабличнойЧасти можно только из двух событий

ПриПолученииДанных(Элемент, ОформленияСтрок)

и

ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
//Например
    Если ДанныеСтроки = Неопределено Тогда
        Возврат;
    КонецЕсли;
   
    Если ДанныеСтроки.БольшеСтаСимволов Тогда
        ОформлениеСтроки.ЦветФона = WebЦвета.Желтый;
    КонецЕсли;
   
    Если ЗначениеЗаполнено(ДанныеСтроки.Номенклатура) Тогда
        ОформлениеСтроки.ЦветФона = WebЦвета.Зеленый;
    КонецЕсли;
 
 
Аналогично и для ячейки:

ОформлениеСтроки.Ячейки.Сотрудник.ЦветФона = WebЦвета.Зеленый;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
А в управляемом можн с помощью условного оформления. И даже код писать не нужно :)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Угу.
Но можно и кодом...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
AIFrame
64 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 286
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal