Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 06:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Картинки в 1С  (Прочитано 7227 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Народ объяснить кто нибудь, есть самописная конфигурация.
Надо к справочнику номенклатуру в ручную подгружать картинки. Не пойму как это сделать.
Может кто объяснить по порядку, как это сделать?


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Re: Картинки в 1С
« Ответ #1: 06 Сен 2012, 16:47 »
А кто тебе подскажет не виде и не зная как и что реализовано в вашей конфигурации! В типовой надо просто нажать левой кнопкой на место прикрепление картинки! Это в 8.2 УТ11!
Помогли, отблагодари!

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Re: Картинки в 1С
« Ответ #2: 06 Сен 2012, 19:59 »
Я же написал конфа самописная.
Мне надо чтоб кто то объяснил, как с нуля загружать картинки в 1С. т.е. создать справочник, создать реквизит какой описать там код и т.д.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Картинки в 1С
« Ответ #3: 06 Сен 2012, 20:20 »
Ну скачай какую-нибудь типовую конфу (УТ, УПП, БП, ЗУП и т.д.) и посмотри как это реализовано там...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Re: Картинки в 1С
« Ответ #4: 06 Сен 2012, 22:28 »
Я вот в эти конфы гляжу и не чего не пойму!!!!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Картинки в 1С
« Ответ #5: 06 Сен 2012, 22:37 »
Тогда чем мы можем тебе помочь?
Конкретизируй что тебе не понятно, постараемся тут разобрать более детально...

Первое на что ты должен себе ответить - это как(где) ты собрался хранить свои картинки (Предполагаю два варианта: 1. В базе данных; 2. В каком либо каталоге на жестком диске)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Re: Картинки в 1С
« Ответ #6: 07 Сен 2012, 09:29 »
Если хранить картинки в базе, на сколько сильно её может раздуть?

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Картинки в 1С
« Ответ #7: 07 Сен 2012, 11:29 »
Смотря какого объема картинки будут загружаться и сколько их будет))
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн beztrud

Re: Картинки в 1С
« Ответ #8: 07 Сен 2012, 14:38 »
Примерно такие коды. Разбирайся, если нужно пришлю конфигурацию.
&НаКлиенте
Процедура ЗагрузитьСДиска(Команда)

АдресВХранилище = "";
ВыбранноеИмяФайла = "";

Если ПоместитьФайл(АдресВХранилище, , ВыбранноеИмяФайла, , УникальныйИдентификатор) Тогда

Файл = Новый Файл(ВыбранноеИмяФайла);

ИмяФайлаКартинки = Файл.Имя;
СсылкаНаКартинку = АдресВХранилище;

Модифицированность = Истина;

КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура СохранитьНаДиск(Команда)

Если Объект.ИмяФайлаКартинки = "" Тогда
Предупреждение("У товара нет сохраненной в базе картинки");

Иначе
СсылкаНаФайлВИБ = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ФайлКартинки");
ПолучитьФайл(СсылкаНаФайлВИБ, Объект.ИмяФайлаКартинки);
КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

// Получить файл из хранилища и поместить его в объект
Если ЭтоАдресВременногоХранилища(СсылкаНаКартинку) Тогда
ДвоичныеДанные = ПолучитьИзВременногоХранилища(СсылкаНаКартинку);
ТекущийОбъект.ФайлКартинки = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных(9));

ТекущийОбъект.ИмяФайлаКартинки = ИмяФайлаКартинки;
КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

// Удалить файл из временного хранилища
Если ЭтоАдресВременногоХранилища(СсылкаНаКартинку) Тогда
УдалитьИзВременногоХранилища(СсылкаНаКартинку);
СсылкаНаКартинку = ПолучитьНавигационнуюСсылку(ТекущийОбъект.Ссылка, "ФайлКартинки");

КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Если Объект.ИмяФайлаКартинки <> "" Тогда
СсылкаНаКартинку = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ФайлКартинки");

КонецЕсли;

КонецПроцедуры


Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Re: Картинки в 1С
« Ответ #9: 08 Сен 2012, 20:53 »
Пришлите конфу.
Вот ящик Pavel.Znaikin@yandex.ru


Теги:
 

Проблема с "Полем картинки" в мобильной платформе

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1990
Последний ответ 25 Июл 2015, 09:05
от TreeDogNight
Вставка картинки в реквизит табличной части справочника с типом хранилище значения

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1722
Последний ответ 20 Сен 2015, 13:27
от ktu78
1C 8.3 управляемые формы вставка HTML файла в форматированный документ, не вставляются картинки

Автор Putilin007Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1885
Последний ответ 24 Мар 2016, 17:08
от Putilin007
Проблема с вставкой открытой картинки в реквизит формы типа ХранилищеДанных

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 925
Последний ответ 17 Сен 2015, 14:04
от ktu78
Внешняя форма счета. Вывод картинки. Помогите пожалуйста.

Автор DMITRIY789Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 9857
Последний ответ 02 Мар 2012, 17:07
от E_x

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 223
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal