Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 15:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сформировать список плательщиков в Банк в ЗиУП 8.2  (Прочитано 2616 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dikovenka

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-04
  • Сайт: 
  • Профессия: Ученик 1С
Нужно в ЗиУП 8.2 документе Зарплата к выплате организации, сформировать элементарный список плательщиков в банк, который состоит только из лицевого счета сотрудника и соответствующий суммы заработной платы, только 2 колонки, без шапок и подвалов. Я создала Внешнюю обработку, но она не работает, подскажите пожалуйста, что в моем модуле не верно? Буду очень очень признательна за любую помощь.

Модуль Объекта внешней обработки:
Функция Печать() Экспорт
   
   ТабДокумент = Неопределено;
   
   Если НЕ СсылкаНаОбъект.СпособВыплаты=Перечисления.СпособыВыплатыЗарплаты.ЧерезБанк тогда
      Сообщить("Документ можно распечатать только, если перечисление через банк!");
      возврат Неопределено;   
   КонецЕсли;   
   
   Объект = СсылкаНаОбъект.ПолучитьОбъект();
   Если Объект.ЭтоНовый() Тогда
      Предупреждение("Документ можно распечатать только после его записи");
      Возврат ТабДокумент;
   КонецЕсли;
   
   Если Не РаботаСДиалогами.ПроверитьМодифицированность(Объект) Тогда
      Возврат ТабДокумент;
   КонецЕсли;

   Запрос=Новый Запрос;
   Запрос.текст="ВЫБРАТЬ
                |   ЛицевыеСчетаРаботниковОрганизации.НомерЛицевогоСчета КАК НомерЗарплатногоСчета,
                |   ЗарплатаКВыплатеОрганизацийЗарплата.Сумма КАК Сумма_Компенсация,
                |   ЗарплатаКВыплатеОрганизацийЗарплата.Физлицо КАК Сотрудник_Наименование,
                |   ЗарплатаКВыплатеОрганизацийЗарплата.КомпенсацияЗаЗадержкуЗарплаты КАК Компенсация
                |ИЗ
                |   Документ.ЗарплатаКВыплатеОрганизаций.Зарплата КАК ЗарплатаКВыплатеОрганизацийЗарплата
                |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЛицевыеСчетаРаботниковОрганизации КАК ЛицевыеСчетаРаботниковОрганизации
                |      ПО ЗарплатаКВыплатеОрганизацийЗарплата.Физлицо = ЛицевыеСчетаРаботниковОрганизации.ФизЛицо
                |         И ЗарплатаКВыплатеОрганизацийЗарплата.Ссылка.Организация = ЛицевыеСчетаРаботниковОрганизации.Организация
                |         И ЗарплатаКВыплатеОрганизацийЗарплата.Ссылка.Банк = ЛицевыеСчетаРаботниковОрганизации.Банк
                |ГДЕ
                |   ЗарплатаКВыплатеОрганизацийЗарплата.Ссылка = &Ссылка
                |ИТОГИ
                |   СУММА(Сумма_Компенсация)
                |ПО
                |   ОБЩИЕ";
             
   Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
   Рез=Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
   
   ТабДокумент = Новый ТабличныйДокумент;
   
   Макет = ПолучитьМакет("МойЭксперимент");
   ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
   
      ТабДокумент.Вывести(ОбластьМакета);
           
      ОбластьМакета = Макет.ПолучитьОбласть("Строка");
         
   ОбщаяСумма=0;
   
   Если Рез.Следующий() тогда
     
      ТабЗарплата=Рез.Выбрать();
      ОбщаяСумма=Рез.Сумма_Компенсация;
      ОбластьМакета.Параметры.ОбщаяСумма=ОбщаяСумма;
     
      НомСтр=1;
      Пока ТабЗарплата.Следующий() Цикл
         
         ЗаполнитьЗначенияСвойств(ОбластьМакета.Параметры,ТабЗарплата);
         ТабДокумент.Вывести(ОбластьМакета);
         НомСтр=НомСтр+1;
      КонецЦикла;
     
   КонецЕсли;   
   
    ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
   
   Возврат ТабДокумент;

КонецФункции


Изображение табличной части  и самой внешней обработки:



Оффлайн Dikovenka

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-09-04
  • Сайт: 
  • Профессия: Ученик 1С
Изображение табличной части и самой обработки можно посмотреть перейдя по ссылке : http://imglink.ru/show-image.php?id=2cd07bbd5f869daec593b011aef5bf1f


Теги:
 

Что такое "Список Значений", "Таблица значений" и "Дерево Значений"?

Автор JahongirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6763
Последний ответ 23 Дек 2011, 16:43
от sergeevds
Массив, Таблица значений и Список значений

Автор Константин163Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 5819
Последний ответ 25 Мар 2015, 16:02
от cska-fanat-kz
Как из справочника вытащить список одной группы справочника и вставить его в поле документа для выбора одного элемента из полученного списка?

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1676
Последний ответ 21 Сен 2016, 08:16
от GadLex
Отчет "Штатно-должностной список"

Автор SashenkaРаздел Закрытые темы

Ответов: 0
Просмотров: 2200
Последний ответ 08 Апр 2010, 03:00
от Sashenka
Список отчетов в справочнике Варианты отчетов пустой. 8.2 УТ 11

Автор SkellarРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 9389
Последний ответ 17 Ноя 2011, 11:01
от Skellar

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 887
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal