Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 09:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запуск и макрос  (Прочитано 2667 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн leftmails

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-08-24
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет!
Возникла такая проблема: есть 1С8.1 и система Инталев, которая создана на базе 1С
В системе инталев есть регламентные задачи/сессии - набор определенных последовательностей для выполнения процессов.

В 1Ске создал справочник для регистрации документов, после регистрации по нажатию кнопки на форме  пытаюсь сделать запуск задачи.
Но не получается.
Думаю есть вариант запуска макроса:
http://km61.intalev.ru/index.html?cdp_macrocm_bp_startsession.htm
Сам справочник по макросам находится в Справочники.Инт_Макросы

Пытался:
Создал Табличный документ, в котором выгрузил все макросы (думал потом привяжусь к нужному), затем выдернул вот такой код
   Если МакросСтрока<>Неопределено Тогда
      Если НЕ МакросСтрока.Доступен Тогда
         Инт_Сообщение("Макрос не может быть выполнен вручную.");
         Возврат;
      КонецЕсли;
      Если НЕ МакросСтрока.Выполнен ИЛИ Вопрос("Макрос выполнялся ранее! Выполнить макрос повторно?",РежимДиалогаВопрос.ДаНет,,КодВозвратаДиалога.Нет,"Выполнение макроса")=КодВозвратаДиалога.Да Тогда
         Инт_ПроформаФорма.ДанныеУпорядочить(ЭтаФорма);
         Попытка
            Документы.Инт_Задача.МакросВыполнить(МакросСтрока);
         Исключение
            Информация=ИнформацияОбОшибке();
            Инт_Сообщение(Информация.Описание);
         КонецПопытки;
         Если Информация=Неопределено Тогда
            ЭлементыФормы.Макросы.ОбновитьСтроки(МакросСтрока);
            Инт_ПроформаФорма.Обновить(ЭтаФорма);
         КонецЕсли;
      КонецЕсли;
   КонецЕсли;


Но без результатно, пожалуйста подскажите что можно сделать


Теги:
 

Необходимо создать интерфейс запуск через тонкого клиента

Автор soulhunter2005Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 5518
Последний ответ 02 Апр 2012, 15:47
от soulhunter2005
Принудительный запуск приложения в 8.2 на тонком клиенте, конфигурации с режимом

Автор mauarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3483
Последний ответ 22 Июн 2012, 09:54
от cska-fanat-kz
Запуск выполнен без использования аппаратной лицензии (ключа защиты)

Автор MuI_I_IkaРаздел Ошибки 1С:Предприятия

Ответов: 0
Просмотров: 10596
Последний ответ 09 Апр 2014, 12:05
от MuI_I_Ika
Запуск функции 1с через командную строку (батник)

Автор windinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 7287
Последний ответ 20 Янв 2014, 17:11
от LordWizard
Нужна помощь, Автоматический запуск формы

Автор kazak_85Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 4810
Последний ответ 29 Дек 2011, 22:25
от freol

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 187
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal