Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 07:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Процедура создания записей в регистре сведений  (Прочитано 11712 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Подскажите в конфигурации "Зарплата и Управление Персоналом, редакция 2.5". При записи справочника физлица, делается движение  в "регистр сведений"ФИОФизЛиц"
Подскажите как найти или как называется эта процедура??????


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Вы уверены, что движения делаются при записи справочника, а не какого-либо документа?

В документе стоит смотреть ОбработкуПрведения, а в справочнике - ну если уверены, что при записи, то и смотрите процедуру ПриЗаписи, ПередЗаписью и ПослеЗаписи.
Как вариант, можно поиском поискать РегистрыСведений.ФИОФизЛиц
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Пишу обработку для выгрузки из XML файла информацию по физлицам. И загрузки её в ЗУП 8
В Форме справочника физЛица, есть строка ИМЯ где указывается ФИО а потом это ФИО делится на Фамилия, Имя, Отчество и при записи этого справочника. Делается запись в регистр сведений "ФИОФизЛиц".
Так вот при загрузки того XML фала в зуп, у меня заполняется строка ИМЯ а ниже это строка нет разбивается. И при записи справочника, не делается запись в регистр сведений "ФИОФизЛиц".

Подскажите как это сделать а еще лучше поделитесь кодом!!!

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Посмотрите, в какой именно момент идет разбивка на Фамилию, Имя и Отчество. ПриЗаписи? Или в момент редактирования ФИО?

Чтобы отработало ПриЗаписи формы также, как и при обычном создании элемента, воспользуйтесь функцией ЗаписатьВФорме() вместо Записать():
Новая = Справочники.Физлица.СоздатьЭлемент();
Новая.Наименование             = Наименование;
....
Форма = Новая.ПолучитьФорму();
Если Форма.ЗаписатьВФорме() Тогда
  Сообщить("Записано");
Иначе
  Сообщить("Не записано!");
КонецЕсли;
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Вот кусок кода где идет создание справочника

Процедура СоздатьЭлементСправочника(СписокЗначений)

ФИО = "";

Для Счетчик = 1 По СписокЗначений.Количество()-1 Цикл

ФИО = СокрЛП(ФИО + " " + СписокЗначений.Получить(Счетчик));

КонецЦикла;

НовыйЭлемент = Справочники.ФизическиеЛица.СоздатьЭлемент();

НовыйЭлемент.СтраховойНомерПФР = СписокЗначений[0].Значение;

НовыйЭлемент.Наименование = ФИО;

НовыйЭлемент.Записать();

КонецПроцедуры

Как мне сделать эту запись в регистр сведений!!!

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Я же Вам написала схему записи элемента. Проведите аналогию.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Да вот, что то не получается как вы написали.
Возможно я делаю что то не так. Может напишите полный код!

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Что именно не работает?
Покажите, что у Вас получилось и какие возникают ошибки.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Решил по своему вот так:

Процедура ЗаписатьДанныеФИО(СписокЗначений,НовыйЭлемент)

МенеджерЗаписи = РегистрыСведений.ФИОФизЛиц.СоздатьМенеджерЗаписи();

Дата = "01.01.1980 12:59:59";


МенеджерЗаписи.ФизЛицо = НовыйЭлемент.Ссылка;
МенеджерЗаписи.Фамилия = СписокЗначений[1].Значение;
МенеджерЗаписи.Имя = СписокЗначений[2].Значение;
МенеджерЗаписи.Отчество = СписокЗначений[3].Значение;
МенеджерЗаписи.Период = Дата;
МенеджерЗаписи.Записать(Истина);

КонецПроцедуры

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Да, можно и так.
Разница в том, что в Вашем случае вы делаете только запись в регистр, и если изменится запись справочника, то Ваша обработка все-равно будет делать запись в регистр. А в моем варианте, будет выполняться точно то же самое, что и при обычном создании элемента.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4855
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7757
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9383
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
В чем отличие регистра сведений от регистра накопления?

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 519
Последний ответ 11 Сен 2017, 10:50
от ilyay
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14367
Последний ответ 11 Янв 2011, 10:04
от nomer13

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 122
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal