Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 окт 2021, 00:09

Как удалить все пустые значения массива?

Автор Леонид, 23 ноя 2009, 13:44

0 Пользователей и 1 гость просматривают эту тему.

Леонид

В общем, есть массив, в который выгружены значения типа «СправочникСсылка.Номенклатура». Как удалить все пустые значения массива? Соответственно заполненные значения не перемещать и не изменять

Никитина

ЦитироватьПроцедура УдалитьПустыеЭлементы(МассивНоменклатуры)

   Счетчик = 0;
   КоличествоЭлементов = МассивНоменклатуры.Количество();

   Пока Счетчик < КоличествоЭлементов Цикл

      Если МассивНоменклатуры [Счетчик].Пустая() Тогда
         МассивНоменклатуры.Удалить(Счетчик);
         
         КоличествоЭлементов = КоличествоЭлементов - 1;

      Иначе
         Счетчик = Счетчик + 1;
         
      КонецЕсли;

   КонецЦикла;

КонецПроцедуры
Но не забываем установить нулевое значения счетчика переменной. После этого организуем сам цикл по обнаружению и удалению

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск