Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Мая 2021, 02:15
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Как удалить все пустые значения массива?  (Прочитано 6473 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Леонид

  • *
  • Регистрация: 2009-11-03
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Профессия: Бухгалтер
В общем, есть массив, в который выгружены значения типа «СправочникСсылка.Номенклатура». Как удалить все пустые значения массива? Соответственно заполненные значения не перемещать и не изменять


Оффлайн Никитина

  • *
  • Регистрация: 2009-11-19
  • Сообщений: 28
  • РЕПУТАЦИЯ: 0
  • Профессия: Бухгалтер
Цитировать
Процедура УдалитьПустыеЭлементы(МассивНоменклатуры)

   Счетчик = 0;
   КоличествоЭлементов = МассивНоменклатуры.Количество();

   Пока Счетчик < КоличествоЭлементов Цикл

      Если МассивНоменклатуры [Счетчик].Пустая() Тогда
         МассивНоменклатуры.Удалить(Счетчик);
         
         КоличествоЭлементов = КоличествоЭлементов - 1;

      Иначе
         Счетчик = Счетчик + 1;
         
      КонецЕсли;

   КонецЦикла;

КонецПроцедуры
Но не забываем установить нулевое значения счетчика переменной. После этого организуем сам цикл по обнаружению и удалению


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
82 Сообщений
LexaK
29 Сообщений
kiokiosan
18 Сообщений
alexandr_ll
16 Сообщений
Ивашка
12 Сообщений
kah
11 Сообщений
antoneus antoneus
9 Сообщений
alex0402 alex0402
9 Сообщений
DmitriyF DmitriyF
9 Сообщений
nvj84
7 Сообщений

* Кто онлайн

  • Точка Гостей: 106
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск