Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 09:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как обойти список значений в цикле  (Прочитано 8551 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Получил список значений, выгрузил его в массив элементов.

Обхожу его в цикле и надо чтоб весь список элементов был записан в переменную.

А уменя получается, что в переменную записывается лишь последний элемент массива элементов.

Помогите разобраться!!!!!!!!!!!!!!

&НаКлиенте
Процедура Прочитать(Команда)

        
        ПрочитатьНаСервере();


КонецПроцедуры

&НаСервере
Процедура  ПрочитатьНаСервере()

        ФИО = " ";
        
        СписокЗначений = Новый СписокЗначений;

        СписокЗначений.Добавить("Асбест+");
        СписокЗначений.Добавить("ООО");

        МассивЭлементов = СписокЗначений.ВыгрузитьЗначения();


        Для каждого ФИО Из МассивЭлементов Цикл


                СписокЗначений.Добавить(ФИО);

  
        КонецЦикла

        НовыйЭлемент =  Справочники.Контрагенты.СоздатьЭлемент();

        НовыйЭлемент.Наименование = ПолноеИмя;

        НовыйЭлемент.Записать();



КонецПроцедуры

Последний раз редактировалось: Slin; 27 Авг 2012, 22:05


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А какая переменная так и не написали.

У вас переменная СписокЗначений заполняется 2 раза. Первый раз вы добавляете просто значения, а потом добавляете значения из массива.

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А если речь про переменную ФИО, то она будет заполнена последним значением из массива. КОнкретизируйте, что вы хотите в результате получить.

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Возможно я что то в цикле не так сделал.
Мне надо чтоб МассивЭлементов был записан в переменную ФИО

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура Прочитать(Команда)

       
        ПрочитатьНаСервере();


КонецПроцедуры

&НаСервере
Процедура  ПрочитатьНаСервере()

        ФИО = " ";
       
        СписокЗначений = Новый СписокЗначений;

        СписокЗначений.Добавить("Асбест+");
        СписокЗначений.Добавить("ООО");

        МассивЭлементов = СписокЗначений.ВыгрузитьЗначения();

        ФИО = МассивЭлементов;

        НовыйЭлемент =  Справочники.Контрагенты.СоздатьЭлемент();

        НовыйЭлемент.Наименование = ПолноеИмя;

        НовыйЭлемент.Записать();

КонецПроцедуры

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ПолноеНаименование = "";

Для каждого ЭлСписка Из СЗ Цикл
      ПолноеНаименование = ПолноеНаименование + ЭлСписка.Значение + " ";
КонецЦикла;

НовыйЭлемент = Справочники.Контрагенты.СоздатьЭлемент();
НовыйЭлемент.Наименование = СокрЛП(ПолноеНаименование);
НовыйЭлемент.Записать();
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Вот как решил:

&НаКлиенте
Процедура Прочитать(Команда)


ПрочитатьНаСервере();


КонецПроцедуры

&НаСервере
Процедура ПрочитатьНаСервере()

ФИО = "";

СписокЗначений = Новый СписокЗначений;

СписокЗначений.Добавить("Асбест+");
СписокЗначений.Добавить("ООО");


Для Счетчик = 0 По СписокЗначений.Количество()-1 Цикл

ФИО = ФИО+СписокЗначений.Получить(Счетчик);


КонецЦикла;

НовыйЭлемент =  Справочники.Контрагенты.СоздатьЭлемент();

НовыйЭлемент.Наименование = ФИО;

НовыйЭлемент.Записать();



КонецПроцедуры


Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
И последний здесь вопрос. У меня в справочнике получается "Наименование" сплошным текстом.
Кто знает как между этими двумя значениями добавить "Пробел".

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
 ФИО = ФИО+" "+СписокЗначений.Получить(Счетчик);
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Лучше все таки ИМХО цикл Для каждого...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 726
Последний ответ 15 Июн 2017, 07:53
от mvk843
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4649
Последний ответ 24 Ноя 2015, 15:38
от welldone
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 20675
Последний ответ 13 Фев 2011, 17:36
от proofet
1C ЗУП 2.5 Помогите с отчетом "Списки сотрудников организации" Объединение значений ячеек

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1041
Последний ответ 10 Фев 2017, 10:49
от ksander-fars
Обход дерева значений на клиенте / развернуть многоуровневое дерево на клиенте

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5149
Последний ответ 01 Ноя 2015, 10:07
от Азиман

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 814
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal