Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 окт 2021, 22:48

Как выявить 2 одинаковых массива

Автор Лида1, 23 ноя 2009, 13:40

0 Пользователей и 1 гость просматривают эту тему.

Лида1

задача состоит в следующем: есть 2 массива, как узнать одинаковы ли они? при этом их размер абсолютно одинаков. В общем требуется проверить на идентичность

Buh777

Цитата: Лида1 от 23 ноя 2009, 13:40
задача состоит в следующем: есть 2 массива, как узнать одинаковы ли они? при этом их размер абсолютно одинаков. В общем требуется проверить на идентичность
очень просто, в качестве параметрв передавать сами проверяемые массивы, т.е. брать не повторяющийся элемент а сразу массив и искать среди таких же=)
smo

Buh777

Сама функция выглядит так:
ЦитироватьФункция ПроверитьИдентичностьМассивов(ПервыйМассив, ВторойМассив)

   НаибольшийИндекс = ПервыйМассив.ВГраница();

   Если НаибольшийИндекс <> ВторойМассив.ВГраница () Тогда
      Возврат Ложь;
      
   КонецЕсли;
   
   Для Счетчик = 0 По НаибольшийИндекс Цикл

      Если ПервыйМассив[Счетчик] <> ВторойМассив[Счетчик] Тогда
         Возврат Ложь;
         
      КонецЕсли;

   КонецЦикла;       

   Возврат Истина;

КонецФункции 
smo

Теги:

Похожие темы (1)

1574

Ответов: 1
Просмотров: 3334

Рейтинг@Mail.ru Rambler's Top100

Поиск