Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Мар 2019, 06:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как выявить 2 одинаковых массива  (Прочитано 2682 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лида1

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-03
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
задача состоит в следующем: есть 2 массива, как узнать одинаковы ли они? при этом их размер абсолютно одинаков. В общем требуется проверить на идентичность


Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
задача состоит в следующем: есть 2 массива, как узнать одинаковы ли они? при этом их размер абсолютно одинаков. В общем требуется проверить на идентичность
очень просто, в качестве параметрв передавать сами проверяемые массивы, т.е. брать не повторяющийся элемент а сразу массив и искать среди таких же=)

Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Сама функция выглядит так:
Цитировать
Функция ПроверитьИдентичностьМассивов(ПервыйМассив, ВторойМассив)

   НаибольшийИндекс = ПервыйМассив.ВГраница();

   Если НаибольшийИндекс <> ВторойМассив.ВГраница () Тогда
      Возврат Ложь;
      
   КонецЕсли;
   
   Для Счетчик = 0 По НаибольшийИндекс Цикл

      Если ПервыйМассив[Счетчик] <> ВторойМассив[Счетчик] Тогда
         Возврат Ложь;
         
      КонецЕсли;

   КонецЦикла;       

   Возврат Истина;

КонецФункции 


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

LexaK
60 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
56 Сообщений
DmitriyF DmitriyF
53 Сообщений
alexandr_ll
37 Сообщений
AIFrame AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
28 Сообщений
alex0402
23 Сообщений
antoneus antoneus
20 Сообщений
isacnew21
16 Сообщений
pavl_vs
15 Сообщений

* Кто онлайн

  • Точка Гостей: 290
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal