Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Окт 2018, 08:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как выявить 2 одинаковых массива  (Прочитано 2593 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лида1

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-03
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
задача состоит в следующем: есть 2 массива, как узнать одинаковы ли они? при этом их размер абсолютно одинаков. В общем требуется проверить на идентичность


Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
задача состоит в следующем: есть 2 массива, как узнать одинаковы ли они? при этом их размер абсолютно одинаков. В общем требуется проверить на идентичность
очень просто, в качестве параметрв передавать сами проверяемые массивы, т.е. брать не повторяющийся элемент а сразу массив и искать среди таких же=)

Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Сама функция выглядит так:
Цитировать
Функция ПроверитьИдентичностьМассивов(ПервыйМассив, ВторойМассив)

   НаибольшийИндекс = ПервыйМассив.ВГраница();

   Если НаибольшийИндекс <> ВторойМассив.ВГраница () Тогда
      Возврат Ложь;
      
   КонецЕсли;
   
   Для Счетчик = 0 По НаибольшийИндекс Цикл

      Если ПервыйМассив[Счетчик] <> ВторойМассив[Счетчик] Тогда
         Возврат Ложь;
         
      КонецЕсли;

   КонецЦикла;       

   Возврат Истина;

КонецФункции 


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
85 Сообщений
alexandr_ll
70 Сообщений
MuI_I_Ika MuI_I_Ika
44 Сообщений
byte777
37 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
36 Сообщений
wise wise
35 Сообщений
LexaK
32 Сообщений
alex0402
29 Сообщений
Каримдат Каримдат
21 Сообщений
АлександрВладимирович
18 Сообщений

* Кто онлайн

  • Точка Гостей: 352
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal