Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 23:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как выявить 2 одинаковых массива  (Прочитано 2325 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лида1

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-03
  • Сайт: OZM.ORG.RU
  • Профессия: Бухгалтер
задача состоит в следующем: есть 2 массива, как узнать одинаковы ли они? при этом их размер абсолютно одинаков. В общем требуется проверить на идентичность


Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
задача состоит в следующем: есть 2 массива, как узнать одинаковы ли они? при этом их размер абсолютно одинаков. В общем требуется проверить на идентичность
очень просто, в качестве параметрв передавать сами проверяемые массивы, т.е. брать не повторяющийся элемент а сразу массив и искать среди таких же=)

Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Сама функция выглядит так:
Цитировать
Функция ПроверитьИдентичностьМассивов(ПервыйМассив, ВторойМассив)

   НаибольшийИндекс = ПервыйМассив.ВГраница();

   Если НаибольшийИндекс <> ВторойМассив.ВГраница () Тогда
      Возврат Ложь;
      
   КонецЕсли;
   
   Для Счетчик = 0 По НаибольшийИндекс Цикл

      Если ПервыйМассив[Счетчик] <> ВторойМассив[Счетчик] Тогда
         Возврат Ложь;
         
      КонецЕсли;

   КонецЦикла;       

   Возврат Истина;

КонецФункции 


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 256
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal