Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Окт 2018, 19:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Повторение в массиве. Как удалить?  (Прочитано 3126 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ППП

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 19
  • КПД: 68%
  • Регистрация: 2009-11-03
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Массив поиском не обаладает, поэтому есть необходимость удалить некоторые элементы как повторяющиеся , так и абсолютно лишние. Как сделатЬ?


Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Скажу сразу, что методом значения поиска он не обладает, и собственно поэтому является самой простой универсальной коллекцией. Поэтому просто перебираем массив и по ходу проверяем значения:
Цитировать
Процедура УдалитьПовторяющиесяЭлементы(Массив)
   
   ТекущийИндекс  = 0;
   ВсегоЭлементов = Массив.Количество();
      
   Пока ТекущийИндекс < ВсегоЭлементов Цикл
      Индекс2 = ТекущийИндекс + 1;
      
      Пока Индекс2 < ВсегоЭлементов Цикл
            
         Если Массив[Индекс2] = Массив[ТекущийИндекс] Тогда
            Массив.Удалить(Индекс2);
            ВсегоЭлементов = ВсегоЭлементов - 1;

         Иначе
            Индекс2 = Индекс2 + 1;
            
         КонецЕсли;
         
      КонецЦикла;
         
      ТекущийИндекс = ТекущийИндекс + 1;
         
   КонецЦикла;

КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
85 Сообщений
alexandr_ll
71 Сообщений
MuI_I_Ika MuI_I_Ika
48 Сообщений
wise wise
38 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
37 Сообщений
byte777
37 Сообщений
LexaK
36 Сообщений
alex0402
29 Сообщений
Каримдат Каримдат
21 Сообщений
АлександрВладимирович
18 Сообщений

* Кто онлайн

  • Точка Гостей: 283
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal