Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 10:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Повторение в массиве. Как удалить?  (Прочитано 2567 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ППП

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 19
  • КПД: 68%
  • Регистрация: 2009-11-03
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Массив поиском не обаладает, поэтому есть необходимость удалить некоторые элементы как повторяющиеся , так и абсолютно лишние. Как сделатЬ?


Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Скажу сразу, что методом значения поиска он не обладает, и собственно поэтому является самой простой универсальной коллекцией. Поэтому просто перебираем массив и по ходу проверяем значения:
Цитировать
Процедура УдалитьПовторяющиесяЭлементы(Массив)
   
   ТекущийИндекс  = 0;
   ВсегоЭлементов = Массив.Количество();
      
   Пока ТекущийИндекс < ВсегоЭлементов Цикл
      Индекс2 = ТекущийИндекс + 1;
      
      Пока Индекс2 < ВсегоЭлементов Цикл
            
         Если Массив[Индекс2] = Массив[ТекущийИндекс] Тогда
            Массив.Удалить(Индекс2);
            ВсегоЭлементов = ВсегоЭлементов - 1;

         Иначе
            Индекс2 = Индекс2 + 1;
            
         КонецЕсли;
         
      КонецЦикла;
         
      ТекущийИндекс = ТекущийИндекс + 1;
         
   КонецЦикла;

КонецПроцедуры


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 260
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal