Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Авг 2020, 23:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Повторение в массиве. Как удалить?  (Прочитано 4139 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ППП

  • *
  • Сообщений: 28
  • РЕПУТАЦИЯ: 19
  • КПД: 68%
  • Регистрация: 2009-11-03
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Массив поиском не обаладает, поэтому есть необходимость удалить некоторые элементы как повторяющиеся , так и абсолютно лишние. Как сделатЬ?


Оффлайн Buh777

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2009-11-19
  • Сайт: reshit.ru
  • Профессия: Бухгалтер
Скажу сразу, что методом значения поиска он не обладает, и собственно поэтому является самой простой универсальной коллекцией. Поэтому просто перебираем массив и по ходу проверяем значения:
Цитировать
Процедура УдалитьПовторяющиесяЭлементы(Массив)
   
   ТекущийИндекс  = 0;
   ВсегоЭлементов = Массив.Количество();
      
   Пока ТекущийИндекс < ВсегоЭлементов Цикл
      Индекс2 = ТекущийИндекс + 1;
      
      Пока Индекс2 < ВсегоЭлементов Цикл
            
         Если Массив[Индекс2] = Массив[ТекущийИндекс] Тогда
            Массив.Удалить(Индекс2);
            ВсегоЭлементов = ВсегоЭлементов - 1;

         Иначе
            Индекс2 = Индекс2 + 1;
            
         КонецЕсли;
         
      КонецЦикла;
         
      ТекущийИндекс = ТекущийИндекс + 1;
         
   КонецЦикла;

КонецПроцедуры


Теги:
 

Не удается удалить "Реализацию ТМЗ и услуги" и "Счет фактуру"

Автор TahibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 879
Последний ответ 05 Авг 2019, 07:58
от alexandr_ll
Не активны кнопки "Добавить" и "Удалить" дополнительные строки в отчете по НДС

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2005
Последний ответ 25 Янв 2018, 14:50
от kiksi
Как удалить зависшее фоновое задание [фоновые задания] [фоновое задание] [снять зависший сеанс]

Автор MuI_I_IkaРаздел Администрирование 1с

Ответов: 0
Просмотров: 37823
Последний ответ 16 Июл 2014, 19:48
от MuI_I_Ika
Внимание вопрос: Как удалить "выемка ДС из кассы"?

Автор Unknown29rusРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 8765
Последний ответ 20 Май 2014, 11:24
от 790619540
Удалить запись из справочника "Сотрудники" уволенного

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4743
Последний ответ 02 Фев 2014, 21:37
от LordWizard

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
82 Сообщений
LexaK
30 Сообщений
antoneus antoneus
29 Сообщений
ToryFree ToryFree
28 Сообщений
alexandr_ll
27 Сообщений
DmitriyF DmitriyF
17 Сообщений
Алексей_1985_06
17 Сообщений
BuhRust
14 Сообщений
Алексей Рожков Алексей Рожков
13 Сообщений
judnikov
10 Сообщений

* Кто онлайн

  • Точка Гостей: 215
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal