Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 06:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с ВПФ Т-1  (Прочитано 1608 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Сделал ВПФ Т-1 для документ "Прием на работу в организацию"
Не могу заполнить две строчки основной оклад и дополнительный оклад. ПОМОГИТЕ СДЕЛАТЬ!!!!!!!!!!

Функция Печать() Экспорт

ТабДок = Новый ТабличныйДокумент;

Макет = ПолучитьМакет("Т1_от_5_1_2004");

СекцияШапка = Макет.ПолучитьОбласть("Шапка");
СекцияРаботник = Макет.ПолучитьОбласть("Работник");
СекцияПодвал = Макет.ПолучитьОбласть("Подвал");

// Выбираем нужные реквизиты
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ПриемНаРаботуВОрганизацию.Номер,
| ПриемНаРаботуВОрганизацию.Дата,
| ПриемНаРаботуВОрганизацию.Организация.НаименованиеПолное,
| ПриемНаРаботуВОрганизацию.Организация.КодПоОКПО,
| ПриемНаРаботуВОрганизацию.РаботникиОрганизации.(
| ДатаПриема,
| ИспытательныйСрок,
| ДатаУвольнения,
| ПодразделениеОрганизации.Наименование,
| Должность,
| Сотрудник.Наименование,
| УсловияПриемаНаРаботу,
| Сотрудник.НомерДоговора,
| Сотрудник.ДатаДоговора,
| Сотрудник.Код КАК ТабКод
| ),
| ПриемНаРаботуВОрганизацию.ОсновныеНачисления.(
| ВидРасчета
| )
|ИЗ
| Документ.ПриемНаРаботуВОрганизацию КАК ПриемНаРаботуВОрганизацию
|ГДЕ
| ПриемНаРаботуВОрганизацию.Ссылка = &Ссылка";

Запрос.Параметры.Вставить("Ссылка",СсылкаНаОбъект);
Запрос.Параметры.Вставить(Формат("ДатаДоговора","ДЛФ=DD"));
Выборка = Запрос.Выполнить().Выбрать();

//Заполняем СекциюШапка
Пока Выборка.Следующий() Цикл

КонецЦикла;

СекцияШапка.Параметры.Заполнить(Выборка);

ВыборкаРаботник = Выборка.РаботникиОрганизации.Выбрать();

// Заполняем СекциюРаботник
Пока ВыборкаРаботник.Следующий() Цикл

КонецЦикла;

СекцияРаботник.Параметры.Заполнить(ВыборкаРаботник);





//ВыборкаТариф = Выборка.ОсновныеНачисления.Выбрать();
//
//Пока ВыборкаТариф.Следующий()  Цикл
//
//
//КонецЦикла;
//
//СекцияРаботник.Параметры.Заполнить(ВыборкаТариф);





ТабДок.Вывести(СекцияШапка);
ТабДок.Вывести(СекцияРаботник);
Табдок.Вывести(СекцияПодвал);

ТабДок.ОтображатьСетку = Ложь;




Возврат ТабДок;

КонецФункции // Печать()






Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Так с этим я разобрался  :D

Теперь когда вывожу печатную форму мои оклады которые я вывел печатаются в самом начале документа.
Хотя в макете все правельно. ПОМОГИТЕ РАЗОБРАТЬСЯ!!!!!!


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
вроде все похоже на правду. может если вы саму обработку пришлете, будет больше шансов разобраться?

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Все, решил. тема закрыта!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4295
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5554
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5892
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4378
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1981
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 129
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal