Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 01:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ГиперСсылка в ТабДок  (Прочитано 3545 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Marta_Li

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-01
  • Сайт: 
  • Профессия: Программист 8.1
Помогите, пожалуйста, нужно в ТабДок вызывать выполнение процедуры по нажатию на область с Гиперссылка=Истина.
Как и где вызвать эту команду?
Спасибо.
Процедура ВывестиОтчет(ТабДок) Экспорт
…..
МассивДокументов = КритерииОтбора.ДокументыПоДоговоруКонтрагента.Найти(ВыборкаДетали.Ссылка);
Если МассивДокументов.Количество() > 0 Тогда
       ОбластьДетали.Параметры.ЕстьДокументы = МассивДокументов.Количество();
       ОбластьДетали.Области.ЕстьДокументы.ГиперСсылка = Истина;
Иначе
       ОбластьДетали.Параметры.ЕстьДокументы = "";
       ОбластьДетали.Области.ЕстьДокументы.ГиперСсылка = Ложь;
КонецЕсли;
…..
Процедура ВывестиСписокДокументовПоДоговору(ДоговорКонтрагента)
           
            ФормаСпискаДокументов = КритерииОтбора.ДокументыПоДоговоруКонтрагента.ПолучитьФорму("ФормаСписка");
            ФормаСпискаДокументов.ПараметрОтборПоЗначению = ДоговорКонтрагента;
            ФормаСпискаДокументов.Открыть();
           
КонецПроцедуры


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Обратите внимание на событие ОбработкаРасшифровки поля табличного документа.

Оффлайн Marta_Li

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-01
  • Сайт: 
  • Профессия: Программист 8.1
Мне уже подсказали, удачно: :zebzdr:

Если табличный документ находится в форме, тогда при его заполнении нужно еще в параметр расшифровки ячейки передавать договор контрагента. А для события   поля табличного документа "Выбор"  ввести процедуру
Процедура ТабДокВыбор(Элемент, Область, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ВывестиСписокДокументовПоДоговору(Область.Расшифровка);
КонецПроцедуры

Оффлайн Marta_Li

  • *
  • Сообщений: 39
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-01
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте. А теперь немного другая ситуация. Прошу помощи, подскажите, пожалуйста, кто знает.
Вывожу на печать таб.документ (не в форме объекта - там все понятно).
Мне нужно на расшифровку параметра повесить вызов процедуры.
Т.е.е если бы это было в формеОбъекта (Отчета), то там есть событие ОбработкаРасшифровки.
А как в отдельном ТабДокументе?
который выводится на экран, как обычный (отдельный) таб.док. в виде таблицы.

Задаю на расшифровку ячейки Структуру:

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
     ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
     ОбластьДетальныхЗаписей.Параметры.РасшифровкаРегистратор = Новый Структура("РегистраторПредставление, Вид", ВыборкаДетальныеЗаписи.Регистратор, "РасшифровкаРегистратор");
КонеЦикла;

Потом хочу при клике на ячейку вызывать конкретную Процедуру.
Или не возможно? Тогда как воспользоваться для этого свойством ячейки Гиперссылка?
Спасибо.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
142 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 142
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal