Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
01 Апр 2020, 12:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматическое заполнение табличной части документа из табличной части другого  (Прочитано 21049 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Slin

  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
Формат первой строки таков:
Массив = <Объект текущего документа>.<Имя реквизита, содержащего исходный приходный документ>.<Имя табличной части приходного документа>.Выгрузить();

Вот модуль формы документа расхода в моей микроконфигурации:
&НаКлиенте
Процедура Заполнить(Команда)
Если Объект.ДокументПрихода.Пустая() Тогда
Возврат;
КонецЕсли;
ЗаполнитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьНаСервере()

массив = Объект.ДокументПрихода.СписокТоваров.Выгрузить();

Объект.СписокТоваров.Загрузить(массив);

КонецПроцедуры

Пояснения:
1. У документа расход создан реквизит "ДокументПрихода" типа "ДокументСсылка.Приход".
2. На форме имеется кнопка, которая вызывает команду "Заполнить", исполняющуюся на стороне клиента.
3. Эта команда вызывает процедуру "ЗаполнитьНаСервере", исполняющуюся на стороне сервера.
4. По процедуре "ЗаполнитьНаСервере":
- Объект - это основной реквизит формы, содержащий собственно значение текущего документа расхода.
- ДокументПриход - реквизит документа расхода, содержащий ссылку на документ прихода
- СписокТоваров - табличная часть документа прихода

Итого:
Ваши строки должны быть примерно такими
Массив = Объект.Приход.Услуги.Выгрузить();
Объект.Услуги.Загрузить(Массив);
при условии, что "Приход" - это ссылка (реквизит документа расхода) на документ прихода.

Возможны варианты.
skype: slin-dev


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6075
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 9730
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 8416
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 13357
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 9132
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
86 Сообщений
LexaK
61 Сообщений
alexandr_ll
34 Сообщений
antoneus antoneus
32 Сообщений
Алексей Рожков Алексей Рожков
32 Сообщений
ef0din
25 Сообщений
wise wise
20 Сообщений
Алексей_1985_06
19 Сообщений
Varg . Varg .
18 Сообщений
Alexbis
15 Сообщений

* Кто онлайн

  • Точка Гостей: 472
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal