Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 18:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматическое заполнение табличной части документа из табличной части другого  (Прочитано 15930 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Will

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Ученик 1С
1С 8.2
Здравствуйте.
Документ Приход: Табличная часть: Услуги. Реквизиты таблицы: Имя, Кол.
Документ Расход: Табличная Часть: Услуги. Реквизиты таблицы: ВыбДокумент (Тип Документ.Приход), Имя, Кол.
Нужно, чтобы при заполнении реквизита ВыбДокумент в табличной части Услуги документа Расход,
реквизиты Имя и Кол заполнялись автоматически в соответствии с выбранным документом Приход из его табличной части.
Пыталась составить запрос, но что-то не работает...

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
                      |Услуги.Имя КАК Имя,
                      |Услуги.Код КАК Код
                      |ИЗ
                      |Документы.Приход.Услуги
                      |ГДЕ
                      |Документы.Приход = &Документ";
 
Услуги.Загрузить(Запрос.Выполнить().Выгрузить());

Каким способом можно произвести заполнение табличной части одного документа из табличной части другого документа?



Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
Вы сами проектировали эту базу? Просто странные поля: имя и код.
Для начала, где параметр запроса "Документ"?
skype: slin-dev

Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
можно еще вот подобным способом, но нужно, чтобы названия и тип колонок совпадали
массив = Объект.ДокументПрихода.СписокТоваров.Выгрузить();
Объект.СписокТоваров.Загрузить(массив);
skype: slin-dev

Оффлайн Will

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо.
Да, эту базу сама проектировала. Просто для примера. Вообще код для документов конфигурации УТ 11.

Оффлайн Will

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Ученик 1С
можно еще вот подобным способом, но нужно, чтобы названия и тип колонок совпадали
массив = Объект.ДокументПрихода.СписокТоваров.Выгрузить();
Объект.СписокТоваров.Загрузить(массив);


названия и тип колонок совпадают, только не совсем понятно что куда подставить.
Массив = Документы.Приход.Услуги.Выгрузить();
Объект.Услуги.Загрузить(Массив);

"Элемент Документы не определен"

Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
Формат первой строки таков:
Массив = <Объект текущего документа>.<Имя реквизита, содержащего исходный приходный документ>.<Имя табличной части приходного документа>.Выгрузить();

Вот модуль формы документа расхода в моей микроконфигурации:
&НаКлиенте
Процедура Заполнить(Команда)
Если Объект.ДокументПрихода.Пустая() Тогда
Возврат;
КонецЕсли;
ЗаполнитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьНаСервере()

массив = Объект.ДокументПрихода.СписокТоваров.Выгрузить();

Объект.СписокТоваров.Загрузить(массив);

КонецПроцедуры

Пояснения:
1. У документа расход создан реквизит "ДокументПрихода" типа "ДокументСсылка.Приход".
2. На форме имеется кнопка, которая вызывает команду "Заполнить", исполняющуюся на стороне клиента.
3. Эта команда вызывает процедуру "ЗаполнитьНаСервере", исполняющуюся на стороне сервера.
4. По процедуре "ЗаполнитьНаСервере":
- Объект - это основной реквизит формы, содержащий собственно значение текущего документа расхода.
- ДокументПриход - реквизит документа расхода, содержащий ссылку на документ прихода
- СписокТоваров - табличная часть документа прихода

Итого:
Ваши строки должны быть примерно такими
Массив = Объект.Приход.Услуги.Выгрузить();
Объект.Услуги.Загрузить(Массив);
при условии, что "Приход" - это ссылка (реквизит документа расхода) на документ прихода.

Возможны варианты.
skype: slin-dev

Оффлайн Will

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-30
  • Сайт: 
  • Профессия: Ученик 1С


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7742
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4780
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8508
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7343
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 456
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal