Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 08:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите ученику 1С  (Прочитано 1860 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн korneevasa

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-23
  • Сайт: 
  • Профессия: Бухгалтер
1С 7.7 Бухучет Добрый день. Столкнулась с такой проблемой: Есть документ «Отгрузка продукции» в котором при отгрузке готовой продукции формируется проводка:
90.2.1- 43
60.01.1-90.1.1
Субконто 1 (ВидНоменклатуры) в счете 90.1.1 и 90.2.1 подтягивается из справочника ВидыНоменклатуры автоматически.. Нужно сделать так, чтобы была возможность менять вид номенклатуры в шапке документа. Например: есть Номенклатура «сок», вид номенклатуры «продукция 18%» , нужно, сделать так, чтобы модно было выбирать вид номенклатуры меду «продукция18%» и «торговля». Я добавила в шапку документ новый реквизита с возможность выбора вида номенклатуры (Справочник.ВидыНоменклатуры), но как подвязать выбранный элемент к проводке , не пойму. Буду очень благодарна за помощь, Спасибо.
/~~~~~~         
         Операция.НоваяПроводка();
         Операция.СодержаниеПроводки = "Отгружено со склада";
         Операция.НомерЖурнала = "ТВ";
         Операция.Кредит.Счет = СчетУчета;
         Операция.Кредит.Номенклатура = Товар;
         Операция.Кредит.МестаХранения = МестоХранения;
         Операция.Количество = Количество;
         Операция.Сумма = СуммаОтгрузки;
         Если ВидОтгрузки = 3 Тогда
            Операция.Дебет.Счет = СчетСписания; 
            Если ПустоеЗначение(Субконто1)=0 Тогда
               Операция.Дебет.Субконто(1,Субконто1);
            КонецЕсли;
            Если ПустоеЗначение(Субконто2)=0 Тогда
               Операция.Дебет.Субконто(2,Субконто2);
            КонецЕсли;
            Если ПустоеЗначение(Субконто3)=0 Тогда
               Операция.Дебет.Субконто(3,Субконто3);
            КонецЕсли;
         ИначеЕсли ВидОтгрузки = 2 Тогда
            Операция.Дебет.Счет = Сч45;
            Операция.Дебет.Контрагенты = Контрагент;
            Операция.Дебет.Договоры = Договор;
            Операция.Дебет.Номенклатура = Товар;

         ИначеЕсли ВидОтгрузки = 1 Тогда
            Операция.Дебет.Счет = Сч90_2_1;
            Операция.Дебет.ВидыНоменклатуры = ВидыНоменклатуры.ВидНоменклатуры;
            
            ТаблицаОтгрузки.НоваяСтрока();
            ТаблицаОтгрузки.ВидНоменклатуры = Товар.ВидНоменклатуры;
            ТаблицаОтгрузки.СтавкаНДС = глСтавкаНалога(Контекст, "НДС");
            ТаблицаОтгрузки.СтавкаНП = глСтавкаНалога(Контекст, "НП");
            Если ТаблицаОтгрузки.ВидыНоменклатуры.ВидНоменклатуры = Перечисление.ВидНоменклатуры.Товар Тогда
               ТаблицаОтгрузки.ВидРасчетов = Перечисление.ВидыРасчетовСПокупателями.РасчетыЗаТовары;
            Иначе
               ТаблицаОтгрузки.ВидРасчетов = Перечисление.ВидыРасчетовСПокупателями.РасчетыЗаПродукциюРаботыУслуги;
            КонецЕсли;


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
Artibon
13 Сообщений
LexaK
13 Сообщений

* Кто онлайн

  • Точка Гостей: 576
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal