Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 19:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проверка по филиалу в документе  (Прочитано 912 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sergqwert

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-11-09
  • Сайт: 
Есть документ Перенаправка(рекв. Город, ГородПолучатель со ссылкой на справочник Филиалы). В нем выбирают новый ГородПолучатель и его надо проверять. Проверять при выборе города и перед записью в форме документа.
Нужно проверить филиал по регистру сведений СостояниеГорода(рекв. Город -ссылка на справочник Города , ресурс -ТолькоПриемкаГруза - булево ). Регистр сведений СостояниеГорода - независимый. Если у города стоит галка, то в этот филиал перенаправку делать нельзя. Город и филиал соединять по коду. Основная База определяется как СокрЛП(ПараметрСеанса.ГородПоУмолчанию.Код) = "КА". Необходимо в документе запретить оформлять перенаправку на другие филиалы кроме "КА".

Процедура ГородПолучательПриИзменении(Элемент)
   
   Если ЗначениеЗаполнено(ГородПолучатель) Тогда
        ПараметрыСеанса.ГородПоУмолчанию = Константы.ГородПоУмолчанию.Получить().Код;
        ГородПолучатель = Справочники.Филиалы.НайтиПоКоду("КА");

КонецПроцедуры     

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
Если РегистрыСведений.споСостояниеГорода.ТолькоПриемкаГруза И СокрЛП(ПараметрыСеанса.споГородПоУмолчанию.Код)<>"КА"
      Тогда
      #Если Клиент Тогда
      Предупреждение("В городе " + ГородПолучатель + " не возможна перенаправка!");
      #КонецЕсли   
   КонецЕсли;
КонецПроцедуры

Возможно ли так сделать?


Теги:
 

заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3592
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 311
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3756
Последний ответ 29 Июн 2012, 18:37
от LexaK
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2029
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Не активно поле ПОЛУЧАТЕЛЬ в документе "выдача наличных" и в "кассовых документах"

Автор Masik777Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 913
Последний ответ 31 Авг 2016, 16:02
от Masik777

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 338
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal