Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 01:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1с82, самописная, внешняя обработка  (Прочитано 3744 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн asdfr1

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-28
  • Сайт: 
внешняя обработка.Необходимо заменить одно значение на другое.Проводок нет.Выбираю запросом
Что = ЭтаФорма.ЭлементыФормы.Что.Значение;
КонтрольнаяДата = ТекущаяДата();
НаКого =  ЭтаФорма.ЭлементыФормы.НаКого.Значение;


    Запрос = Новый Запрос;
    Запрос.Текст =
"ВЫБРАТЬ
|      Задача.Ссылка КАК Ссылка,
|      Задача.Представление,
|      Задача.ТочкаМаршрута,
|      ПРЕДСТАВЛЕНИЕ(Задача.ТочкаМаршрута),
|      Задача.Наименование,
|      Задача.Пользователь КАК Пользователь1,
|      ПРЕДСТАВЛЕНИЕ(Задача.Пользователь),
|      Задача.Создатель,
|      ПРЕДСТАВЛЕНИЕ(Задача.Создатель),
|      Задача.БизнесПроцесс.Номер
|   ИЗ
|      Задача.Задача КАК Задача
|   ГДЕ

|      Задача.Выполнена = ЛОЖЬ
|      И Задача.КонтрольныйСрок < &КонтрольнаяДата
|       И Задача.Пользователь = &Что
|
|ДЛЯ ИЗМЕНЕНИЯ";

а дальше непонятки :
  Для каждого Строка Из ТЗ Цикл
 Объект = Строка.Ссылка.ПолучитьОбъект();
Для каждого Строка Из ТЗ Цикл
         
Заменяемые.Вставить(Что, НаКого);
Объект.Записать();
КонецЦикла;  КонецЦикла;

и не записывает :(






Оффлайн asdfr1

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-28
  • Сайт: 
или как-то так :
      Для каждого Строка Из ТЗ Цикл
Объект = Строка.Ссылка.ПолучитьОбъект();
Объект.Пользователь = НаКого;

Сообщить(Объект.Исполнитель);

Объект.Записать();
КонецЦикла;  КонецЦикла;
ткните кто-нибудь носом

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
"...Для каждого Строка Из ТЗ Цикл..."

Скорее меня ткните носом где у вас выше что нибудь вроде
"ТЗ = ..."
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн asdfr1

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-28
  • Сайт: 
"...Для каждого Строка Из ТЗ Цикл..."

Скорее меня ткните носом где у вас выше что нибудь вроде
"ТЗ = ..."
ТЗ = Результат.Выгрузить();
ОткрытьЗначение(ТЗ);

Оффлайн asdfr1

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-28
  • Сайт: 
обычная невнимательность, подсказали на другом форуме :

ТЗ = Запрос.Выполнить().Выгрузить();

Для каждого Строка Из ТЗ Цикл
Объект = Строка.Ссылка.ПолучитьОбъект();
Объект.Пользователь = НаКого;
Сообщить(Объект.Исполнитель);
Объект.Записать();
КонецЦикла; КонецЦикла;

тема закрыта

Оффлайн asdfr1

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-10-28
  • Сайт: 
обычная невнимательность, подсказали на другом форуме :

ТЗ = Запрос.Выполнить().Выгрузить();

Для каждого Строка Из ТЗ Цикл
Объект = Строка.Ссылка.ПолучитьОбъект();
Объект.Пользователь = НаКого;
Сообщить(Объект.Исполнитель);
Объект.Записать();
КонецЦикла; КонецЦикла;

тема закрыта


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
142 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 144
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal