Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 22:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вычисляемое поле в форме документа  (Прочитано 5666 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Обезьяна

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-31
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте! v 8.2 Розница (8.2.14.537)
Создал новый документ ПрихАлко, у табличной части реквизитов немного Номенклатура, Крепость, ВычПоле. У справочника Номенклатура добавил новый реквизит Крепость (Число).
У реквизита Табличной части Номенклатура ПутьКДанным указал Объект.ТаблЧасть.Номенклатура; реквизит Крепость - Объект.ТаблЧасть.Номеклатура.Крепость.
Создал событие ПриИзменении для реквизита Номенклатура
&НаКлиенте
Процедура ТаблЧастьНоменклатураПриИзменении(Элемент)

Для каждого СтрокаТЧ Из Объект.ТаблЧасть Цикл
СтрокаТЧ.ВычПоле = СтрокаТЧ.Крепость*5;
КонецЦикла;
КонецПроцедуры

Результат - поле формы ВычПоле остается пустым, Поле Крепость заполняется соответствующим значением.
Смотрел в отладчике - поле крепость значение - 0(хотя поле формы заполняется).
Прошу помощи - как ве-таки получить значение Крепости для дальнейшей работы с ним?


Оффлайн Обезьяна

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-12-31
  • Сайт: 
  • Профессия: Программист 8.1
Проблема была решена на другом форуме. Вот решение
&НаКлиенте
Процедура ТаблЧастьНоменклатураПриИзменении(Элемент)
  СтрокаТЧ = Элементы.ТаблЧасть.ТекущиеДанные;
  КрепостьНоменклатуры = ПолучитьКрепостьНоменклатуры(СтрокаТЧ.Номенклатура);
  СтрокаТЧ.Крепость = КрепостьНоменклатуры;
  СтрокаТЧ.ВычПоле = КрепостьНоменклатуры*5;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьКрепостьНоменклатуры(Номенклатура)
  Возврат Номенклатура.Крепость;
КонецФункции;


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4857
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 17234
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4770
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1193
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8273
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
165 Сообщений
alex0402
78 Сообщений
oleg-x
69 Сообщений
AIFrame AIFrame
63 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
39 Сообщений
KOI8-R
36 Сообщений
Анюта17
33 Сообщений
Alter
30 Сообщений

* Кто онлайн

  • Точка Гостей: 311
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal