Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 05:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка Список Активных Пользователей  (Прочитано 4309 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Народ помогите разобраться не могу понять почему не работает.

Создал обработку в ней реквизит-таблица значений.
Создал форму в форме создал колонки к таблице значений.
А все равно не работает вот код.
Помогите разобраться
&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере(Объект.СписокПользователей,НадписьКоличество);
КонецПроцедуры


&НаСервереБезКонтекста
Процедура Команда1НаСервере(СписокПользователей,НадписьКоличество)

Попытка
СписокПользователей.Очистить();
МассивСоединений=ПолучитьСоединенияИнформационнойБазы();
Для Каждого Соединение Из МассивСоединений Цикл
НовСтр=СписокПользователей.Добавить();
ЗаполнитьЗначенияСвойств(НовСтр,Соединение);
Если Соединение.Пользователь<>Неопределено Тогда
НовСтр.ПарольУстановлен=Соединение.Пользователь.ПарольУстановлен;
КонецЕсли;
КонецЦикла;
СписокПользователей.Сортировать("Пользователь");
НадписьКоличество.Заголовок="Количество: "+МассивСоединений.Количество();
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;

КонецПроцедуры


Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
Нельзя передавать на сервер тип 'ДанныеФормыКоллекция' (параметр 'Объект.СписокПользователей')
Делайте серверную процедуру контекстной и уберите таблицу из параметров

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
А можете код подправить, а то не доконца понимаю

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
&НаКлиенте
Процедура Команда1(Команда)
    Команда1НаСервере();
КонецПроцедуры


&НаСервере
Процедура Команда1НаСервере()


    СписокПользователей = Объект.СписокПользователей;      // чтобы много раз через точку не обращаться, лучше 1 раз присвоить  локальной переменной
    Попытка
        СписокПользователей.Очистить();
        МассивСоединений=ПолучитьСоединенияИнформационнойБазы();
        Для Каждого Соединение Из МассивСоединений Цикл
            НовСтр=СписокПользователей.Добавить();
            ЗаполнитьЗначенияСвойств(НовСтр,Соединение);                   
            Если Соединение.Пользователь<>Неопределено Тогда           
                НовСтр.ПарольУстановлен=Соединение.Пользователь.ПарольУстановлен;
            КонецЕсли;
        КонецЦикла;
        СписокПользователей.Сортировать("Пользователь");               
        НадписьКоличество.Заголовок="Количество: "+МассивСоединений.Количество();
    Исключение
        Сообщить(ОписаниеОшибки());   
    КонецПопытки;
   
    КонецПроцедуры

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
А можете теперь подсказать, как описать чтоб можно было пользователей выкидывать.
Как по одному ьак и всех.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2860
  • РЕПУТАЦИЯ: 547
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
О какой поворот событий =)))
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Что такое "Список Значений", "Таблица значений" и "Дерево Значений"?

Автор JahongirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6977
Последний ответ 23 Дек 2011, 16:43
от sergeevds
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8742
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Обработка "ПодборНоменклатуры"

Автор BigAnnРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3071
Последний ответ 18 Апр 2012, 20:38
от Dethmontt
Обработка "СогласованиеЗаявок"

Автор Денис АндрушкоРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 877
Последний ответ 24 Сен 2016, 00:37
от Денис Андрушко
Обработка "Ввести реализацию"

Автор inoifantomРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1774
Последний ответ 27 Мар 2011, 12:57
от inoifantom

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
LexaK
13 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 212
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal