Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 00:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обмен заказами 1С с сайтом!!!  (Прочитано 1171 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Himon

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте! Помогите пожалуйста с задачей! Необходимо чтобы при обмене заказами сайта на Битриксе и 1С 8.2 УТ 10.3 в поле комментарий (в форме заказа) попадал адрес доставки, который покупатель задает на сайте! Нашел чей-то код, который решает аналогичную задачу, расположил его также, как в работающей конфигурации:
                                             СФ_Метоположение = "";
            СФ_АдресДоставки = "";
            СФ_ДатаДоставки = "";
            СФ_ВремяДоставки = "";
            СФ_Комментарий = "";
            СФ_ТипЗаказа = "";
            СФ_МетодОплаты = "";
            СФ_СпособДоставки = "";
            Для Каждого ТоварУслугаСвойство Из Док.Строки Цикл
               
               Если НЕ ЗначениеЗаполнено(ТоварУслугаСвойство.СвойствоНаименование) Тогда
                  Продолжить;
               КонецЕсли;
               
               Если ТоварУслугаСвойство.СвойствоНаименование = "Местоположение" Тогда
                  СФ_Метоположение = ". Мест.: "+ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               Если ТоварУслугаСвойство.СвойствоНаименование = "Адрес доставки" Тогда
                  СФ_АдресДоставки = ". Адр.: "+ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               Если ТоварУслугаСвойство.СвойствоНаименование = "Желаемая дата доставки (ММ/ДД)" или ТоварУслугаСвойство.СвойствоНаименование = "Желаемая дата доставки (ДД/ММ)" Тогда
                  СФ_ДатаДоставки = ". Жел.дата: "+ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               Если ТоварУслугаСвойство.СвойствоНаименование = "Желаемое время доставки" Тогда
                  СФ_ВремяДоставки = ". Жел.время: "+ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               
               Если ТоварУслугаСвойство.СвойствоНаименование = "Тип заказа" Тогда
                  СФ_ТипЗаказа = ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               
               Если ТоварУслугаСвойство.СвойствоНаименование = "Метод оплаты" Тогда
                  СФ_МетодОплаты = ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               
               Если ТоварУслугаСвойство.СвойствоНаименование = "Способ доставки" Тогда
                  СФ_СпособДоставки = ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               
            КонецЦикла;         
            
            СФ_Комментарий = Сред(Док.ДокументОбъект.Комментарий, Найти(Док.ДокументОбъект.Комментарий, "[")-1, (Найти(Док.ДокументОбъект.Комментарий, "]")-Найти(Док.ДокументОбъект.Комментарий, "[")+2));
            Док.ДокументОбъект.Комментарий = "№ " + Док.ДокументОбъект.СФ_Номер + " Заказ с сайта " + ИмяСайта + " Инф. по доставке: " + СФ_АдресДоставки + СФ_ДатаДоставки + СФ_ВремяДоставки + СФ_Метоположение + СФ_Комментарий;

, но у меня он не работает. При перечисление свойств "ТоварУслугаСвойство.СвойствоНаименование", таких свойства как "Местоположение", "Адрес доставки" и т.д. там нет и что такое "ТоварУслугаСвойство.СвойствоНаименование" и откудо оно берется не понимаю и найти не могу. Помогите кто чем может!
P.S. "В программировании профан."


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 197
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal