Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Май 2018, 13:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите с печатной формой м-11  (Прочитано 2315 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн LED82

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-27
  • Сайт: 
  • Профессия: Программист 7.7
есть внешняя печатная форма м-11 в которой хочу чтобы выводилась сумма  по колонке сумма без учета ндс в модуле внешней печатной форме добавил но нефига не хочет выводить помогите люди


Функция КодСубсчета(Д)
                                            
   Код = "";
   
   Если Д.Материал.Вид() = "Материалы" Тогда
      Код = Д.Материал.СубСчет10;
      
   ИначеЕсли Д.Материал.Вид() = "Номенклатура" Тогда
      Если Д.Материал.ТипНоменклатуры = Перечисление.ТипыНоменклатуры.Продукция Тогда
         Код = "43";
         
      Иначе // полуфабрикат
         Код = "21";
      КонецЕсли;
   КонецЕсли;
   
   Возврат Код;
   
КонецФункции // КодСубсчета()

//_____________________________________________________________________________
   
Процедура Печать(Д, Устройство=0, КолвоКопий=1)
   
   перем сум1;
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("М-11");
   
   ПодразделениеПолучатель = "";
   Если Д.ВидПеремещения = 0 Тогда
      КорСчет = Д.СчетЗатрат.Код;
      Для СчетчикЦикла = 1 По Д.СчетЗатрат.КоличествоСубконто() Цикл
         Субконто = Д.ПолучитьАтрибут("Субконто" + СчетчикЦикла);
         Если Субконто.Вид() = "Подразделения" Тогда
            ПодразделениеПолучатель = Субконто;
            Прервать;
         КонецЕсли;
      КонецЦикла;
   Иначе
      ПодразделениеПолучатель = Д.МестоХраненияПриемник;
   КонецЕсли;                 
   ПодразделениеОтправитель = Д.МестоХранения;
   
   
   сум1=0; // мое
   

   Если Д.Проведен() = 0 Тогда
      НомерПовторяемойСтроки = 16;
      ТекстПредупреждения = "Для непроведенного документа графы ""Цена"" и ""Сумма"" не заполняются.";
      Таб.ВывестиСекцию("Предупреждение");
      Таб.ВывестиСекцию("Шапка");
      
      Д.ВыбратьСтроки();
      Пока Д.ПолучитьСтроку() = 1 Цикл
         Субсчет = КодСубсчета(Д);
         Если Д.Материал.Выбран() = 1 Тогда
             МатЦенность = Д.Материал;
            Код = Д.Материал.Код;
            ЕдиницаИзмерения = Д.Материал.ЕдиницаИзмерения;
            ЕдиницаИзмеренияКод = Д.Материал.ЕдиницаИзмерения.Код;
            МатериалСумма = 0;
            МатериалЦенаБезНДС = 0;
                сум1=сум1+МатериалСумма;// мое
         КонецЕсли;
         Таб.ВывестиСекцию("Строка");
         Состояние("Выведено строк: " + Д.НомерСтроки);
      КонецЦикла;
      
   ИначеЕсли Д.Модифицированность() = 1 Тогда
      Предупреждение("Для печати документ необходимо перепровести.");
      Возврат;
      
   Иначе
      НомерПовторяемойСтроки = 15;
      Таб.ВывестиСекцию("Шапка");

      Д.ВыбратьСтроки();
      Пока Д.ПолучитьСтроку() = 1 Цикл
         Если Д.Материал.Выбран() = 1 Тогда
            Субсчет = КодСубсчета(Д);
            МатЦенность = Д.Материал;
            Код = Д.Материал.Код;
            ЕдиницаИзмерения = Д.Материал.ЕдиницаИзмерения;
            ЕдиницаИзмеренияКод = Д.Материал.ЕдиницаИзмерения.Код;
            МатериалСумма = Д.Сумма;
            МатериалЦенаБезНДС = Д.Сумма / Д.КоличествоОтпущено;
               сум1=сум1+МатериалСумма;// мое
         КонецЕсли;
         Таб.ВывестиСекцию("Строка");
         Состояние("Выведено строк: " + Д.НомерСтроки);
      КонецЦикла;
   КонецЕсли;

   Таб.ВывестиСекцию("Подвал");
   Таб.ПовторятьПриПечатиСтроки(НомерПовторяемойСтроки, НомерПовторяемойСтроки);
   
   
   Если Устройство = 0 Тогда
      Таб.Опции(0, 0, ?(Д.Проведен() = 0, 1, 0), 0, "ОпцииПечатиМ11", "ОкноМ11");     
      Таб.ОбластьПечати(?(Д.Проведен() = 0, 2, 1), 2,,);
      Таб.ТолькоПросмотр(1);
      Таб.Показать("Требование-накладная (форма №М-11)");
   Иначе     
      Таб.КоличествоЭкземпляров(КолвоКопий);
      Таб.Напечатать(0);
   КонецЕсли;
КонецПроцедуры // Печать()


//******************************************************************************
// ПоКнопкеПечать()
//
// Параметры:
//  Нет
//
// Возвращаемое значение:
//  Нет
//
// Описание:
//
Процедура ПоКнопкеПечать()
   
   Если Док.Выбран() = 0 Тогда
       Предупреждение("Не выбран документ!", 60);
      Возврат;
   КонецЕсли;
   
   Печать(Док);
   
КонецПроцедуры // ПоКнопкеПечать()

//******************************************************************************
// Предопределенная процедура
//
Процедура ПриОткрытии()
   
   Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
      
      Докум      = Форма.Параметр.Получить("Контекст");
      Устройство = Форма.Параметр.Получить("Устройство");
      КолвоКопий = Форма.Параметр.Получить("КоличествоКопий");
   
      Печать(Докум, Устройство, КолвоКопий);
      Статусвозврата(0);
      Возврат;
   КонецЕсли;
   
   
КонецПроцедуры // ПриОткрытии()
 


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
oleg-x
64 Сообщений
alex0402
62 Сообщений
AIFrame AIFrame
52 Сообщений
wise wise
38 Сообщений
KOI8-R
33 Сообщений
buketov.av buketov.av
28 Сообщений
Alter
21 Сообщений
alexandr_ll
19 Сообщений
Анюта17
19 Сообщений

* Кто онлайн

  • Точка Гостей: 284
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal