Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 03:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Прощу помощи по коду  (Прочитано 1549 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dobrolubov

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-12
  • Сайт: 
  • Профессия: Ученик 1С
День добрый, мне надо сделать печатную форму(), по регистру сведений. Оттуда мне необходимо брать номенклатуру сырья и считать приход и уход за сегодняшний день, подскажите кто что сможет))



Процедура Печать(Элемент)
   
   
   Макет=РЕгистрыНакопления.Движение.ПолучитьМакет("Макет");
   ОбластьШапки=макет.ПолучитьОбласть("Шапка");
   ТабДок=Новый ТабличныйДокумент;
   дат=текущаядата();
     Результат="";
    Если ТипЗнч(Дат)=Тип("Дата") Тогда
        Результат=Формат(Дат,"ДФ=""дд ММММ гггг 'г.'""");
    КонецЕсли;
   областьшапки.Параметры.текущаядата=РЕзультат;
   ТабДок.Вывести(ОбластьШапки);
        
   Выборка=РЕгистрыНакопления.Движение.Выбрать();
    имяц=выборка.Номенклатура;
   пока выборка.Следующий() цикл
       к1=0;             
      к2=0;
      к3=0;

      датТ=выборка.Период;
        Рез="";
    Если ТипЗнч(ДатТ)=Тип("Дата") Тогда
        Рез=Формат(ДатТ,"ДФ=""дд ММММ гггг 'г.'""");
    КонецЕсли;
                 облТабЧасти=макет.ПолучитьОбласть("Строка");
          если рез=результат               //проверка сегоднящней даты
      тогда
   облтабчасти.Параметры.наим=выборка.Номенклатура;   
   
   пока      выборка.Следующий() цикл
      
      
      
      к1=к1+выборка.Факт;
         к2=к2+выборка.Расход_сырья;
      
   конеццикла;   
   конецесли;   

                              
        облтабчасти.Параметры.прих=к1;
       облтабчасти.Параметры.расх=к2;
          

   конеццикла;
   табдок.Вывести(ОблТабЧасти);

       табдок.Защита=Истина;
   табдок.ТолькоПросмотр=Истина;
   табдок.Показать();
      

КонецПроцедуры


Оффлайн Dobrolubov

  • **
  • Сообщений: 70
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-12
  • Сайт: 
  • Профессия: Ученик 1С
вот скрины

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
такой вопрос, вы что новичок в 1с.Могу помочь если не понятно вам все.
1. Какая конфигурация?
2. По какому регистру сведений надо сделать печатную форму?

3. скрин это что нужно сделать или то что уже сделано? А то на скрине уже номенклатура сырья.

У меня к вам вопрос, у вас этот странный для меня кусок кода ошибок не выдает? А то я минут только 20 хотел понять что код должен делать и толком не понял до конца.

данные из регистра запросом вытаскивайте, проще будет.
Просто у вас в цикле который не правилен вы хотите типо сделать, пока есть хоть какие-то записи в регистре
всегда приравнивать K1=0, K2=0, K3=0
Потом вытаскиваете дату(которая всегда имеет тип Дата) и ставите условие если Дата имеющая всегда тип Дата равно Тип Дата то ее преобразовать.
И у вас нет вывода данных. Область выводите, а в нее данных никаких не выводите.

 облТабЧасти=макет.ПолучитьОбласть("Строка"); -например к чему это строка если потом ее не вывдите, а тем более не каких данных в макет не выводите по коду.

Зачем вам эти конструкции?
дат=текущаядата();
     Результат="";
    Если ТипЗнч(Дат)=Тип("Дата") Тогда
        Результат=Формат(Дат,"ДФ=""дд ММММ гггг 'г.'""");
    КонецЕсли;

  датТ=выборка.Период;
        Рез="";
    Если ТипЗнч(ДатТ)=Тип("Дата") Тогда
        Рез=Формат(ДатТ,"ДФ=""дд ММММ гггг 'г.'""");
    КонецЕсли;

Просто это делается:
дат=текущаядата();
датТ=выборка.период.
если дат=датТ тогда
и дальше что нужно.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Регистр сведений или все таки накопления?..

Почитайте самую малость про систему компоновки данных - сделаете отчет на раз-два...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как при помощи СКД при формировании макета отчета данные связанного набора данных вывести в Параметр через ";"

Автор sveta CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 966
Последний ответ 01 Мар 2016, 14:33
от sveta C
перечисление разовых премий и материальной помощи физическим лицам не состоящим в штате организации

Автор Лана ЮрьевнаРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 411
Последний ответ 09 Дек 2016, 19:04
от Лана Юрьевна
Нужно очень много помощи, в выпускной работе по 1с предприятию 8.1.

Автор Artem_KovalevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1473
Последний ответ 21 Апр 2014, 23:54
от MuI_I_Ika
"Данные по коду не найдены"

Автор elteawРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 8118
Последний ответ 03 Дек 2015, 13:58
от Timofey Gurubanov
Прошу помощи, чтобы исправить ошибку в конфигурации

Автор garmin-osaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1657
Последний ответ 10 Апр 2011, 17:43
от chuevsf

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 172
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal