Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 00:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: преобразовать данные xml в текстовую заявку на какой-либо товар  (Прочитано 1670 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Devillord

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-07-23
  • Сайт: 
  • Профессия: Ученик 1С
нужно преобразовать данные xml в заявку, пусть даже текстовый документ.
есть код,для чтения xml файла, а как преобразовать в текстовый документ, не знаю.  :dfbsdfbsdf:
могу дополнительно залить сам xml, чтобы было примерно видно,критерии заявки

используемый код для чтения :
ЧтениеXML = Новый ЧтениеXML;
ЧтениеXML.ОткрытьФайл("E:\задание\order_18284401.xml");
   
 // Создать новый документ Поступление товаров и услуг - РАБОТАЕТ!
 НовыйДокумент = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
 НовыйДокумент = Документы.ПоступлениеТоваровУслуг.ПолучитьФормуНовогоДокумента();
 НовыйДокумент.Открыть();
     

Пока ЧтениеXML.Прочитать()Цикл
      Если ЧтениеXML.ТипУзла=ТипУзлаXML.НачалоЭлемента Тогда
              ИмяУзла =ЧтениеXML.Имя;
              Сообщить("--Начало:"+ ИмяУзла);
          
           Пока ЧтениеXML.ПрочитатьАтрибут() Цикл
               //Прочитать данные узла атрибута
                 ТипУзла=ЧтениеXML.ТипУзла;
                  Имя=ЧтениеXML.Имя;
                  Значение=ЧтениеXML.Значение;
            КонецЦикла;

          
              ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
             
              Сообщить("Текст:" + ЧтениеXML.Значение);
      
       
       ИначеЕсли ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда
  // В примере просто выводим признак конца элемента
  // в окно сообщений   
 НоваяСтрока = НовыйДокумент.ТабЧасть.Добавить();
 НоваяСтрока.Реквизит1 = ЧтениеXML.Значение;

  Сообщить("--Конец:" + ЧтениеXML.Имя);
   
      КонецЕсли;
      
КонецЦикла;
КонецПроцедуры
_____________________
нужен был бы код для залития прочтённой информации в текстовый файл

Ожидаю помощи,так как в 1С попросту учусь!  :(


Теги:
 

Как перенести данные из 7.7 типовая УСН 1.3 в 1С 8 типовая бухгалтерия

Автор Александр бухгалтерРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 5108
Последний ответ 13 Фев 2010, 07:58
от Александр бухгалтер
"Лишние" данные в зарплате

Автор Мария_ХРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 4197
Последний ответ 05 Апр 2014, 11:11
от Славянка
"Данные по коду не найдены"

Автор elteawРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 9178
Последний ответ 03 Дек 2015, 13:58
от Timofey Gurubanov
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7701
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 155
Последний ответ 10 Апр 2018, 14:00
от Св Ч

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
39 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
Alter
30 Сообщений

* Кто онлайн

  • Точка Гостей: 202
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal