Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 23:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите сделать кнопочку для получения данных справочника  (Прочитано 4369 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Королева Юлия

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-07-19
  • Сайт: 
  • Профессия: Консультант 1С
Доброго времени суток!
Прошу помочь решить следующую проблему:
есть справочник в котором  храниться наименование тары и вес
так же есть документ в котором добавлена кнопочка получить вес тары, в табличной части соответственно есть и тара и вес, как сделать чтоб при нажатии кнопочки из справочника отбиралась тара (в соответствии с указанной в документе) и в табличную часть вставал вес тары....


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Выполняете проход табличной части документа с обращением к нужному справочнику при нажатии на кнопку и далее выполняете подстановку и него же... Ничего сложного там нет.

Оффлайн den_vrn

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-16
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн Королева Юлия

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-07-19
  • Сайт: 
  • Профессия: Консультант 1С

эээ.... а можно по подробнее...
хочу попросить пример..., если не сложно :nhsrm:

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Пока занят. Закрытие квартала у нас. Позже напишу.

Оффлайн Королева Юлия

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-07-19
  • Сайт: 
  • Профессия: Консультант 1С

Вот такую штуку написала:

Процедура КоманднаяПанель1ВосстановитьВесТары(Кнопка)
   Запрос = Новый Запрос;
   Запрос.УстановитьПараметр("ВесТары", Транспорт.ВесВагона);
   ТекстЗапроса = "ВЫБРАТЬ
   |   Справочники.узтмВагоны.Наименование                      КАК Вагон,
   |   Справочники.узтмВагоны.ВесВагона                           КАК ВесВагона
   |ИЗ
   |   Справочники.узтмВагоны(&Вагон, &ВесВагона) КАК ВесТары
   |   
   |   ВНУТРЕННЕЕ СОЕДИНЕНИЕ (
   |      ВЫБРАТЬ
   |         Транспорт.Код    КАК Транспорт
   |      ИЗ
   |         Документ.узтмСправкаОВзвешиванииВагонов.Транспорт     
   |      ГДЕ
   |         Транспорт.Код = &Вагон)
   //|      СГРУППИРОВАТЬ ПО
   //|         Вагоны.Транспорт.Код)КАК Вагон
   |";
   Запрос.Текст = ТекстЗапроса;
   Запрос.УстановитьПараметр("ВесТары", Транспорт.ВесВагона);
   Результат = Запрос.Выполнить();
   Если Результат.Пустой() Тогда
      Возврат;
   КонецЕсли;
   
   Выборка = Результат.Выбрать();
   Пока Выборка.Следующий() Цикл
      ВесВагона = ВесВагона.Добавить();
      ЗаполнитьЗначенияСвойств(Транспорт.ВесВагона, Выборка);
   КонецЦикла;
   
   ТаблицыДанныхДокумента = Новый Структура;
   ТаблицыДанныхДокумента.Вставить("Транспорт", ВесВагона);
   КонецПроцедуры

А он ругается:
{Документ.узтмСправкаОВзвешиванииВагонов.Форма.ФормаДокумента(236)}: Ошибка при вызове метода контекста (Выполнить)
   Результат = Запрос.Выполнить();
по причине:
{(14, 1)}: Ожидается псевдоним запроса


Что не так, понять не могу  :dfbsdfbsdf: :nhsrm:

Оффлайн den_vrn

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-16
  • Сайт: 
  • Профессия: Программист 1С
Запрос не правильно написан, попробуй заново его сделать.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 291
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal