Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 03:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема со встроенным языком  (Прочитано 2265 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Герман Штайнер

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-07-15
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте , я обучаюсь программированию в среде 1с 8.2. Обучаюсь по книжке Сергея Кашаева "1c:Предприятие 8 учимся программировать на примерах". Код процедуры созданный конструктором печать в 8.2 очень отличается от того что представлен в книге.

Например текст в книге выглядит так :

Процедура Печать (Элемент)
ТабДок = Новый ТабличныйДокумент;
Макет = Справочники.Курсы.ПолучитьМакет ("Печать");
Область = Макет.ПолучитьОбласть ("Заголовок");
ТабДок. Вывести (Область);
Выборка =  Справочники.Курсы.Выбрать ();
Пока Выборка. Следующий () = Истина Цикл
Объект = Выборка.ПолучитьОбъект ();
Область = Макет.ПолучитьОбласть ("Элемент");
Область.Параметры.Наименование = Объект. Наименование;
Область.Параметры.ДатаНачала = Объект. ДатаНачала;
Область.Параметры.Продолжительность =Объект. Продолжительность;
Область.Параметры.Стоимость = Объект. Стоимость;
Область.Параметры.Преподаватель = Объект. Преподаватель;
ТабДок. Вывести (Область);
    КонецЦикла;
   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Ложь;
   ТабДок.ТолькоПросмотр = Ложь;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   
КонецПроцедуры

а в 1с 8.2 так :
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
   //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
         ТабДок = Новый ТабличныйДокумент;
   Печать(ТабДок, ПараметрКоманды);

   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Ложь;

   ТабДок.ТолькоПросмотр = Ложь;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   //}}
КонецПроцедуры

&НаСервере
Процедура Печать(ТабДок, ПараметрКоманды)
   Справочники.Курсы.Печать(ТабДок, ПараметрКоманды);
КонецПроцедуры

Вопрос , как адаптировать код предложенный в книге для работы в 1с 8.2?


Код в книге :
Процедура Печать (Элемент)
ТабДок = Новый ТабличныйДокумент;
Макет = Справочники.Курсы.ПолучитьМакет ("Печать");
Область = Макет.ПолучитьОбласть ("Заголовок");
ТабДок. Вывести (Область);
Область = Макет.ПолучитьОбласть ("Шапка");
ТабДок. Вывести (Область);

      Если (ЭлементыФормы.КороткиеКурсы.Значение = Истина) Тогда
       СтруктураОтбора = Новый Структура;
       СтруктураОтбора юВставить ("Продожительность" ,2);
Выборка = Справочник . Курсы. Выбрать (,, СтруктураОтбора);
       Иначе = Справочники. Курсы.Выбрать();
            КонецЕсли;
Пока Выборка. Следующий () = Истина Цикл
Объект = Выборка.ПолучитьОбъект ();
Область = Макет.ПолучитьОбласть ("Элемент");
Область.Параметры.Наименование = Объект. Наименование;
Область.Параметры.ДатаНачала = Объект. ДатаНачала;
Область.Параметры.Продолжительность =Объект. Продолжительность;
Область.Параметры.Стоимость = Объект. Стоимость;
Область.Параметры.Преподаватель = Объект. Преподаватель;
ТабДок. Вывести (Область);
    КонецЦикла;
   ТабДок.ОтображатьСетку = Ложь;
   ТабДок.Защита = Ложь;
   ТабДок.ТолькоПросмотр = Ложь;
   ТабДок.ОтображатьЗаголовки = Ложь;
   ТабДок.Показать();
   
КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Переходите на книжку именно по 8.2, например Радченко "Практическое пособие разработчика".
Потому что программирование управляемых приложений сильно отличается от обычных...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Не понятно, надо ли изучать именно управляемые формы, для начала может с обычных начать?

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
надо изучать управляемые формы, 1с хочет отказаться от обычных со врменем

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Не понятно, надо ли изучать именно управляемые формы, для начала может с обычных начать?

Как сказал преподаватель из Москвы - чтобы не переучиваться.
Сразу вырабатывать навыки клиент-серверного программирования.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн djvjv

  • ****
  • Сообщений: 262
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2012-03-15
  • Сайт: 
  • Профессия: Программист 8.1
Скажу кратко. Зачем тебе изучать то что со временем канет в лето.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
А я бы сказала так:
1. Если хотим изучать 8.2 - то лучше это делать по книге для 8.2
2. Если хотим изучать 8.1 - то делаем это по текущей книге для 8.1

А вот изучать перекрестно, наверное, не стоит.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1175
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4689
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2418
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3319
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3572
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 205
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal