Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не заполняется таблица товары в документе  (Прочитано 1401 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sergey11111

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-11-17
  • Сайт: 
  • Профессия: Программист 8.1
Здравстуйте Всем . Помогите кто может )
Не заполняется таблица товары в документе Реализация с помощью внешней обработки Заполнение остатков с отбором по основному поставщику

Внешняя обработка Заполнение остатков с отбором по основному поставщику


Перем ПользовательОтказался Экспорт;

Процедура Заполнить(ФормаОбъекта,ТаблицаТовары,КнопкаПанели) Экспорт
   #Если Клиент Тогда
      ТаймаутДиалогов=обПраво("ТаймаутДиалогов");
      Если ТаблицаТовары.Количество()>0 Тогда
         //спросим про очистку
         ОтветПользователя=Вопрос("Таблица товаров будет очищена!",РежимДиалогаВопрос.ДаНет,ТаймаутДиалогов);
         Если ОтветПользователя=КодВозвратаДиалога.Да Тогда
            ТаблицаТовары.Очистить();
         Иначе
            //В данном примере нельзя без очистки, хотя можно потом повторяющие строки сворачивать или еще что-нибудь делать
            Возврат
         КонецЕсли;
      КонецЕсли;
      
   МетаданныеДокумента = ФормаОбъекта.ЭтотОбъект.Метаданные();
   //Заказ внутренний
   
   Если ЕстьРеквизитДокумента("ПодразделениеПолучатель", МетаданныеДокумента) Тогда
      ПодразделениеДокумента = ФормаОбъекта.ПодразделениеПолучатель;
   //Перемещение
   ИначеЕсли ЕстьРеквизитДокумента("СкладПолучатель", МетаданныеДокумента) Тогда
      Если ТипЗнч(ФормаОбъекта.СкладПолучатель) = Тип("СправочникСсылка.СкладыКомпании") Тогда
         ПодразделениеДокумента = ФормаОбъекта.СкладПолучатель.Подразделение;
      ИначеЕсли ТипЗнч(ФормаОбъекта.СкладПолучатель) = Тип("СправочникСсылка.ПодразделенияКомпании") Тогда
         ПодразделениеДокумента = ФормаОбъекта.СкладПолучатель;
      Иначе
         ПодразделениеДокумента = Справочники.ПодразделенияКомпании.ПустаяСсылка();
      КонецЕсли;
   //Заказ поставщику
   ИначеЕсли ЕстьРеквизитДокумента("СкладКомпании", МетаданныеДокумента) Тогда
      ПодразделениеДокумента = ФормаОбъекта.СкладКомпании.Подразделение;
   Иначе
      Предупреждение("Для данного вида документа не удалось определить подразделение матрицы!!!");
      Возврат;
   КонецЕсли;
   Если Не ЗначениеЗаполнено(ПодразделениеДокумента) Тогда
      Предупреждение("Не заполнено подразделение!!!");
      Возврат;
   КонецЕсли;

   
   ПостроительОтчета.Текст = "ВЫБРАТЬ
                             |   ОстаткиТоваровКомпанииОстатки.Номенклатура КАК Номенклатура,
                             |   ОстаткиТоваровКомпанииОстатки.КоличествоОстаток КАК Количество
                       |ИЗ
                             |   РегистрНакопления.ОстаткиТоваровКомпании.Остатки(&КонДата, СкладКомпании.Наименование = ""А. Товарная"") КАК ОстаткиТоваровКомпанииОстатки
                             |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
                             |      ПО ОстаткиТоваровКомпанииОстатки.Номенклатура = ЗначенияСвойствОбъектов.Объект
                             |         И (ЗначенияСвойствОбъектов.Свойство.Наименование = ""ОсновнойПоставщик"")
                             |{ГДЕ
                             |   ЗначенияСвойствОбъектов.Значение КАК ОсновнойПоставщик}
                             |
                             |УПОРЯДОЧИТЬ ПО
                             |   ОстаткиТоваровКомпанииОстатки.Номенклатура.Наименование";
                                                             
                      
   ПостроительОтчета.Параметры.Вставить("КонДата", ФормаОбъекта.Дата);
    Справочники.ЗначенияСвойств.НайтиПоНаименованию("У",Истина,,ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("КлассНоменклатуры",Истина));
   
   ПользовательОтказался = Истина;
   Форма1=ЭтотОбъект.ПолучитьФорму("Форма");
   Форма1.ОткрытьМодально();
   Если ПользовательОтказался Тогда
      //пользователь не нажал кнопку "Выполнить" в форме
      Возврат;
   КонецЕсли;
   
   Состояние("Выполнение запроса...");
   Запрос = ПостроительОтчета.ПолучитьЗапрос();
   Выборка = Запрос.Выполнить().Выбрать();
   
   Состояние("Заполнение документа...");
   //включаем индикатор
   ФормаИндикаторЗагрузкиДокумента = ПолучитьОбщуюФорму("Индикация");
   ФормаИндикаторЗагрузкиДокумента.Открыть();
   ФормаИндикаторЗагрузкиДокумента.ЭлементыФормы.Индикатор.МинимальноеЗначение = 1;
   ФормаИндикаторЗагрузкиДокумента.ЭлементыФормы.Индикатор.МаксимальноеЗначение = Выборка.Количество();
   ФормаИндикаторЗагрузкиДокумента.СтрокаСостояния = "Заполнение документа...";
   Сч = 0;
   Пока Выборка.Следующий() Цикл
      Сч = Сч + 1;
      ФормаИндикаторЗагрузкиДокумента.ЭлементыФормы.Индикатор.Значение = Сч;
      ЧистаяМатрица = Выборка.Количество - Выборка.Остаток;
      Если ЧистаяМатрица <=0 Тогда
         Продолжить;
      КонецЕсли;
      СтрокаТЧ = ТаблицаТовары.Добавить();
      СтрокаТЧ.Номенклатура = Выборка.Номенклатура;
      ФормаОбъекта.ЭтотОбъект.ОбработкаРеквизита("Товары.Номенклатура",СтрокаТЧ);
      СтрокаТЧ.Количество = ЧистаяМатрица;
      //Пересчитаем связанные реквизиты
      ФормаОбъекта.ЭтотОбъект.ОбработкаРеквизита("Товары.Количество",СтрокаТЧ);
   КонецЦикла;
   ФормаИндикаторЗагрузкиДокумента.Закрыть();
   #КонецЕсли
КонецПроцедуры    








Теги:
 

Что такое "Список Значений", "Таблица значений" и "Дерево Значений"?

Автор JahongirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6762
Последний ответ 23 Дек 2011, 16:43
от sergeevds
заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3589
Последний ответ 10 Июн 2013, 22:34
от Sasa1C
Заполнение табличной части при выборе реквизита другой табличной части в документе.

Автор Vlad-93Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 309
Последний ответ 25 Окт 2017, 14:15
от Vlad-93
УТ 11.В документе "Заявка на расходование денежных средств" нет кнопки "Печать"!

Автор Valery3103Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3755
Последний ответ 29 Июн 2012, 18:37
от LexaK
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2028
Последний ответ 05 Мар 2017, 14:36
от Igor100500

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 348
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal