Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 00:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: создание документа  (Прочитано 11369 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн studentca

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2011-10-16
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Кто может подсказать мне мои ошибки в следующем коде :
не получается следующее:
1) строка "Контр.ЗачетАвансов = Перечисления.СпособыЗачетаАвансов.Автоматически" не добавляем, потому что ЗачетАвансов не доступен для записи - как сделать так чтобы он стал доступен?

2) номенклатура не записывается в колонку номенклатура, хотя в сообщении выводится все правильно (пробовала разными способами: просто приравнивала к ТекКонтр.Номенклатура, просто справочник.номенклатура.найтиПоКоду, а последний раз вот таким способом)

3)Если документы с таким номером существует, то он все равно перечитывает и сообщает, что номер не уникален.Как сделать так чтобы он видел это Если НайденнаяСсылка.Пустая() Тогда


    СтрокаНаименования = НСН.Номер;
       Накл = Документы.РеализацияТоваровУслуг;
       НайденнаяСсылка = Накл.НайтиПоНомеру(СтрокаНаименования);
      
       Если НайденнаяСсылка.Пустая() Тогда

       
                
          Контр = Документы.РеализацияТоваровУслуг.СоздатьДокумент();
         Контр.ВидОперации = Перечисления.ВидыОперацийРеализацияТоваров.ПродажаКомиссия;
         Контр.Номер = НСН.Номер;
         Контр.Комментарий = НСН.Номер;
         Контр.Дата = НСН.День;
         Контр.Организация = Справочники.Организации.НайтиПоКоду("000000001");
         Контр.Склад = Справочники.Склады.НайтиПоКоду("000000001");
         Контр.Контрагент = Справочники.Контрагенты.НайтиПоКоду(НСН.Контрагент);
          Контр.ДоговорКонтрагента = Справочники.ДоговорыКонтрагентов.НайтиПоКоду(НСН.Код);
         Контр.ЗачетАвансов = Перечисления.СпособыЗачетаАвансов.Автоматически;
         
         ИскомоеЗначение = НСН.Код;
                           
            СтруктураОтбора = Новый Структура;
            СтруктураОтбора.Вставить("Договор", ИскомоеЗначение);
            НайденныйМассивСтрок = ТЗСост.НайтиСтроки(СтруктураОтбора);
            Для Каждого ТекКонтр Из НайденныйМассивСтрок Цикл
               
               Объект = Контр.Товары.Добавить();
               Номенкл = Справочники.Номенклатура.НайтиПоКоду(ТекКонтр.Номенклатура);
               Объект.Номенклатура = Номенкл.Наименование;
               Сообщить(Объект.Номенклатура);
               Объект.Количество = ТекКонтр.Количество;
               Объект.Цена = ТекКонтр.Цена;
               Объект.Сумма = ТекКонтр.Сумма;
               Объект.СтавкаНДС = ТекКонтр.НДС;
               ЗаполнитьЗначенияСвойств(Объект, ТекКонтр);
 
         КонецЦикла;
         Контр.Записать();
         Контр.ПолучитьФорму().Открыть();
         Если ПроводитьПН = Истина Тогда
          Контр.Записать(РежимЗаписиДокумента.Проведение);
                  КонецЕсли;
   
               КонецЕсли;
            КонецЕсли;
            


Оффлайн nn68

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 3
  • КПД: 18%
  • Регистрация: 2012-05-18
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте Объект.Номенклатура = Номенкл.Ссылка;

Оффлайн studentca

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2011-10-16
  • Сайт: 
  • Профессия: Ученик 1С
Нет так тоже не записывается номенклатура

Оффлайн nn68

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 3
  • КПД: 18%
  • Регистрация: 2012-05-18
  • Сайт: 
  • Профессия: Программист 1С
Метод НайтиПоНомеру(НомерДокумента, ДатаИнтервала) - имеет 2 параметра. Документ, который Вы создаете скорее всего имеет периодическую нумерацию. Поэтому Вам просто нужно указать Дату интервала.

Оффлайн studentca

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2011-10-16
  • Сайт: 
  • Профессия: Ученик 1С
Сделала со 2 параметром, но результат такой же

Оффлайн nn68

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 3
  • КПД: 18%
  • Регистрация: 2012-05-18
  • Сайт: 
  • Профессия: Программист 1С
НайденнаяСсылка = Накл.НайтиПоНомеру(СокрЛП(НСН.Номер), НСН.День) - должна возвращать пустую ссылку, если нет документа с номером  - НСН.Номер  в периоде,где НСН.День- дата из этого периода. Вы проверяли значения  НСН.Номер и НСН.День в отладчике, перед тем, как записать документ? НСН.День - должна быть датой.

Оффлайн studentca

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2011-10-16
  • Сайт: 
  • Профессия: Ученик 1С
у меня получилось с документом, он теперь видит записанные, но как быть с номенклатурой и ЗачетАвансов&Ds не подскажите как можно сделать истинным запись в зачет авансов, и с номенклатурой?

Оффлайн nn68

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 3
  • КПД: 18%
  • Регистрация: 2012-05-18
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте:
Контр.СпособЗачетаАвансов = Перечисления.СпособыЗачетаАвансов.Автоматически;

Оффлайн studentca

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 1
  • КПД: 4%
  • Регистрация: 2011-10-16
  • Сайт: 
  • Профессия: Ученик 1С
ЗачетАвансов получилось, а вот с номенклатурой никак не получается, не подскажите как можно сделать

Оффлайн nn68

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 3
  • КПД: 18%
  • Регистрация: 2012-05-18
  • Сайт: 
  • Профессия: Программист 1С
Какой тип у реквизита табличной части товары "Номенклатура" ?


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15910
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4195
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 620
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7735
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 209
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal