Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 06:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: вывод прайса в две колонки  (Прочитано 8116 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн tema111

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-17
  • Сайт: 
  • Профессия: Ученик 1С

у меня есть макет. в нем таблица из двух колонок: Номенклатура и Цена.
как можно вывести эту таблицу в двух колонках?

то есть так :
Товар1 Цена1                       Товар4 Цена4
Товар2 Цена2                       Товар5 Цена5
Товар3 Цена3                       Товар6 Цена6


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
можно в макете сделать два набора колонок и выводить прайс так
Товар1 Цена1   Товар2 Цена2
Товар3 Цена3   Товар4 Цена4
Товар5 Цена5
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн tema111

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-17
  • Сайт: 
  • Профессия: Ученик 1С
а как заполнять программно-то?

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
??? да вроде все просто как
в строке макета добавляете (копируете) колонки Товар2 и Цена2
в программе вывода, что-то вроде:
...
Пока Выборка.Следующий() цикл
//первая колонка
СтрокаМакета.Параметры.Товар = Выборка.Товар;
СтрокаМакета.Параметры.Цена= Выборка.Цена;
Если Выборка.Следующий() Тогда
   СтрокаМакета.Параметры.Товар2 = Выборка.Товар;
   СтрокаМакета.Параметры.Цена2= Выборка.Цена;
Иначе
   СтрокаМакета.Параметры.Товар2 = "";
   СтрокаМакета.Параметры.Цена2= "";
КонецЕсли;
ТабДокумент.Вывести(СтрокаМакета);
КонецЦикла;
...


Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
??? да вроде все просто как
в строке макета добавляете (копируете) колонки Товар2 и Цена2
в программе вывода, что-то вроде:
...
Пока Выборка.Следующий() цикл

//первая колонка
СтрокаМакета.Параметры.Товар = Выборка.Товар;
СтрокаМакета.Параметры.Цена= Выборка.Цена;

//вторая колонка
Если Выборка.Следующий() Тогда
   СтрокаМакета.Параметры.Товар2 = Выборка.Товар;
   СтрокаМакета.Параметры.Цена2= Выборка.Цена;
Иначе
   СтрокаМакета.Параметры.Товар2 = "";
   СтрокаМакета.Параметры.Цена2= "";
КонецЕсли;

ТабДокумент.Вывести(СтрокаМакета);

КонецЦикла;
...

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Либо сделать  - сначала вывести область товар+цена, затем присоединить эту же область, потом опять вы вести, потом присоединить, будет тот же эффект)
Тазовод)

Оффлайн tema111

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-04-17
  • Сайт: 
  • Профессия: Ученик 1С
при таком коде вообще ничего не выводит=(

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
	// Вставить содержимое обработчика.
Запрос = Новый запрос;
Запрос.Текст =

//Какой-то запрос.........

Выборка = Запрос.Выполнить().Выбрать();


Таб = Новый ТабличныйДокумент;
Макет = ПолучитьМакет("Макет");
Счетчик =1;
Пока Выборка.Следующий() цикл
СтрокаМакета  = Макет.ПолучитьОбласть("Строка|ТоварЦена");
СтрокаМакета.Параметры.Товар = Выборка.Товар;
СтрокаМакета.Параметры.Цена= Выборка.Цена;
Если Счетчик = 1 Тогда //первая колонка
ТабДокумент.Вывести(СтрокаМакета);
Счетчик = 2;
Иначе
СтрокаПустая  = Макет.ПолучитьОбласть("Строка|Пустая");
ТабДокумент.Вывести(СтрокаПустая);
ТабДокумент.Присоединить(СтрокаМакета);
КонецЕсли;
КонецЦикла;

Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
 вот фото макета
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
простите чуть спутала - вместо
            СтрокаПустая  = Макет.ПолучитьОбласть("Строка|Пустая");
            ТабДокумент.Вывести(СтрокаПустая);
 
вставить
 СтрокаПустая  = Макет.ПолучитьОбласть("Строка|Пустая");
          ТабДокумент.Присоединить(СтрокаПустая);
Тазовод)


Теги:
 

Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 208
Последний ответ 07 Окт 2017, 19:03
от Norfolk
Вывод результата запроса через условие другого запроса

Автор jonik_jokerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2905
Последний ответ 16 Окт 2013, 15:08
от jonik_joker
Вывод линейной таблицы посредством СКД в виде "шахматки"

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 10736
Последний ответ 19 Апр 2011, 11:12
от Klyacksa
Вывод набора данных "объединение" скд в дерево значений

Автор Gae4kaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1554
Последний ответ 02 Июн 2015, 12:19
от Gae4ka
Как добавить вывод ДоговораКонтрагента в печатную форму "Счет на оплату"

Автор ValentusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 12960
Последний ответ 09 Июн 2010, 15:25
от Karamelkina

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 138
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal