Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 12:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Нужна помощь программиста!  (Прочитано 2891 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dgalanov

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-22
  • Сайт: 
  • Профессия: Бухгалтер
Документ попадает только при точном совпадении ДДММГГГГ:ЧЧММСС (Если ВыборкаДокументов.Дата()=ЭтотОбъект.Дата() Тогда), надо чтобы заполнение происходило без учета времени ЧЧММСС т.е. документами у которых совпадает только дата ДДММГГ!


Процедура КоманднаяПанельОснованиеДействиеЗаполнить(Кнопка)
   Перем ДатаСледующегоВыпуска;

   ВыборкаДокументовВЫпускПродукции=Документы.ОбщепитВыпускПродукции.Выбрать(ЭтотОбъект.Дата,);
   Пока ВыборкаДокументовВЫпускПродукции.Следующий() цикл
      Если ВыборкаДокументовВЫпускПродукции.ПометкаУдаления=Ложь И 
         ЭтотОбъект.Дата<>ВыборкаДокументовВЫпускПродукции.Дата тогда
         ДатаСледующегоВыпуска=ВыборкаДокументовВЫпускПродукции.Дата;
         Прервать;
      КонецЕсли;   
   КонецЦикла;
   
   ОбщепитДокументыОснования.Очистить();
   Товары.Очистить();
   ВыборкаДокументов = Документы.РеализацияТоваровУслуг.Выбрать(ЭтотОбъект.Дата,ДатаСледующегоВыпуска );
   
   Пока ВыборкаДокументов.Следующий() Цикл
   Если ВыборкаДокументов.Дата()=ЭтотОбъект.Дата() Тогда
      ЭлементыФормы.ДокументыОснования.ДобавитьСтроку();
      
      СтрокаТаблицы =ЭлементыФормы.ДокументыОснования.ТекущаяСтрока;
      СтрокаТаблицы.ДокументОснование=ВыборкаДокументов.Ссылка;
      
   //   ЗначениеВыбора=ВыборкаДокументов.Товары.Выгрузить();
      
      Для Каждого СтрокаТоваров Из ВыборкаДокументов.Товары Цикл
         Если СтрокаТоваров.Номенклатура.ОбщепитВидНоменклатуры=Перечисления.ОбщепитВидыНоменклатуры.Блюдо тогда
            
            // Ищем выбранную позицию в таблице подобранной номенклатуры.
            //  Если найдем - увеличим количество; не найдем - добавим новую строку.
            СтруктураОтбора = Новый Структура();
            СтруктураОтбора.Вставить("Номенклатура",     СтрокаТоваров.Номенклатура);
            СтруктураОтбора.Вставить("ЕдиницаИзмерения", СтрокаТоваров.ЕдиницаИзмерения);
            
            //Если ЗначениеЗаполнено(Цена) Тогда
            //   СтруктураОтбора.Вставить("Цена", Цена);
            //КонецЕсли; 
            СтрокаТабличнойЧасти = ОбработкаТабличныхЧастей.НайтиСтрокуТабЧасти(Товары, СтруктураОтбора);
            
            Если СтрокаТабличнойЧасти <> Неопределено Тогда
               СтрокаТабличнойЧасти.Количество = СтрокаТабличнойЧасти.Количество + СтрокаТоваров.Количество;
               // Рассчитать реквизиты табличной части.
               ОбработкаТабличныхЧастей.РассчитатьСуммуТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
               ОбработкаТабличныхЧастей.РассчитатьСуммуНДСТабЧасти(СтрокаТабличнойЧасти, ЭтотОбъект);
            иначе   
               ЗаполнитьЗначенияСвойств(Товары.Добавить(), СтрокаТоваров);
               
            КонецЕсли;
         КонецЕсли;
      КонецЦикла;
                  КонецЕсли;

   КонецЦикла;
   КоманднаяПанельПроизводствоДействиеЗаполнить(Кнопка);
КонецПроцедуры


Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
можно использовать
Если НачалоДня(ВыборкаДокументов.Дата) = НачалоДня(ЭтотОбъект.Дата) Тогда
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Используйте функцию Дата() или преобразование через Формат
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
можно использовать
Если НачалоДня(ВыборкаДокументов.Дата) = НачалоДня(ЭтотОбъект.Дата) Тогда
Как вариант)
Тазовод)

Оффлайн dgalanov

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-22
  • Сайт: 
  • Профессия: Бухгалтер
можно использовать
Если НачалоДня(ВыборкаДокументов.Дата) = НачалоДня(ЭтотОбъект.Дата) Тогда

Спасибо ))) работает

Оффлайн SergeiB

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-07-04
  • Сайт: 
  • Профессия: Программист 8.1
Для перевода даты в формат ДДММГГ, можно воспользоваться функцией формат().
Пример ДатаТек = Формат(ТекущаяДата(),"ДФ=ддММгг"), соответственно сравнение производить:
Формат(ЭтотОбъект.Дата,"ДФ=ддММгг")<>Формат(ВыборкаДокументовВЫпускПродукции.Дата ,"ДФ=ддММгг")

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Для перевода даты в формат ДДММГГ, можно воспользоваться функцией формат().
Пример ДатаТек = Формат(ТекущаяДата(),"ДФ=ддММгг"), соответственно сравнение производить:
Формат(ЭтотОбъект.Дата,"ДФ=ддММгг")<>Формат(ВыборкаДокументовВЫпускПродукции.Дата ,"ДФ=ддММгг")

Лучше сравнивать именно даты.
В данном случае сравниваются строки.
Хотя надо признать что требуемый результат - будет получен.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 277
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal