Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 03:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите пожалуйста с обработкой  (Прочитано 3272 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Василий

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-04-27
  • Сайт: 
Я делал перенос из Айлант ЖКХ с помощью универсальной обработки ЗагрузкаВыгрузка.xml. Всё перенеслось, но при открытие справочник-лицевые счета в лицевом счете не указана организация(вместо этого написано объект на найден), а чтобы в каждом лицевом счете изменить на организацию которую надо слишком долго. Как написать обработку чтоб все лицевые счета открывались и заполнялись


Оффлайн oltie

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 8
  • КПД: 13%
  • Регистрация: 2011-08-21
  • Сайт: 
  • Профессия: Разработчик 1С
в какую конфигурацию-то сделали перенос? и что из себя представляет справочник "лицевые счета" ?

Оффлайн Василий

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-04-27
  • Сайт: 
в какую конфигурацию-то сделали перенос? и что из себя представляет справочник "лицевые счета" ?
В такую же 8,2. в справочнике занесены все лицевые счета при открытии лицевого счета в нем указаны площадь, помещение, здание. Всё это перенеслось корректно, но вот организация нет

Оффлайн oltie

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 8
  • КПД: 13%
  • Регистрация: 2011-08-21
  • Сайт: 
  • Профессия: Разработчик 1С
сложно сказать, не видя конфигурации. Но если надо пройтись по лицевым счетам и проставить организацию, то сделай это вот так, например. только надо исправить на правильные справочники, но чуть будет такая же.

Процедура КнопкаВыполнитьНажатие(Кнопка)
   ВыбНмк= Справочники.СотрудникиОрганизаций.Выбрать();
   Пока ВыбНмк.Следующий() Цикл      
      об = ВыбНмк.ПолучитьОбъект();
          Попытка
                                 об.Организация = Справочники.Организации.НайтиПоКоду("000000001").Ссылка;
             об.Записать();                                           
         исключение
            сообщить(об.Наименование);
          конецпопытки;        
   КонецЦикла; 
КонецПроцедуры

Оффлайн Василий

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-04-27
  • Сайт: 
сложно сказать, не видя конфигурации. Но если надо пройтись по лицевым счетам и проставить организацию, то сделай это вот так, например. только надо исправить на правильные справочники, но чуть будет такая же.

Процедура КнопкаВыполнитьНажатие(Кнопка)
   ВыбНмк= Справочники.СотрудникиОрганизаций.Выбрать();
   Пока ВыбНмк.Следующий() Цикл      
      об = ВыбНмк.ПолучитьОбъект();
          Попытка
                                 об.Организация = Справочники.Организации.НайтиПоКоду("000000001").Ссылка;
             об.Записать();                                           
         исключение
            сообщить(об.Наименование);
          конецпопытки;        
   КонецЦикла; 
КонецПроцедуры

А как мне бы разместить картинку чтобы было более понятно какую именно обработку я хочу?

Оффлайн oltie

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 8
  • КПД: 13%
  • Регистрация: 2011-08-21
  • Сайт: 
  • Профессия: Разработчик 1С
добавьте просто к сообщению картинку, а что вы хотите показать? картинку конфигурации? :)

Оффлайн Василий

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-04-27
  • Сайт: 
Вот примерная картинка. В том месте где обведено необходимо чтоб при обработке выбиралась организация

Оффлайн oltie

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 8
  • КПД: 13%
  • Регистрация: 2011-08-21
  • Сайт: 
  • Профессия: Разработчик 1С
ну так я дала вам уже готовый код, замените названия на названия ваших справочников и будет вам счастье

Оффлайн Василий

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-04-27
  • Сайт: 
ну так я дала вам уже готовый код, замените названия на названия ваших справочников и будет вам счастье
Извините, ноя полный ноль в этом может поподробней напишите как и что или может посоветуете какую нить книгу по изучению таких моментов которую вы знаете?

Оффлайн Василий

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-04-27
  • Сайт: 
ну так я дала вам уже готовый код, замените названия на названия ваших справочников и будет вам счастье
В модуле объекта я написал

Процедура КнопкаВыполнитьНажатие(Кнопка)
   ВыбНмк=Справочники.ЛицевыеСчета.Выбрать();
   Пока ВыбНмк.Следующий() Цикл     
      об = ВыбНмк.ПолучитьОбъект();
          Попытка
                                 об.Организация = Справочники.Организации.НайтиПоКоду("000000001").Ссылка;
             об.Записать();                                           
         исключение
            сообщить(об.Наименование);
          конецпопытки;         
   КонецЦикла; 
КонецПроцедуры

Но при открытии результатов никаких. Что еще нужно сделать или что я не правильно написал?


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4300
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5556
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5895
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4381
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1982
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 128
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal