Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 10:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Код для заполнения аналитики у счета 68.01 (конифгурация ЗУП 2.5)  (Прочитано 3254 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Помогите разобраться , в документе отражение зарплаты в регл учете формируется проводка Дт 76.05 Кр 68.01 , на счете 68.01 подразделение не проставляется, ниже привожу код, который бы якобы должен проставлять подразделение , но отрабатывается, подскажите где допущена ошибка



---------------Дб 76.05 Кр 68.01
Процедура КнопкаВыполнитьНажатие(Кнопка)
 Док = ВыбДок.ПолучитьОбъект();

 Для Каждого Строка Из Док.ОтражениеВУчете Цикл
 Если Строка.СчетДт.Код = "76.5" и Строка.СчетКт.Код = "68.01" Тогда
 ФизЛицо = Строка.СубконтоДт1.Ссылка;
 Сотрудник = Справочники.СотрудникиОрганизаций.НайтиПоРеквизиту("Физлицо" ,ФизЛицо);
 Подразделение = Сотрудник.ТекущееПодразделениеОрганизации.Ссылка;
 Строка.ПодразделениеКт = Подразделение;
 КонецЕсли;
 КонецЦикла;
 Док.Записать();

КонецПроцедуры
------------------------------


Оффлайн 1Cnastroika

Посмотрите в отладчике значения переменных при выполнении программы.

Оффлайн oltie

  • **
  • Сообщений: 60
  • РЕПУТАЦИЯ: 8
  • КПД: 13%
  • Регистрация: 2011-08-21
  • Сайт: 
  • Профессия: Разработчик 1С
ваш код работоспособный. подразделение подставляется. однако, есть два замечания. я бы подразделение искала бы через запрос
Строка.ПодразделениеКт = ПолучитьПодразделение(Строка.СубконтоДт1.Ссылка);

Запрос.Текст =    "ВЫБРАТЬ
                   |   СотрудникиОрганизаций.ТекущееПодразделениеОрганизации.Ссылка
                   |ИЗ
                   |   Справочник.СотрудникиОрганизаций КАК СотрудникиОрганизаций
                   |ГДЕ
                   |   СотрудникиОрганизаций.Физлицо = &ФизЛицо"   ;
   Запрос.Параметры.Вставить("ФизЛицо", Физлицо);

а во-вторых, если у вас в БП стоит галочка "учет ведется во внешней программе", то у вас просто нет данных для заполнения, т.е. подразделения не проставлены будут, т.к. кадровые документы в ЗУПе, соответственно и подразделение будет возвращаться как пустая ссылка, которую он и подставит


Теги:
 

Значение поля "Лицевой счет" содержит недопустимое значение типа лицевого счета

Автор unantedРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3827
Последний ответ 24 Июл 2012, 05:02
от unanted
Не выгружается документ основания для счета фактуры с типом возврат, когда документ основание поступление выгружается, КД 2

Автор Алексей ГеннадьевичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 377
Последний ответ 21 Апр 2017, 04:55
от Алексей Геннадьевич
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 221
Последний ответ 18 Авг 2017, 11:57
от ZSS
Отчет "Обороты счета"

Автор evgeniy1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5548
Последний ответ 02 Апр 2013, 13:14
от Besart
Синтаксическая ошибка "ИЗ" <<?>>ИЗ при печати счета ут 10.3

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4010
Последний ответ 02 Дек 2013, 14:42
от romanprogrammist

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 886
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal