Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 18:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с заполнением табличной части  (Прочитано 5190 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
Помогите пожалуйста, я не программист, а очень надо:
Суть проблемы: при выгрузке из УТ в БП в бухгалтерию передаются документы реализации, в которых в товаре указывается ставка НДС, но так же в бухгалтерии есть столбец под названием субконто (в нашем случае туда должны проставляться номенклатурные группы, которые у нас называются товар с НДС 10, товар с НДС 18 и товар без НДС). Вот, при выгрузке это поле остается пустым и потом месяц не закрывается, приходится групповой обработкой делать каждый месяц, хотелось бы упростить это при помощи внешней обработки заполнения табличных частей, чтобы при нажатии кнопки "заполнить субконто" в зависимости от ставки НДС Номенклатуры присваивалось субконто номенклатурной группы, т.е. примерно так: Товар с о ставкой НДС 10%, значит при нажатии кнопки заполнялось субконто"10%" и.т.д. Пытался при помощи "Процедура Инициализировать(Объект,ИмяТабличнойЧасти,ТабличноеПолеОбъекта) Экспорт", но выборку сделать не могу. Пожалуйста помогите. Вроде такая легкотня,но не по мне


Оффлайн 1Cnastroika

Если в документе на закладке данные есть табличная часть с именем "Товары", то строки табличной части обходят так:

Для Каждого Товар Из Товары Цикл

КонецЦикла;

Оффлайн LexaK

  • *****
  • Сообщений: 1267
  • РЕПУТАЦИЯ: 347
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
а зачем так сложно, писать какие-то обработки? подправьте обмен данными, что бы он сразу в БП писал то что надо!
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
Если в документе на закладке данные есть табличная часть с именем "Товары", то строки табличной части обходят так:

Для Каждого Товар Из Товары Цикл

А что в теле самого цикла писать? В этом-то и вся проблема
КонецЦикла;

Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
Ребят, ну очень надо, помогите пожалуйста

Оффлайн 1Cnastroika

Сначала во внешней обработке нужно выбрать документы и сделать обход выборки:

Выборка = Документы.Реализация.Выбрать(НачДата, КонДата);

Пока Выборка.Следующий() Цикл
   ДокОбъект = Выборка.ПолучитьОбъект();
   // Обход табличной части
   

КонецЦикла;

Оффлайн 1Cnastroika

Выборка = Документы.Реализация.Выбрать(НачДата, КонДата);

Пока Выборка.Следующий() Цикл
   ДокОбъект = Выборка.ПолучитьОбъект();
   // Обход табличной части
   Для Каждого Товар Из ДокОбъект.Товары Цикл
        Если Товар.СтавкаНДС = Справочники.СтавкиНДС.НайтиПоНаименованию("10%") Тогда
              Товар.Субконто = // Субконто 10%
       Иначе Если Товар.СтавкаНДС = Справочники.СтавкиНДС.НайтиПоНаименованию("20%") Тогда
              Товар.Субконто = // Субконто 10%
       КонецЕсли;
   КонецЦикла;
  ДокОбъект.Записать();

КонецЦикла;

Приблизительно так.

Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
Процедура Инициализировать(Объект,ИмяТабличнойЧасти,ТабличноеПолеОбъекта) Экспорт
   Для Каждого Товар Из Объект.Товары Цикл
        Если Товар.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС Тогда
             Товар.Субконто = "Без НДС";
           КонецЕсли;
   КонецЦикла;
КонецПроцедуры


Вот так не заполняется, что я делаю не так?

Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
Процедура Инициализировать(Объект,ИмяТабличнойЧасти,ТабличноеПолеОбъекта) Экспорт
   Для Каждого Товар Из Объект.Товары Цикл
    Если Товар.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС Тогда
        Товар.Субконто = "Товар без НДС"
   ИначеЕсли Товар.СтавкаНДС = Перечисления.СтавкиНДС.НДС10 Тогда
      Товар.Субконто = "Товар с НДС 10%"
   ИначеЕсли Товар.СтавкаНДС = Перечисления.СтавкиНДС.НДС18 Тогда
        Товар.Субконто = "Товар с НДС 18%"
   КонецЕсли   
   КонецЦикла;
КонецПроцедуры


Вот полный код, только не заполняется

Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
Все получилось, сделал вот так:

Процедура Инициализировать(Объект,ИмяТабличнойЧасти,ТабличноеПолеОбъекта) Экспорт
Для Каждого Товар Из Объект.Товары Цикл
      Если Товар.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС Тогда
        Товар.Субконто = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Товар без НДС")
   ИначеЕсли Товар.СтавкаНДС = Перечисления.СтавкиНДС.НДС10 Тогда
      Товар.Субконто = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Товар с НДС 10%")
   ИначеЕсли Товар.СтавкаНДС = Перечисления.СтавкиНДС.НДС18 Тогда
        Товар.Субконто = Справочники.НоменклатурныеГруппы.НайтиПоНаименованию("Товар с НДС 18%")
   КонецЕсли   
КонецЦикла;
КонецПроцедуры

Всем огромное спасибо


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4292
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5551
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5885
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4366
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1978
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 590
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal