Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 18:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите написать обработку пометка на удаление  (Прочитано 7403 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Хочу написать обработку пометка на удаление с помощью запроса.
Запрос составил правильно. Но все равно не работает помогите разобраться:

&НаКлиенте
Процедура Пометка(Команда)

ПометкаНаУдалениеНаСервере();

КонецПроцедуры


&НаСервереБезКонтекста
Процедура ПометкаНаУдалениеНаСервере()



Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Номенклатура.Ссылка
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| НЕ Номенклатура.ЭтоГруппа
| И НЕ Номенклатура.Предопределенный";

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

ВыборкаДетальныеЗаписи.Получить();

ВыборкаДетальныеЗаписи.УстановитьПометкуУдаления(Истина);



КонецЦикла;




КонецПроцедуры



Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
С помощью запросов можно только читать данные, а вот модифицировать нельзя...
Нужно сделать примерно так:
   выборка = Справочники.Номенклатура.Выбрать();
   Пока выборка.Следующий() Цикл
      Если НЕ (Выборка.Предопределенный ИЛИ Выборка.ЭтоГруппа) Тогда
         спрОбъект = выборка.ПолучитьОбъект();
         спрОбъект.ПометкаУдаления = Истина;
         спрОбъект.Записать();
      КонецЕсли;
   КонецЦикла;

PS. А ведь иногда не хватает в языке запросов 1С секции UPDATE, не правда ли? :)

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
Или лучше вместо моего фрагмента
   спрОбъект.ПометкаУдаления = Истина;
   спрОбъект.Записать();
сделать как у вас с помощью метода УстановитьПометкуУдаления(<ПометкаУдаления>, <ВключаяПодчиненные>)
   спрОбъект.УстановитьПометкуУдаления(Истина,Истина);

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Я так полагаю, что с помощью запроса это сделать нельзя?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
С помощью запроса можно только получить список который бы будешь обходить в цикле и помечать на удаление....
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
А можете мой запрос доделать. Почему он не работает.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Тебе же написали почему!
Потому что нужно получатьОбъект!!
Заменить ----
ВыборкаДетальныеЗаписи.Получить();
ВыборкаДетальныеЗаписи.УстановитьПометкуУдаления(Истина);
\НА вот так
ВыборкаДетальныеЗаписи.Номенклатура.ПолучитьОбъект().УстановитьПометкуУдаления(Истина);
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
И последний вопрос.
Почему когда ставишь "." подсказка то вылезает то нет.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Фиг знает, да и не нужно это.....
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Просто с подсказкой легче. сразу знаешь, что можно использовать а что нет....


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4292
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5551
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5885
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4366
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1978
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 550
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal