Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 16:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите пожалуйста разораться с вариантами отчета СКД!!!  (Прочитано 2878 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Лейсан

  • ***
  • Сообщений: 142
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-12
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день!Делаю отчет в СКД.Создала 2 варианта отчета.на форму вывела поле выбора варианта отчета,но почему то у меня не показываются варианты отчетов.

+ Code
Процедура ПриОткрытии()
       
    Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    Для каждого вариант из макет.ВариантыНастроек Цикл
        ЭлементыФормы.Варианты.СписокВыбора.Добавить(вариант.Представление);
    КонецЦикла;
    Варианты = ЭлементыФормы.Варианты.СписокВыбора[0].значение;
   
КонецПроцедуры

Процедура ВариантыПриИзменении(Элемент)
     Макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    настройки=ОпределитьНастройки(макет, элемент.значение);
    КомпоновщикНастроек.ЗагрузитьНастройки(настройки);
    ЭлементыФормы.Результат.Очистить();
    СкомпоноватьРезультат(ЭлементыФормы.Результат,ДанныеРасшифровки);

КонецПроцедуры
 Функция ОпределитьНастройки(Макет, представлениеМакета)
Для каждого вариант из макет.ВариантыНастроек Цикл
        если вариант.Представление=представлениеМакета тогда
            настройки=вариант.настройки;
        КонецЕсли;
    КонецЦикла;
Возврат настройки;
КонецФункции

Подскажите пожалуйста,где я что не правильно сделала


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4291
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5547
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5883
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4361
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1976
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 850
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal