Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Предупреждения на все компьютеры  (Прочитано 2024 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн crazykapter

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-05-04
  • Сайт: 
  • Профессия: Программист 7.7
Здравствуйте!

Подскажите пожалуйста такую вещь. Можно ли стандартными средствами вывести на все компьютеры в сети предупреждение о необходимости выхода из 1с (для сохранения ИБ), и как это организовать.

Заранее благодарю.


Оффлайн Вячеслав62

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 5
  • КПД: 5%
  • Регистрация: 2010-11-09
  • Сайт: 
  • Профессия: Программист 7.7
Процедура тмОбработка()
   Если СокрЛП(Константа.тмВремя)=Лев(ТекущееВремя(),5) Тогда
      Предупреждение("Работа программы будет завершена через 10 секунд.",10);
      Если НЕ(НазваниеНабораПрав(1)="") Тогда
         ЗавершитьРаботуСистемы(0);
      КонецЕсли;
   КонецЕсли;   
   
   Если СокрЛП(Константа.тмЮзер)="" Тогда
      Если      Константа.тмДействие = 1 Тогда
         Предупреждение(Константа.тмТекст,30);
      ИначеЕсли Константа.тмДействие = 2 Тогда
         Предупреждение("Работа программы будет завершена через 10 секунд.",10);
         Если НЕ(НазваниеНабораПрав(1)="") Тогда
            ЗавершитьРаботуСистемы(0);
         КонецЕсли;
      КонецЕсли;   
   Иначе
      Если СокрЛП(Константа.тмЮзер)=СокрЛП(ИмяПользователя()) Тогда
         Предупреждение(Константа.тмТекст);
         Константа.тмТекст = "";
         Константа.тмЮзер  = "";
      КонецЕсли;   
   КонецЕсли;   
   
КонецПроцедуры // тмОбработка

Всё это пишешь в глобальном модуле.Потом создаешь константы ; тмЮзер, тмДействие,тмВремя,тмТекст.

Для того что бы выбросить пользователей из сети просто в константах ствишь в поле тмДействие цифру 1.Появится предупреждение на всех мониторах пользователей.Если сами не выйдут то ставишь цифру 2. Выбросит всех. Не забудь после того как вернешь базу в работу поставить 0 в действия.

Оффлайн Вячеслав62

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 5
  • КПД: 5%
  • Регистрация: 2010-11-09
  • Сайт: 
  • Профессия: Программист 7.7
Да, и еще. в константах пропиши там где тмДействие--Работа программы будет завершена через 10 минут.

Оффлайн Вячеслав62

  • **
  • Сообщений: 93
  • РЕПУТАЦИЯ: 5
  • КПД: 5%
  • Регистрация: 2010-11-09
  • Сайт: 
  • Профессия: Программист 7.7
Извини, в тмТекст

Оффлайн crazykapter

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-05-04
  • Сайт: 
  • Профессия: Программист 7.7
Огромное спасибо :)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
43 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal