Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 09:26
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Из запроса не выводятся значения полей - выводятся пустые значения  (Прочитано 12255 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex1111

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
Есть запрос:

запрос2=новый запрос;   
   запрос2.Текст=
   "ВЫБРАТЬ
   |ПроцентВладельцу.ДатаЗакрытия как ДатаЗакрытия,
   |ПроцентВладельцу.Период как Период,
   |ПроцентВладельцу.Скидка как Скидка
   |ИЗ
   |РегистрСведений.ПроцентВладельцу КАК ПроцентВладельцу
   |   ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.ИнформационныеКарты КАК ИнформационныеКарты
   |   ПО ПроцентВладельцу.Объект = ИнформационныеКарты.Ссылка
   |   ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Контрагенты КАК Контрагенты
   |   ПО ПроцентВладельцу.Владелец = Контрагенты.Ссылка
   |ГДЕ
   |ИнформационныеКарты.Наименование = """+ИнформационнаяКарта+"""
   |И Контрагенты.Наименование = """+Контрагент+"""
   |УПОРЯДОЧИТЬ ПО ПроцентВладельцу.Период УБЫВ";
   выборка2=запрос2.Выполнить().Выбрать();
   Сообщить(выборка2.Количество()); //выводится 2 (две записи)
   если выборка2.Количество() > 0 Тогда
      пер=выборка2.период;
               ДатаЗакр=выборка2.ДатаЗакрытия;
      скид=выборка2.скидка;

      
      Сообщить("Дата закрытия: " +ДатаЗакр+" период: "+пер+" скидка: "+скид);
      Пока Выборка.Следующий() Цикл
       // ... выведем в окно сообщений поля из результата.
      пер=выборка2.период;
       ДатаЗакр=выборка2.ДатаЗакрытия;
      скид=выборка2.скидка;
                                                             
       Сообщить("Дата закрытия: " +ДатаЗакр+" период: "+пер+" скидка: "+скид);
      КонецЦикла;

В окне сообщений выводится
Дата закрытия:  период:  скидка:
Дата закрытия:  период:  скидка:
т.е. сами значения полей не выводятся, хотя они есть - проверял в режиме Предприятия в соответствующем регистреСведений.
Почему так происходит? Как сделать чтобы показывались значения?


Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте так
Сообщить("Дата закрытия: " +Строка(ДатаЗакр)+" период: "+Строка(пер)+" скидка: "+Строка(скид));
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
а вообще скажите что Вы хотите увидеть?
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Зачем Вам внутреннее соединение с справочником контрагенты? если у Вас условие идет по контрагенту?
Тазовод)

Оффлайн Alex1111

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
Попробуйте так
Сообщить("Дата закрытия: " +Строка(ДатаЗакр)+" период: "+Строка(пер)+" скидка: "+Строка(скид));

Так - тот же результат - значения не показываются

Оффлайн Alex1111

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
а вообще скажите что Вы хотите увидеть?

вообще мне нужно вытащить только дату закрытия. другие поля я специально вывел, чтобы проверить может проблема только в поле "дата закрытия", но оказалось у других то же самое ((

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
запрос2=новый запрос;   
   запрос2.Текст=
   "ВЫБРАТЬ
   |ПроцентВладельцу.ДатаЗакрытия как ДатаЗакрытия,
   |ПроцентВладельцу.Период как Период,
   |ПроцентВладельцу.Скидка как Скидка
   |ИЗ
   |РегистрСведений.ПроцентВладельцу КАК ПроцентВладельцу
   |ГДЕ
   |ПроцентВладельцу.Объект = &ИнформационныеКартыСсылка
   |И ПроцентВладельцу.Владелец =&Контрагент
   |УПОРЯДОЧИТЬ ПО ПроцентВладельцу.Период УБЫВ";
   Выборка2=запрос2.Выполнить().Выбрать();
      Пока Выборка2.Следующий() Цикл
       // ... выведем в окно сообщений поля из результата.
      пер=выборка2.период;
       ДатаЗакр=выборка2.ДатаЗакрытия;
      скид=выборка2.скидка;
                                                            
       Сообщить("Дата закрытия: " +ДатаЗакр+" период: "+пер+" скидка: "+скид);
      КонецЦикла;

И Потом установить параметр контрагента.... и информационных карт
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
вот так -
запрос2=новый запрос;   
   запрос2.Текст=
   "ВЫБРАТЬ
   |ПроцентВладельцу.ДатаЗакрытия как ДатаЗакрытия,
   |ПроцентВладельцу.Период как Период,
   |ПроцентВладельцу.Скидка как Скидка
   |ИЗ
   |РегистрСведений.ПроцентВладельцу КАК ПроцентВладельцу
   |ГДЕ
   |ПроцентВладельцу.Объект = &ИнформационныеКартыСсылка
   |И ПроцентВладельцу.Владелец =&Контрагент
   |УПОРЯДОЧИТЬ ПО ПроцентВладельцу.Период УБЫВ";
запрос2.УстановитьПараментр("ИнформационныеКартыСсылка",ИнформационныеКарты);
запрос2.УстановитьПараментр("Контрагент",Контрагент);
   Выборка2=запрос2.Выполнить().Выбрать();
      Пока Выборка2.Следующий() Цикл
       // ... выведем в окно сообщений поля из результата.
      пер=выборка2.период;
       ДатаЗакр=выборка2.ДатаЗакрытия;
      скид=выборка2.скидка;
                                                             
       Сообщить("Дата закрытия: " +ДатаЗакр+" период: "+пер+" скидка: "+скид);
      КонецЦикла;
Тока уточните почему Вы берете Контрагент.Наименование, ИнформационныеКарты.наименование - а не ссылки на объекты??
Тазовод)

Оффлайн Alex1111

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
{РегистрСведений.ВладельцыДисконтныхКарт.Форма.ФормаЗаписи(77)}: Метод объекта не обнаружен (УстановитьПараментр)
   запрос2.УстановитьПараментр("ИнформационныеКартыСсылка",Справочники.ИнформационныеКарты);

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
так погодите...ИнформационныеКарты у Вас что это? реквизиты, которые выбираются на форме?
сорри
запрос2.УстановитьПараметр("ИнформационныеКартыСсылка",ИнформационныеКарты);
запрос2.УстановитьПараметр("Контрагент",Контрагент);
Тазовод)


Теги:
 

"ПОДОБНО" в условие связи запроса

Автор Станиславъ ЗверевъРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 3290
Последний ответ 11 Май 2016, 15:29
от LexaK
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 751
Последний ответ 15 Июн 2017, 07:53
от mvk843
Возможно ли языком запросов без конкатенации текста запроса и без СКД преобразовать строки таблицы в столбцы (колонки) выходной таблицы?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 453
Последний ответ 29 Май 2017, 15:29
от alex0402
Ошибка при выполнении запроса - "неоднозначное поле"

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 11968
Последний ответ 21 Апр 2011, 16:00
от Marta_Li
Где найти вкладку "Параметры", в конструкторе запроса при создании динамического списка?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 820
Последний ответ 09 Мар 2017, 14:48
от LexaK

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 168
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal