Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 05:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Подсветка поля ввода по условию  (Прочитано 6123 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! Необходимо что бы в поле ввода при выборе одного из перечислений фон подкрашивался, например: при выборе "Товар в пути" - фон красный, а "Доставлен" - Зеленый


Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Вставляете в поле процедуру обработка выбора в ней пишите

Процедура Реквизит1ОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Если ВыбранноеЗначение = Перечисления.ЮрФизЛицо.ФизЛицо Тогда
ЭлементыФормы.Реквизит1.ЦветФонаПоля= WebЦвета.Красный;
ИначеЕсли ВыбранноеЗначение = Перечисления.ЮрФизЛицо.ЮрЛицо Тогда
ЭлементыФормы.Реквизит1.ЦветФонаПоля = WebЦвета.Зеленый;
КонецЕсли;
КонецПроцедуры
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
это пример)
Тазовод)

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
сделал но теперь ругается: {Документ.ПеремещениеТоваров.Форма.ФормаДокумента.Форма(1790,1)}: Неопознанный оператор
<<?>><span style="white-space: pre;">    </span>Если ВыбранноеЗначение = Перечисления.СостояниеТовара.ВПути Тогда (Проверка: Толстый клиент (обычное приложение))

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
<<?>><span style="white-space: pre;">    </span>
что это?
выложите всю процедуру либо обработку - скажу что не так
Тазовод)

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Процедура СостояниеТранспортировкиОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
   
<span style="white-space: pre;">    </span>Если ВыбранноеЗначение = Перечисления.СостояниеТовара.ВПути Тогда
<span style="white-space: pre;">    </span><span style="white-space: pre;">    </span>ЭлементыФормы.СостояниеТранспортировки.ЦветФонаПоля = WebЦвета.Красный;
<span style="white-space: pre;">    </span>ИначеЕсли ВыбранноеЗначение = Перечисления.СостояниеТовара.Доставлен Тогда
<span style="white-space: pre;">    </span><span style="white-space: pre;">    </span>ЭлементыФормы.СостояниеТранспортировки.ЦветФонаПоля = WebЦвета.Зеленый;
<span style="white-space: pre;">    </span>КонецЕсли;
КонецПроцедуры

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
<span style="white-space: pre;">    </span>
что это??
Тазовод)

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
должно быть вот так
Процедура СостояниеТранспортировкиОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
 Если ВыбранноеЗначение = Перечисления.СостояниеТовара.ВПути Тогда
        ЭлементыФормы.СостояниеТранспортировки.ЦветФонаПоля = WebЦвета.Красный;
 ИначеЕсли ВыбранноеЗначение = Перечисления.СостояниеТовара.Доставлен Тогда
        ЭлементыФормы.СостояниеТранспортировки.ЦветФонаПоля = WebЦвета.Зеленый;
КонецЕсли;
КонецПроцедуры
Тазовод)

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн lia171

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-23
  • Сайт: 
  • Профессия: Ученик 1С
Светлана подскажите еще возможно ли в табличном поле создать иеррархию, что бы просмотр был в виде дерева?


Теги:
 

Не работают поля "налоговый" и "бухгалтерский"

Автор oleg_e1Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 2477
Последний ответ 31 Дек 2011, 11:36
от AntonB
Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6875
Последний ответ 24 Ноя 2014, 12:21
от gigson
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4203
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3240
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8540
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
AIFrame
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 128
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal