Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 04:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отчет среднего заработка  (Прочитано 5250 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток!!! подскажите как исправить ошибку {Форма.РасчетСреднегоЗаработка.Форма(29)}: Значение не является значением объектного типа (Количество)
Кол = ДопСписок.Количество();


При формирование отчета, выскакивает ошибка. В конфигураторе когда код проверяешь на ошибки, пишет ошибок не обнаружено!!!

1С:Предприятие 8.2 (8.2.15.301) Конфигурация Зарплата и Управление Персоналом.

Процедура РасчетСреднегоЗаработка(ТабДок, КонецПериодаРегистрации, Орг, ПериодРегистрации, ПодОрг) Экспорт
Если Не ЗначениеЗаполнено(Список) Тогда

СписокИскл = ЗаполнитьСписокИскл(ОбщегоНазначения.ПустоеЗначение(СписокИскл), "");

Иначе СписокИскл = Список;                     
КонецЕсли;

Макет = ОтчетОбъект.ПолучитьМакет("РасчетСреднегоЗаработка");
//Найти список исключаемых фамилий, т.е. те которые были уволены до заданного числа
СписокИсклФИО = Новый СписокЗначений;
СписокИсклФИО.Добавить(Справочники.ФизическиеЛица.ПустаяСсылка());
Если ИсключатьУволенных Тогда

Запрос = Новый Запрос;

Если Подразделение Тогда
ДопУсловие =    " И ПодразделениеОрганизации = &ПодОрг)";
Иначе ДопУсловие = ")";
КонецЕсли; 

запрос.Текст = "ВЫБРАТЬ
               | РаботникиОрганизацийСрезПоследних.Физлицо
               |ИЗ
               | РегистрСведений.РаботникиОрганизаций.СрезПоследних(
               | ,
               | ПричинаИзмененияСостояния = &Уволен
               |     И Организация = &Орг"+ДопУсловие+
               "      КАК РаботникиОрганизацийСрезПоследних
               |ГДЕ
               | РаботникиОрганизацийСрезПоследних.Период <= &Период";
запрос.УстановитьПараметр("Уволен",Перечисления.ПричиныИзмененияСостояния.Увольнение);
запрос.УстановитьПараметр("Период", КонецДня(ДатаИскл));
запрос.УстановитьПараметр("Орг", Орг);
запрос.УстановитьПараметр("ПодОрг", ПодОрг);
Выборка = запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
СписокИсклФИО.Добавить(Выборка.Физлицо);
КонецЦикла;
КонецЕсли;

//Отбор по подразделением. Выбор тех фамилей которые работают на заданном подразделении предприятия
УсловияОснНач ="";
УсловияДопНач ="";
Если Подразделение Тогда
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | РаботникиОрганизацийСрезПоследних.Физлицо КАК Физлицо
               |ИЗ
               | РегистрСведений.РаботникиОрганизаций.СрезПоследних(, ) КАК РаботникиОрганизацийСрезПоследних
               |ГДЕ
               | РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации = &ПодОрг
               |
               |УПОРЯДОЧИТЬ ПО
               | Физлицо
               |АВТОУПОРЯДОЧИВАНИЕ";
Запрос.УстановитьПараметр("ПодОрг", ПодОрг);
Выборка = Запрос.Выполнить().Выбрать();
ФамилииПоПодразделениям = Новый СписокЗначений;
Пока Выборка.Следующий() Цикл

ФамилииПоПодразделениям.Добавить(Выборка.Физлицо);

КонецЦикла;
УсловияОснНач = " И ОсновныеНачисленияРаботниковОрганизации.ФизЛицо в (&ФИО)";
УсловияДопНач = " И ДополнительныеНачисленияРаботниковОрганизации.ФизЛицо в (&ФИО)";

КонецЕсли;

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ВложенныйЗапрос.ФизЛицо КАК ФизЛицо,
| ВложенныйЗапрос.ПодразделениеОрганизации,
| ВложенныйЗапрос.ПериодРегистрации КАК РасчетныйПериод,
| ВложенныйЗапрос.ВидРасчета,
| ВложенныйЗапрос.ОтработаноДней КАК ОтработаноДней,
| ВложенныйЗапрос.ОтработаноЧасов КАК ОтработаноЧасов,
| ВложенныйЗапрос.Начисления КАК Начисления
|ИЗ
| (ВЫБРАТЬ
| ОсновныеНачисленияРаботниковОрганизации.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
| ОсновныеНачисленияРаботниковОрганизации.ФизЛицо КАК ФизЛицо,
| ОсновныеНачисленияРаботниковОрганизации.ПериодРегистрации КАК ПериодРегистрации,
| ОсновныеНачисленияРаботниковОрганизации.ВидРасчета КАК ВидРасчета,
| ОсновныеНачисленияРаботниковОрганизации.ОтработаноДней КАК ОтработаноДней,
| ОсновныеНачисленияРаботниковОрганизации.ОтработаноЧасов КАК ОтработаноЧасов,
| ОсновныеНачисленияРаботниковОрганизации.ОтработаноДней + ОсновныеНачисленияРаботниковОрганизации.УчитываемыеДни КАК УчитываемыеДни,
| ОсновныеНачисленияРаботниковОрганизации.ОтработаноЧасов + ОсновныеНачисленияРаботниковОрганизации.УчитываемыеЧасы КАК УчитываемыеЧасы,
| ОсновныеНачисленияРаботниковОрганизации.Результат КАК Начисления
| ИЗ
| РегистрРасчета.ОсновныеНачисленияРаботниковОрганизаций КАК ОсновныеНачисленияРаботниковОрганизации
| ГДЕ
| ОсновныеНачисленияРаботниковОрганизации.ПериодРегистрации МЕЖДУ &ПериодРегистрации И &КонецПериодаРегистрации
| И ОсновныеНачисленияРаботниковОрганизации.Организация = &Орг
| "+УсловияОснНач+

"
| ОБЪЕДИНИТЬ ВСЕ
|
| ВЫБРАТЬ
| ДополнительныеНачисленияРаботниковОрганизации.ПодразделениеОрганизации,
| ДополнительныеНачисленияРаботниковОрганизации.ФизЛицо,
| НАЧАЛОПЕРИОДА(ДополнительныеНачисленияРаботниковОрганизации.ПериодРегистрации, МЕСЯЦ),
| ДополнительныеНачисленияРаботниковОрганизации.ВидРасчета,
| 0,
| 0,
| 0,
| 0,
| ДополнительныеНачисленияРаботниковОрганизации.Результат
| ИЗ
| РегистрРасчета.ДополнительныеНачисленияРаботниковОрганизаций КАК ДополнительныеНачисленияРаботниковОрганизации
| ГДЕ
| ДополнительныеНачисленияРаботниковОрганизации.ПериодРегистрации МЕЖДУ &ПериодРегистрации И &КонецПериодаРегистрации
| И ДополнительныеНачисленияРаботниковОрганизации.Организация = &Орг
|"+УсловияДопНач+

"
| ) КАК ВложенныйЗапрос
|ГДЕ
| ВложенныйЗапрос.Начисления > 0
| И (НЕ ВложенныйЗапрос.ВидРасчета В (&СписокИскл))
| И (НЕ ВложенныйЗапрос.ФизЛицо В (&СписокИсклФИО))
|
|
|УПОРЯДОЧИТЬ ПО
| ФизЛицо,
| РасчетныйПериод
|ИТОГИ
| СУММА(ОтработаноДней),
| СУММА(ОтработаноЧасов),
| СУММА(Начисления)
|ПО
| ФизЛицо
|АВТОУПОРЯДОЧИВАНИЕ";

Запрос.УстановитьПараметр("КонецПериодаРегистрации", КонецДня(КонецПериодаРегистрации));
Запрос.УстановитьПараметр("Орг", Орг);
Запрос.УстановитьПараметр("ПериодРегистрации", НачалоДня(ПериодРегистрации));
    Запрос.УстановитьПараметр("СписокИскл", СписокИскл);
Запрос.УстановитьПараметр("СписокИсклФИО", СписокИсклФИО);

Если Подразделение Тогда
Запрос.УстановитьПараметр("ФИО", ФамилииПоПодразделениям);
КонецЕсли;

Результат = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьФизЛицо = Макет.ПолучитьОбласть("ФизЛицо");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаФизЛицо = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаФизЛицо.Следующий() Цикл
ОбластьФизЛицо.Параметры.Заполнить(ВыборкаФизЛицо);
Если ВыборкаФизЛицо.ОтработаноЧасов > 0 Тогда
ОбластьФизЛицо.Параметры.Средний = ВыборкаФизЛицо.Начисления / ВыборкаФизЛицо.ОтработаноЧасов;
ОбластьФизЛицо.Параметры.Средний_8 = ВыборкаФизЛицо.Начисления / ВыборкаФизЛицо.ОтработаноЧасов * 8;
КонецЕсли;
ТабДок.Вывести(ОбластьФизЛицо, ВыборкаФизЛицо.Уровень());

ВыборкаДетали = ВыборкаФизЛицо.Выбрать();

Пока ВыборкаДетали.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
ОбластьДетальныхЗаписей.Параметры.РасчетныйПериод = Формат(ВыборкаДетали.РасчетныйПериод, "ДЛФ=DD");

ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());
КонецЦикла;
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);

//}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ
КонецПроцедуры

С Уважением!!!


Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
лучше так вставлю КОД!!!


Процедура РасчетСреднегоЗаработка(ТабДок, КонецПериодаРегистрации, Орг, ПериодРегистрации, ПодОрг) Экспорт
   Если Не ЗначениеЗаполнено(Список) Тогда
   
       СписокИскл = ЗаполнитьСписокИскл(ОбщегоНазначения.ПустоеЗначение(СписокИскл), "");

   Иначе СписокИскл = Список;                     
   КонецЕсли;
      
   Макет = ОтчетОбъект.ПолучитьМакет("РасчетСреднегоЗаработка");
   //Найти список исключаемых фамилий, т.е. те которые были уволены до заданного числа
   СписокИсклФИО = Новый СписокЗначений;
   СписокИсклФИО.Добавить(Справочники.ФизическиеЛица.ПустаяСсылка());
   Если ИсключатьУволенных Тогда
   
      Запрос = Новый Запрос;
      
      Если Подразделение Тогда
         ДопУсловие =    " И ПодразделениеОрганизации = &ПодОрг)";
      Иначе ДопУсловие = ")";   
      КонецЕсли; 
      
      запрос.Текст = "ВЫБРАТЬ
                     |   РаботникиОрганизацийСрезПоследних.Физлицо
                     |ИЗ
                     |   РегистрСведений.РаботникиОрганизаций.СрезПоследних(
                     |      ,
                     |      ПричинаИзмененияСостояния = &Уволен
                     |          И Организация = &Орг"+ДопУсловие+
                     "           КАК РаботникиОрганизацийСрезПоследних
                     |ГДЕ
                     |   РаботникиОрганизацийСрезПоследних.Период <= &Период";
      запрос.УстановитьПараметр("Уволен",Перечисления.ПричиныИзмененияСостояния.Увольнение);
      запрос.УстановитьПараметр("Период", КонецДня(ДатаИскл));
      запрос.УстановитьПараметр("Орг", Орг);
      запрос.УстановитьПараметр("ПодОрг", ПодОрг);
      Выборка = запрос.Выполнить().Выбрать();
      Пока Выборка.Следующий() Цикл
         СписокИсклФИО.Добавить(Выборка.Физлицо);
      КонецЦикла;   
   КонецЕсли;
   
   //Отбор по подразделением. Выбор тех фамилей которые работают на заданном подразделении предприятия
   УсловияОснНач ="";
   УсловияДопНач ="";
   Если Подразделение Тогда
      Запрос = Новый Запрос;
      Запрос.Текст = "ВЫБРАТЬ
                     |   РаботникиОрганизацийСрезПоследних.Физлицо КАК Физлицо
                     |ИЗ
                     |   РегистрСведений.РаботникиОрганизаций.СрезПоследних(, ) КАК РаботникиОрганизацийСрезПоследних
                     |ГДЕ
                     |   РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации = &ПодОрг
                     |
                     |УПОРЯДОЧИТЬ ПО
                     |   Физлицо
                     |АВТОУПОРЯДОЧИВАНИЕ";
      Запрос.УстановитьПараметр("ПодОрг", ПодОрг);
      Выборка = Запрос.Выполнить().Выбрать();
      ФамилииПоПодразделениям = Новый СписокЗначений;
      Пока Выборка.Следующий() Цикл
      
          ФамилииПоПодразделениям.Добавить(Выборка.Физлицо);
      
       КонецЦикла;
       УсловияОснНач = " И ОсновныеНачисленияРаботниковОрганизации.ФизЛицо в (&ФИО)";
       УсловияДопНач = " И ДополнительныеНачисленияРаботниковОрганизации.ФизЛицо в (&ФИО)";

   КонецЕсли;
   
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ВложенныйЗапрос.ФизЛицо КАК ФизЛицо,
   |   ВложенныйЗапрос.ПодразделениеОрганизации,
   |   ВложенныйЗапрос.ПериодРегистрации КАК РасчетныйПериод,
   |   ВложенныйЗапрос.ВидРасчета,
   |   ВложенныйЗапрос.ОтработаноДней КАК ОтработаноДней,
   |   ВложенныйЗапрос.ОтработаноЧасов КАК ОтработаноЧасов,
   |   ВложенныйЗапрос.Начисления КАК Начисления
   |ИЗ
   |   (ВЫБРАТЬ
   |      ОсновныеНачисленияРаботниковОрганизации.ПодразделениеОрганизации КАК ПодразделениеОрганизации,
   |      ОсновныеНачисленияРаботниковОрганизации.ФизЛицо КАК ФизЛицо,
   |      ОсновныеНачисленияРаботниковОрганизации.ПериодРегистрации КАК ПериодРегистрации,
   |      ОсновныеНачисленияРаботниковОрганизации.ВидРасчета КАК ВидРасчета,
   |      ОсновныеНачисленияРаботниковОрганизации.ОтработаноДней КАК ОтработаноДней,
   |      ОсновныеНачисленияРаботниковОрганизации.ОтработаноЧасов КАК ОтработаноЧасов,
   |      ОсновныеНачисленияРаботниковОрганизации.ОтработаноДней + ОсновныеНачисленияРаботниковОрганизации.УчитываемыеДни КАК УчитываемыеДни,
   |      ОсновныеНачисленияРаботниковОрганизации.ОтработаноЧасов + ОсновныеНачисленияРаботниковОрганизации.УчитываемыеЧасы КАК УчитываемыеЧасы,
   |      ОсновныеНачисленияРаботниковОрганизации.Результат КАК Начисления
   |   ИЗ
   |      РегистрРасчета.ОсновныеНачисленияРаботниковОрганизаций КАК ОсновныеНачисленияРаботниковОрганизации
   |   ГДЕ
   |      ОсновныеНачисленияРаботниковОрганизации.ПериодРегистрации МЕЖДУ &ПериодРегистрации И &КонецПериодаРегистрации
   |      И ОсновныеНачисленияРаботниковОрганизации.Организация = &Орг
   | "+УсловияОснНач+
   
   "
   |   ОБЪЕДИНИТЬ ВСЕ
   |   
   |   ВЫБРАТЬ
   |      ДополнительныеНачисленияРаботниковОрганизации.ПодразделениеОрганизации,
   |      ДополнительныеНачисленияРаботниковОрганизации.ФизЛицо,
   |      НАЧАЛОПЕРИОДА(ДополнительныеНачисленияРаботниковОрганизации.ПериодРегистрации, МЕСЯЦ),
   |      ДополнительныеНачисленияРаботниковОрганизации.ВидРасчета,
   |      0,
   |      0,
   |      0,
   |      0,
   |      ДополнительныеНачисленияРаботниковОрганизации.Результат
   |   ИЗ
   |      РегистрРасчета.ДополнительныеНачисленияРаботниковОрганизаций КАК ДополнительныеНачисленияРаботниковОрганизации
   |   ГДЕ
   |      ДополнительныеНачисленияРаботниковОрганизации.ПериодРегистрации МЕЖДУ &ПериодРегистрации И &КонецПериодаРегистрации
   |      И ДополнительныеНачисленияРаботниковОрганизации.Организация = &Орг
   |"+УсловияДопНач+
   
   "
   | ) КАК ВложенныйЗапрос
   |ГДЕ
   |   ВложенныйЗапрос.Начисления > 0
   |   И (НЕ ВложенныйЗапрос.ВидРасчета В (&СписокИскл))
   |   И (НЕ ВложенныйЗапрос.ФизЛицо В (&СписокИсклФИО))
   |
   |
   |УПОРЯДОЧИТЬ ПО
   |   ФизЛицо,
   |   РасчетныйПериод
   |ИТОГИ
   |   СУММА(ОтработаноДней),
   |   СУММА(ОтработаноЧасов),
   |   СУММА(Начисления)
   |ПО
   |   ФизЛицо
   |АВТОУПОРЯДОЧИВАНИЕ";

   Запрос.УстановитьПараметр("КонецПериодаРегистрации", КонецДня(КонецПериодаРегистрации));
   Запрос.УстановитьПараметр("Орг", Орг);
   Запрос.УстановитьПараметр("ПериодРегистрации", НачалоДня(ПериодРегистрации));
    Запрос.УстановитьПараметр("СписокИскл", СписокИскл);
   Запрос.УстановитьПараметр("СписокИсклФИО", СписокИсклФИО);
   
   Если Подразделение Тогда
      Запрос.УстановитьПараметр("ФИО", ФамилииПоПодразделениям);
   КонецЕсли;   

   Результат = Запрос.Выполнить();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
   ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
   ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
   ОбластьФизЛицо = Макет.ПолучитьОбласть("ФизЛицо");
   ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

   ТабДок.Очистить();
   ТабДок.Вывести(ОбластьЗаголовок);
   ТабДок.Вывести(ОбластьШапкаТаблицы);
   ТабДок.НачатьАвтогруппировкуСтрок();

   ВыборкаФизЛицо = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

   Пока ВыборкаФизЛицо.Следующий() Цикл
      ОбластьФизЛицо.Параметры.Заполнить(ВыборкаФизЛицо);
      Если ВыборкаФизЛицо.ОтработаноЧасов > 0 Тогда
         ОбластьФизЛицо.Параметры.Средний = ВыборкаФизЛицо.Начисления / ВыборкаФизЛицо.ОтработаноЧасов;
         ОбластьФизЛицо.Параметры.Средний_8 = ВыборкаФизЛицо.Начисления / ВыборкаФизЛицо.ОтработаноЧасов * 8;
      КонецЕсли;
      ТабДок.Вывести(ОбластьФизЛицо, ВыборкаФизЛицо.Уровень());

      ВыборкаДетали = ВыборкаФизЛицо.Выбрать();

      Пока ВыборкаДетали.Следующий() Цикл
         ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
         ОбластьДетальныхЗаписей.Параметры.РасчетныйПериод = Формат(ВыборкаДетали.РасчетныйПериод, "ДЛФ=DD");
         
         ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());
      КонецЦикла;
   КонецЦикла;

   ТабДок.ЗакончитьАвтогруппировкуСтрок();
   ТабДок.Вывести(ОбластьПодвалТаблицы);
   ТабДок.Вывести(ОбластьПодвал);

   //}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ
КонецПроцедуры

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
вот код функции

Функция ЗаполнитьСписокИскл(ДопСписок, Текст) Экспорт;

СписокИскл = Новый СписокЗначений;
СписокИскл.Добавить(ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОплатаПоСреднему);
СписокИскл.Добавить(ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОплатаПоСреднемуБЛ);
СписокИскл.Добавить(ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОплатаПоСреднемуОтп);
СписокИскл.Добавить(ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОтпускПоБеременностиИРодам);
СписокИскл.Добавить(ПланыВидовРасчета.ОсновныеНачисленияОрганизаций.ОтпускПоУходуЗаРебенкомДо3ЛетБезОплаты);
СписокИскл.Добавить(ПланыВидовРасчета.ДополнительныеНачисленияОрганизаций.КомпенсацияОтпуска);
СписокИскл.Добавить(ПланыВидовРасчета.ДополнительныеНачисленияОрганизаций.НайтиПоНаименованию("Возмещение за выпуск платежных карт"));

Если ЗначениеЗаполнено(ДопСписок) Тогда
  Кол = ДопСписок.Количество();       <------ //вот где ошибка!

  Для л=0 по кол-1 цикл
   СписокИскл.Добавить(ДопСписок[л].Значение);
  КонецЦикла;
КонецЕсли;
Список = СписокИскл;
ЭлементыФормы.ПолеВвода2.Значение = Текст;
Возврат Список;
КонецФункции

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
конец кода


Если ЗначениеЗаполнено(ДопСписок) Тогда
      Кол = ДопСписок.Количество();
      
      Для л=0 по кол-1 цикл
         СписокИскл.Добавить(ДопСписок[л].Значение);
      КонецЦикла;   
   КонецЕсли;
   Список = СписокИскл;
   ЭлементыФормы.ПолеВвода2.Значение = Текст;
   Возврат Список;
КонецФункции

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
1С - ИНТЕРПРЕТАТОР.
На некоторые ошибки натыкается непосредственно при выполнении кода...
Ставьте на это место точку останова и смотрите какого типа у вас "ДопСписок"...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Тип Значение

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
не бывает такого типа...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Поставил и ни че не показал, походу не определен тип

Оффлайн СветланаCC

  • Модератор
  • *****
  • Сообщений: 295
  • РЕПУТАЦИЯ: 46
  • КПД: 16%
  • Я человек творческий, что хочу - то и творю))
  • Регистрация: 2010-11-03
  • Сайт: 
  • Профессия: Программист 1С
Ставите точку останова на строчке
Кол = ДопСписок.Количество();
и смотрите какого типа ДопСписок, возможно он не определен, тогда будет стоять значение НЕОПРЕДЕЛЕНО
Тазовод)

Оффлайн ls600

  • ****
  • Сообщений: 322
  • РЕПУТАЦИЯ: 20
  • КПД: 6%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
Значение НЕ ОПРЕДЕЛЕНО не стоит, пусто!
.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 214
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal